Italo Jurisato Junior

Nf-E E Nfc-E Versão 3.10

498 posts in this topic

Estive olhando a pasta schemas do demo da NFe e ele está usando a versão 3.00. Sou de SP e por enquanto meus clientes usam apenas NFe e cupom fiscal (maquininha ECF Daruma/Bematech/Epson). Posso atualizar meus clientes em produção e deixá-los utilizando para NFe o schema 3.00? Eu poderia também atualizá-los e deixá-los emitindo a NFe com o schema 3.10? Estou meio perdido, para emissão de NFe existe alguma diferença entre a versão 3.00 e 3.10 aqui em SP?

Share this post


Link to post
Share on other sites

Boa noite Atilio,

 

Em vigencia em todos os Estados brasileiros a versão da NF-e é 2.00.

 

Em vigencia nos Estados participantes do projeto piloto da NFC-e a versão é 3.00.

 

Como o layout do XML de ambos os modelos de documentos fiscais, ou seja, NF-e e NFC-e é o mesmo, este ano a versão de ambos passa a ser 3.10 

 

Resumindo:

 

NF-e passa de 2.00 para 3.10

 

e

 

NFC-e passa de 3.00 para 3.10

 

Favor ficar ler as Notas Técnicas que estão disponiveis no Portal Nacional da NF-e, para saber as novidades, ou seja, novos campos opcionais e obrigatórios.

Share this post


Link to post
Share on other sites

Bom dia alguém já conseguiu autorizar uma nfe de DI na versão 3.10 no web service de são paulo,se possível por favor posta o xml , pois estou tentando mas da erro 999 (não catalogado),Obrigado.

1 person likes this

Share this post


Link to post
Share on other sites

Boa tarde Marcos,

 

Os webservices da SEFAZ-SP já estão recepcionando XML na versão 3.10, só não sei se esta 100%.

 

Recebi um e-mail de um colega, informando que conseguiu o protocolo de autorização de uma NF-e na versão 3.10 enviada para a SEFAZ-SP.

 

NF-e enviada hoje 04/02/2014 as 14:07

Share this post


Link to post
Share on other sites

Boa Tarde,

 

Alguém consegui emitir NF-e em Minas Gerais ? 

Estou com problema de WebServices.

 

Obrigado

Share this post


Link to post
Share on other sites

Bom dia a todos!!!

 

Aqui no RS estou conseguindo utilizar o ambiente de produção na versão 3.10 da NFC-e tranquilamente, porém quando tento cancelar a NFC-e me vem o seguinte Retorno :  "cancNFe_v3.10.xsd não encontrado" já procurei por este schema em todos os lugares possíveis, inclusive baixei os schemas no Sefaz/RS e não o encontrei, alguém saberia me informar onde estou errando :

 

 

Grato

Carlos H. S. Teles

Share this post


Link to post
Share on other sites

Boa tarde Carlos,

 

O motivo é simples.

 

Esse Schema "cancNFe_v2.00" era utilizado para o cancelamento normal de uma NF-e agora o cancelamento é por evento.

 

E a versão dos schemas referentes a eventos tanto da NF-e quanto da NFC-e ainda é 1.00

Share this post


Link to post
Share on other sites

Igor, boa tarde.

MG ainda não foi implementado.

Segue resposta deles
 

Senhor (a),

Segue parecer da superintendência responsável:

A NT2013/005 divulgou especificamente as funcionalidades opcionais que serão disponibilizadas pelas SEFAZ para o serviço de autorização de uso da NF-e; as alterações necessárias para a migração da versão "2.00" para a versão 3.10 do leiaute da NF-e e as alterações em regras de validação, principalmente aquelas vinculadas aos novos campos ou a novos controles, melhorando a qualidade da informação prestada pelas empresas e mantida pelas SEFAZ.

A atualização do leiaute da NF-e para versão 3.10 ficou assim definida:

Ambiente de Homologação: 03/02/2014 WS que já aceitam mensagem da versão 3.10: GO, RS e SVRS Ambiente de produção...: 10/03/2014 Prazo final de uso da versão 2.00: 01/12/2014.

A partir desta data não será mais possível autorizar NF-e com o leiaute da versão 2.00

A SEFAZ/MG está concluindo os testes para disponibilização dos Web Service. 

Share this post


Link to post
Share on other sites

Ola pessoal boa tarde, estou testando a versão 310 NFE, mas estou recebendo esta mensagem de erro qdo estou enviando a nota, alguem poderia me dar uma luz, ja atualizei o ACBR, Schemas, recompilei os pacotes do Acbr e nada.

 

TAG:<det nItem="1"><imposto><ICMS><ICMS00> ID:N16/pICMS(Alíquota do Imposto) - Tamanha maior que o máximo permitido [18].

 

No XML a tag esta fiscando assim

 

-<imposto>
    <vTotTrib>0.73</vTotTrib>
   -<ICMS>
      -<ICMS00>
          <orig>0</orig>
          <CST>00</CST>
          <modBC>3</modBC>
          <vBC>1.89</vBC>
          <pICMS>18.0000</pICMS>
          <vICMS>0.34</vICMS>
      </ICMS00>

 

Desde ja agradeço a atenção de todos

 

Luciano

Edited by Luciano_Deltress

Share this post


Link to post
Share on other sites

Boa tarde Luciano,

 

Segundo o manual, na versão 3.10 algumas TAGs como por exemplo a pICMS tem o tamanho de 3v2-4, isso significa que são 3 inteiro e 2 ou 4 decimais.

 

Pois bem, algumas SEFAZ estão preparadas para receber esse valor com 2 ou 4 casas decimais e outras não fizeram essa alteração, logo só aceitam com 2 casas decimais.

 

O que fazer neste caso.

 

Primeiro entrar em contato com a SEFAZ e questiona-los a respeito dessa mudança.

Segundo criar um mecanismo de identificar as UF e determinar a quantidade de casas decimais para a TAG pICMS e as demais que também estão nessa situação.

Share this post


Link to post
Share on other sites

Ola Italo boa tarde, muito obrigado pela atenção amigo, tentei enviar com 2 casas ai não deu mais erro. mas,

 

Aproveitando estou com um projeto funcionando perfeito na versão 2.00, simplesmente peguei atualizei o ACBR e estou comecei os testes, recompilei o projeto e apenas setei o Modelo e a Versão e estou tentando enviar a nota, primeiramente deu esse erro que passei, ai mudei no componente para gerar com 2 casas e tentei enviar, Simplesmente nao deu mensagem de erro, gerou o XML, não gravou o protocolo, não gravou nas pastas ja de costume, e qdo tento consultar pela chave me retorna Rejeicao: Cabecalho - Versao do arquivo XML superior a Versao vigente.

Sera que estou fazendo algo errado? ou era pra funcionar normal. ou SEFAZ ainda não esta 100%

 

Desde ja agradeço novamente a atenção...

 

Luciano...

Share this post


Link to post
Share on other sites

Ola Italo bom dia, Estou testando com a UF SP mesmo pq disseram que a partir de 03/02/2014 ja estaria em fucionamento a Homologação.

 

Luciano.

Share this post


Link to post
Share on other sites

Ola Italo boa tarde, me desculpa te perturbar, mas vc conseguiu ver algo que eu possa estar fazendo errado.

 

Muito Obrigado...

 

Luciano.

Share this post


Link to post
Share on other sites

Boa tarde Luciano,

 

Por não ter um certificado valido de uma empresa de São Paulo, não tenho como realizar os testes, apenas estou realizando alterações nos fontes do componente baseado em relatos dos colegas.

Share this post


Link to post
Share on other sites

Ah ta, blz então vamos aguardar mais alguns amigos testarem na UF SP.

 

Só para vc ter uma ideia, qdo eu peço para consultar o WEBService ele ja me da a Rejeicao: Cabecalho - Versao do arquivo XML superior a Versao vigente. Agora volto para Versão 2.00, volta a funcionar tudo perfeito.

 

Vou tentar depurar aqui e ve se consigo descobrir algo e qq coisa te reporto.

 

Muito Obrigado...

 

Luciano...

Share this post


Link to post
Share on other sites

Boa noite Luciano,

 

Se o enviar funciona, mas o consultar não, isso significa que as alterações necessárias não foram completadas pela SEFAZ.

 

A minha sugestão, é que você entre em contato com a SEFAZ e coloque para eles o problema que você esta enfrentando.

Share this post


Link to post
Share on other sites

Boa tarde Marcos,

 

Muito obrigado pela informação.

 

Notei que alem de incluirem os novos webservices eles alteram todas as URLs para esta nova versão.

Share this post


Link to post
Share on other sites

Olá amigos, acabei de efetuar um teste no ambiente de homologação no sefaz de SÃO PAULO, não obtive sucesso, retornou a mensagem "Rejeição: Cabeçalho - "Versão do arquivo XML superior a versão vigente."

 

caso alguém tenha novidades, nos informe pf.

Share this post


Link to post
Share on other sites

Ola Italo boa noite, baixei hj de manha os fontes novamente, compilei td certinho, a consulta do Webservice voltou a funcionar, e não esta dando mais a mensagem de versão, mas qdo tento enviar nao esta indo, estou postando aqui, se mais algum amigo tiver testando o envio no Estado de SP e puder ir reportando os problemas, agradeço.

 

Desde ja agradeço a todos...

 

Luciano...

Share this post


Link to post
Share on other sites

Estou tendo o mesmo problema ao enviar, amanhã posto a mensagem que esta dando. Também estou com o fonte atualizado

Edited by ThiagoRS

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Atenção !!  Este tópico está sem resposta a mais de 120 dias.