Jump to content

sergio_api

Membros Pro
  • Posts

    69
  • Joined

  • Last visited

Everything posted by sergio_api

  1. Show. Vi que tem um demo em Lazarus, vou dar uma olhada. Obrigado !
  2. Olá pessoal. Vi na pasta Fontes que já consta o ACBrPIXCD e, se não me engano, é ele que fará a integração com a Shippay, correto ? Ele já está finalizado e podemos usar ou ainda demanda de finalização ? Não achei nenhum tópico aqui no fórum sobre esse componente especificamente. Grande abraço a todos.
  3. Italo, muito obrigado. Vocês são incríveis. Mais uma vez obrigado. Agora, bora implementar !!!!!
  4. Obrigado Italo. Agradeço muito sua dedicação. Abraços.
  5. Bom dia. Conforme solicitado no papo pro no Discord, segue o manual de integração do provedor FGMAISS de Três Rios / RJ Abraços. Integração FgMaiss.rar
  6. Uma coisa que esqueci de colocar no primeiro post. Estou no ambiente de Homologação.
  7. Boa tarde José. Sim, eu não estou emitindo, mas ao Gerar, Validar e Assinar eu já deveria ter a chave. Tanto que o XML vem certinho ... Verificando aqui, concordo que AcbrNFe1.NotasFiscais.Items[0].NFe.procNFe.nProt deve vir vazia, pois não há protocolo de entrega. Mas a chave é gerada pelo componente.
  8. Boa tarde pessoal. Estou gerando uma NFCe e quando gero em contingência as tags AcbrNFe1.NotasFiscais.Items[0].NFe.procNFe.chNFe e AcbrNFe1.NotasFiscais.Items[0].NFe.procNFe.nProt vem vazias. Enviando em modo normal elas retornam os valores preenchidos. Estou usando AcbrNFe1.NotasFiscais.GerarNFe, AcbrNFe1.NotasFiscais.Assinar, AcbrNFe1.NotasFiscais.Validar e AcbrNFe1.GravarXML antes de ler esses valores. Estou reescrevendo meu emissor pois ele estava baseado em códigos mais antigos dos exemplos do ACBr. Existe algum "manual de boas práticas pra emissão de NFe" com ACBr ? Obrigado a todos.
  9. Então ! Não houve alteração no xml. Simplesmente fiz o seguinte. Na unit ACBrDFeSSl, function TDFeSSl.Validar (linha 1442) coloquei Result := True e comentei o FSSLXmlSignClass.Validar. Com isso a nota foi enviada. Claro que já desfiz a alteração, foi só pra efetuar o teste que eu precisava pro cliente. De qualquer forma, segue o xml gerado em anexo. Se conseguirem descobrir algo, por favor me avisem ... rsrs Mais uma vez, obrigado. 33200510286992000119650100000010881596366355-nfe.xml
  10. Boa tarde pessoal. Obrigado pelas respostas, mas no caso a validação está nos Schemas. Não chega a haver contato com a SEFAZ, então o CSC e o caminho do webservice ainda não foram acionados. Mesmo assim verifiquei o CSC como o Gilson falou, mas não era isso. Como é só um teste de homologação, fiz um POG terrível aqui e retornei true manualmente na validação da schemas. A nota foi enviada para a SEFAZ e validada normalmente. Ou seja, não há erro na estrutura, mas o "leiauteNFe_v4.00.xsd" insistem em informar erro. Vou continuar tentando corrigir, mas por enquanto o tópico pode ser fechado pelos moderadores se desejarem. Obrigado.
  11. Boa tarde pessoal. Não estou conseguindo gerar NFCe em homologação. Dá um erro na validação das Schemas. Já fiz a atualização com a última review do ACBr, mas não resolveu. Apresenta o seguinte erro: "Falha na validação dos dados da nota: 1071 1824 - Element '{http://www.portalfiscal.inf.br/nfe}qrCode': 'http://www4.fazenda.rj.gov.br/consultaNFCe/QRCode?p=33200510286992000119650100000010711899545933|2|2|1|D7506EE93958BAECECB16E561792E35EEA3FC996' is not a valid value of the local atomic type." Fiz uma comparação com o schema de produção e está igual, mas em produção não ocorre esse erro. Agradeço se puderem ajudar. Obrigado.
  12. Foi o que eu imaginei. O set de comandos das duas deve ser diferente. Faz mais sentido manter a mais atual (MP4200). Obrigado pela atenção de todos. Abraços.
  13. Boa tarde a todos. Daniel, estou enviando o arquivo fonte modificado. Luis, obrigado pelo retorno. A minha impressora é uma MP4000 e não uma MP4200. Será possível que os firmwares sejam diferentes ? Não duvido. Talvez por isso funcione em uma e não na outra. A imagem do manual que anexei era da 4200, procurei da 4000 e não encontrei. Se alguém tiver as duas e puder testar ... Minha impressora: Build: Nov 18 2009 MP-4000 TH (Standard) - Versão 2.4 Mais uma vez, obrigado ... ACBrEscBematech.pas
  14. Pessoal, olá. Eu uso o ACBrPosPrinter a bastante tempo mas me deparei com um probleminha. Alguns clientes meus possuem impressoras Bematech e nesses casos a abertura da gaveta não funciona. Eu uso o comando direto (ACBrPosPrinter1.AbrirGaveta) mas mesmo com o uso das Tags não funciona. Fiz os testes usando o Exemplo que vem no ACBr (PosPrinterTeste.exe) e o resultado é o mesmo. Alterei todas as opções possíveis (número da gaveta e tempo) O interessante é que se eu colocar o modelo para ppEscPosEpson a gaveta abre mas, claro, as outras tags não funcionam. A Epson usa o comando ESC p e na Bematech está o ESC v ou o ESC #120 dependendo do número da gaveta. Verifiquei no manual (imagem abaixo) que o padrão ESC/Bema também aceita o comando ESC p. Fiz uma alteração nos fontes do ACBrEscBematech.pas e coloquei o mesmo set de comandos da Epson e funcionou. O único detalhe é que tive que mudar o número da gaveta para 2 no envio do comando para que o parâmetro CharGav usasse #1 em vez de #0; Fiz todos testes em equipamentos físicos (MP4000, Elgin I7 e gaveta Menno). Por enquanto vou deixar meu código alterado, mas gostaria de saber se vocês enfrentam esse mesmo problema ou se, apesar de todos os testes, eu ainda tenha deixado passar alguma configuração. Grande abraço a todos. Sergio
  15. Eu não uso ele, mas acho que você poderia dar uma olhada no ACBR Monitor. Você pode fazer a configuração ESCPOS da sua impressora nele e enviar o TXT para impressão. Como disse, não uso ele, mas creio que tenha como. Acho que será mas prático que copiar para a impressora de rede. Abraços.
  16. Parabéns ! Novidades muito bem vindas
  17. Boa tarde estou com um problema na DistribuicaoDFePorChaveNFe pois no cliente ele está trazendo somente um cabeçalho a nota e quando eu realizo o teste ele traz normalmente mas eu utilizo o Certificado A1 eo cliente A3. Teria alguma diferença? Obrigado pela Atenção
  18. Bom dia pessoal estou uma um problema que quando eu uso esse método DistribuicaoDFePorChaveNFe() algumas notas não são encontradas, alguém já passou por isso ?
  19. Dá uma olhada nesse post aqui. Pode te ajudar. Estou começando a analisar as UNITs dele. Abraços.
  20. Bom dia Toninho. Gostaria de saber se com a mudança do BACEN, em relação a cobrança centralizada, se você precisou alterar algo no seu boleto ou arquivo de remessa. Vou precisar desenvolver para um cliente e a CAIXA indicou que o arquivo de remessa e retorno são os mesmos do boleto no formato CNAB240. Abraços. Sergio.
  21. Boa tarde pessoal alguém esta passando por esse problema? Erro de requisição não enviada 12002 e 12157. Pois meu sistema estava funcionando normalmente ate o dia 17/03 com isso fui realizar uma atualização de rotina do acbr depois disso começou a dar esse erros em certas maquinas não em todas mas a maioria eu vi que teve algumas mudanças no componente NFE mas não fiz nenhuma mudança. Teria alguma coisa nova que eu teria que implementar para esse erro não ocorrer. OBS(As dll foram todas atualizadas, ja foi verificada as rotinas do IE e estão corretas pois funcionava antes) Obrigado pela atenção.
  22. Bom dia. Hoje fui atualizar o Firmware de uma Daruma DR700 da versão L para a L-e para que o QRCode seja impresso. São duas atualizações, da versão L 02.10.01 para a L 02.51.00 e depois para a L-e. A impressora foi ligada em um no-break para evitar interrupção por queda de energia e fiz a primeira atualização. Foi tudo bem, mas na segunda a impressora apagou e agora simplesmente não liga mais. Agora não consigo falar com o suporte da Daruma, o telefone 0800 não existe mais e já adicionei 3 atendentes no Skype que não respondem. Já determinei aqui na empresa que se um cliente tiver Daruma, não faremos mais nenhum tipo de assistência, que mande pra autorizada, pois agora, como o serviço foi feito aqui na empresa vou ter que ressarcir o cliente. Sei que problemas ocorrem, mas o que está me decepcionando mais é a falta de assistência do Suporte, sempre elogiei pois já fui atendido varias vezes, mas de um tempo pra cá está terrível ! Alguém já teve esse problema e conseguiu resolver sem ter que trocar a placa da impressora ? Abraços.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.