Jump to content

botao.pngbotao.png

PARA DEVS E SW. HOUSES
Novos Palestrantes e Patrocinadores confirmados!

dia-do-acbr-online.png  

Saiba Mais

botao.pngbotao.png

botao.pngbotao.png

Ofertas Embarcadero
Descontos de até 35%

Saiba Mais

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


botao.png

beneficios.png

jamil

Usuários SAC
  • Content Count

    365
  • Joined

  • Last visited

  • Days Won

    2

Everything posted by jamil

  1. quanto ao item3 já resolvi realmente pequenos ajustes fazem a diferença... veja a imagem em anexo quanto ao item2 não consegui imprimir qr code via lib na impressora, se poder me orientar onde estou errando..... usei até uma etiqueta maior (imagem 2) quanto ao item1 quando escrevo direto para impressora envio por exemplo hb_utf8tostr( "promoção" ) e imprime corretamente com acento.
  2. Boa Noite, já estou imprimindo em rede em linux usando a libetq, porem esbarrei com tres problemas, 1º: ela (a lib) não está imprimindo palavras acentuadas, com comados diretos consigo imprimir com acentos.... 2º: não tem código para impressão de QR Code... isso é muito importante na emissão de etiqueta.... 3º: se eu mandar uma quantidade relativa de etiquetas para serem impressas via lib ela não imprime o que se comanda a partir da 4 etiqueta no meu caso mandei somente 11 etiquetas diferente e uma certa informação só imprimiu nas 3 primeiras e na 6 sexta etique
  3. @Daniel Simoes Ficou Show agora.... obrigado pela sua Atenção
  4. @Daniel Simoes, testei aqui a nova libetq que voce disponibilizou e imprimiu perfeitamente bem obrigado a equipe...
  5. na impressora esta correto como pode ver na imagem:
  6. montei uma VM, e usei ETQTeste.exe no linux
  7. sim testei o PING chega sim segue o log etq.txt ACBrLibETQ-20200417.log EtqLog.log
  8. ok, mais mesmo a impressora estando em esc/bema codigo da pagina cp850 configurado sw.Básico da impressora usando o programa da Bematech imprime sem assento assim: acbrlib.ini ACBrLibPosPrinter-20200417.log
  9. @Daniel Simoes Espero poder contribuir, e assim resolvemos o problema em questão (assim espero) mesmo que a impressora Bematech Esteja em esc/Pos ..... cp860 , posso alterar Sw.Básico via comando sem utilizar o programa da Bematech exemplo em Decimal (que eu fiz , em uma impressora que era Esc/pos,) 27 64 -> reseta a impressora 29 249 53 0 -> seleciona esc/bema 29 249 55 2 ->cp850
  10. @Daniel Simoes, me desculpe, posso até esta enganado, vou testar aqui, mais esse ajuste pode ser feito via comando, sem precisar entrar no programa da Bematech, dito isso , acredito que quando utilizo ConfigGravarValor("PosPrinter", "PaginaDeCodigo", "2" ) ele já o fassa, ou deveria fazer.
  11. @rafael dias, se retirar a função, fica da seguinte maneira (segue na imagem) hResult := DllCall(::hHandle, DLL_OSAPI, "POS_Imprimir", eString, PulaLinha, DecodificarTags, CodificarPagina, Copias)
  12. sim 192.168.25.72:9100 como disse usei o teste do windows do ACBr para etiqueta e funcionou .... a lib ela não aceita imprimir quando é rede (TCP: ou RAW:)
  13. Só para completar, testei a impressora com o programa de Teste de Etiqueta disponível no Forum e imprimiu via TCP corretamente serviu inclusive para que eu pudesse corrigir alguns erros, mais o problema continua, segue os logs atualizados.... Obrigado acbrlib.ini ACBrLibETQ-20200415.log EtqLog.log
  14. Boa Noite, Hoje comecei a usar a LibEtq, comprei uma impressora Zebra GT800 Ethernet ZPL, porém ela (a lib ) não reconhece na rede ja tentei RAW: / TCP: / o nome instalado no CUPS e nada via programação direta em zpl no meu sistema ela esta imprimindo nos teste que fiz... segue os logs gerados para me dizerem onde Eu posso esta errando obrigado. acbrlib.ini ACBrLibETQ-20200415.log EtqLog.log
  15. Eu enviei como envio todas as escritas que são acentuadas para impressora (seja via Cairo ou EscPos -cp850- ) ou para o Gui (na tela ) uso no caso do nosso exemplo hb_utf8tostr( "emissão" ) e sai acentuado, quando usei esse mesmo processo com a LibPos ela mudou para Emiss[195][163]o
  16. segue... acbrlib.ini ACBrLibPosPrinter-20200414.log
  17. Obrigado @Daniel Simoes perfeito, o invertido só funciona em esc/pos, assim como algumas outras funções da Bematech, vou fazer mais uns teste para ver porque ela não esta acentuando mesmo selecianado cp850. existe previsão para cria o suporte esc/pos para Bematech ?
  18. user o programa da bematech....
  19. mudei para esc/bema, não funcionou, continuou o mesmo problema
  20. sim sim, já havia visto este tópico também nem ali tem a demonstração da impressão do invertido, <in> </in> como eu mostrei usando comando esc/pos direto na impressora funciona assim como os acentos..... só isso, as demais instruções/comandos (negrito, sublinhado, comprimido etc..) estão funcionando perfeitamente na impressora....
  21. Boa Tarde, comecei essa semana a usar a LibPosPrinter no linux junto com o Harbour, não tiver nenhum problema em criar os Metodos para o bom funcionamento da lib. bem encontrei duas dificuldades a primeira foi quando tentei imprimir invertido ( <in> ), não imprimiu, estou mandado o log junto com imagem, segundo mesmos mudando a pagina de codigo não consigo acentuar usando a lib... desde já obrigado... minha impressora é uma bematech MP-4200 TH Equipamentos testados acbrlib.ini ACBrLibPosPrinter-20200413.log
  22. jamil

    MunIBGE

    Boa Tarde, gostaria de sugerir que a pasta MunIBGE, também fosse integrado as pasta do ACBrLib onde elas são necessárias ... (NFe / MDF-e .....) pois estou tendo que Instalar e Desinstalar o ACBrMonitorPlus para pegar essa pasta necessária na Normatização de Municípios nas Libs Obrigado
  23. Resolvido..... Obrigado.....
×
×
  • Create New...