Jump to content

Gustavo R Scarabelot

Membros
  • Posts

    3
  • Joined

  • Last visited

Posts posted by Gustavo R Scarabelot

  1. Boa tarde Italo.

    2 horas atrás, Italo Jurisato Junior disse:

    Você esta usando o DistribuicaoDFe do componente ACBNFe para obter o XML da NF-e ou o do componente ACBrCTe para obter o XML do CT-e?

    Sim, uso os componentes separadamente pra capturar o XML de cada tipo.

    2 horas atrás, Italo Jurisato Junior disse:

    Para obter o XML completo da NF-e se faz necessário enviar o evento de Manifestação do Destinatário, caso contrario você só vai obter o resumo da nota.

    Por outro lado para obter o XML completo do CT-e não se faz necessário enviar nenhum evento, basta o CPF/CNPJ ter sido informado no CT-e como: Remetente, Destinatário, Expedidor, Recebedor, ou Tomador - Outro e as pessoas contidas na lista autXML.

    Referente a isso, também já fazia o tratamento dessas particularidades dentro do sistema.

    O que me chamou a atenção é que entre os dias 10/06 e 22/06 teve um delay de 24 a 48h para que o Ambiente Nacional me disponibilizasse o XML dos CT-es. Sendo que antes era no máximo 3 horas.
    Para os XMLs de NF-es não vi diferença nenhuma.

    Mas agora voltou ao normal a captura dos XMLs dos CT-es.

    Obrigado pela atenção.

    • Like 2
  2. Boa noite pessoal!

    Estou postando uma dúvida pela primeira vez no fórum, então se estiver fazendo algo incorretamente, desculpem o erro de iniciante hehe.

    Tenho um sistema que captura os XMLs dos DFes emitidos contra os CNPJs da empresa. Em média temos 15 CNPJs ativos com movimentação quase que diária.
    Hoje pela manhã um dos nossos usuários relatou que um dos CTes não estava disponível para validação, porém a NFe que ele era vinculado, estava ok no sistema.
    Achei que era alguma falha entre o Sefaz de origem do CTe e o Ambiente Nacional da Receita que as vezes realmente "demora" pra disponibilizar no ambiente nacional.

    Porém nesse caso não era, estava corretamente nos dois ambientes, porém não havia o meu Evento de Ciência da Operação para poder capturar o XML do CTe.
    Busquei se havia algum erro no CTe ou no sistema, mas não encontrei nada. Logo após isso, outros usuários relataram o mesmo problema.

    Fiz uma pesquisa no meu banco de dados e o último CTe capturado foi no dia 12/06, porém o número do NSU do documento é o mesmo do MaxNSU que eu recebo ao usar o procedimento de busca via NSU.

    Vi no fórum do ACBr que nesse dia (12/06)  houve um problema e foi habilitado o modo de contingência, porém pelo que eu vi, os CTes do exemplo foram emitidos no ambiente normal.

    Alguém está passando por uma situação semelhante? Ou sabe se há algum erro no ambiente nacional?

    Obrigado pela atenção.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.