Jump to content

Search the Community

Showing results for tags 'nfse'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Categories

There are no results to display.

Forums

  • Fórum Aberto - ACBr
    • ACBr News
    • Equipamentos testados
    • Base de Conhecimento
    • Dúvidas Gerais sobre o ACBr
    • ACBrSerial
    • ACBrSAT
    • ACBrNFe
    • ACBrMonitor PLUS
    • ACBrDFe
    • ACBrTEFD e Dúvidas sobre TEF
    • ACBrTXT
    • ACBrBoleto
    • ACBrDiversos
    • ACBrTCP
    • ACBrFramework
    • ACBrLIB
    • Dia do ACBr
  • Suporte Pago - SAC
    • Dúvidas gerais
    • ACBrMonitorPLUS
    • NFe/NFCe - Nota Fiscal Eletrônica
    • DFe - Documentos Fiscais Eletrônicos
    • SAT / MFE
    • TEF
    • Boleto
    • ACBrSPED
    • ACBrTXT
    • Paf-ECF
    • Requisitos Fiscais por UF
    • ACBrLIB
  • Outros Assuntos
    • ACBr's Pub
    • Legislação Fiscal e Tributária
    • Object Pascal - Delphi & Lazarus
    • Data Base
    • Classificados
    • Dúvidas não relacionadas ao ACBr

Categories

  • ACBrLib
  • Suporte Pago - SAC
    • ACBrMonitorPLUS - SAC
    • Utilitários - SAC
    • Dia do ACBr 1a edição
    • Dia do ACBr 2a edição
  • Free Download
    • ACBrMonitorPLUS
    • Demos / Testes / Utilitários
    • Apresentações - Palestras

Calendars

  • Eventos - Palestras - Webinars
  • Prazos SEFAZ
  • Community Calendar
  • Feriados Nacionais

Blogs

  • Daniel Simoes' Blog
  • André Ferreira de Moraes
  • Moderadores ACBr
  • Teste de Blog
  • Notícias do ACBr

Categories

  • Suporte Pago - SAC
    • Curso Dominando o ACBrMonitor
    • Webinars
    • Video Aulas
    • Palestras - Dia do ACBr 2a Ediçao
  • Vídeos Abertos
    • Video Aulas
    • Comunicados
    • Dia do ACBr 2a Ediçao
    • Dia do ACBr 1a Ediçao
    • Homologação ACBr
  • Campanhas promocionais

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Skype


Localização


Interesses


CNPJ da Empresa


CPF

Found 664 results

  1. Olá, estamos fazendo o envio das NFS-e na cidade de Capão da Canoa-RS, usando o provedor Betha, estamos informando a tag CondicaoPagamento e as parcelas corretamente, tanto que no xml do rps gerado aparece corretamente essas tags, porém o xml de retorno da nota não vem com essa tag e muito menos imprime no DaNFSe. Se irmos no site da prefeitura e fazermos o download do xml e pdf desta mesma nota gerada pelo nosso sistema, aparece corretamente estes campos. Existe algo que podemos fazer para obter o retorno do xml correto? Segue em anexo os xml's do rps e da nfs-e de retorno obtidos pelo componente do Acbr. O último arquivo anexo ('LoteNfse_543594049509883162.xml'), é o xml da mesma nota porém obtido através do site da prefeitura. 4318070789990400014056000000000000085-nfse.xml 4318070789990400014056000000000000103-rps.xml LoteNfse_543594049509883162.xml
  2. Bom dia, estou tendo alguns problemas quanto ao envio de NFSE, algumas situações que diga-se de passagem, bem curiosas e estranhas que estão causando transtornos em vários transtornos em clientes da empresa que trabalho. Bom vamos para eles: 1 - Em máquina que faço a programação (sistema) não é pedido o certificado quando se envia a nota, eu apenas atribuo o número de série ao componente, e a nota envia. 2 - Quando executo em máquina cliente, é pedido 'n' vezes o certificado, causando outras duas situações: 2.1 - É pedido o certificado de 3 a 4 vezes e a nota envia com sucesso 2.2 - É pedido o certificado 'n' vezes e fica no loop de pedir o certificado toda a hora e a nota não envia 3 - Para tentar resolver o problema, colocamos o sistema em máquina que não era servidor, e fizemos com que uma outra máquina acessa-se essa máquina como servidor, o que ocasionou mais duas situações curiosas: 3.1 -Nas duas máquinas enviaram as notas normais, todas sem problema algum, até um determinado momento (isso aconteceu ontem). Das 8 da manhã, até 16:20 a máquina que estava acessando a nova máquina servidor começou a entrar na situação 2.2 ou seja fica pedindo o certificado 'n' vezes e não sai disso. 3.2 - Na nova máquina servidor é enviado a nota normal sem problema. Alterações que fiz para tentar resolver o problema: 1 - Coloquei a opção visualizar = True (porém não é apresentado nenhuma mensagem, o sistema cai na situação 2.2) 2 - Coloquei os códigos: ACBrNFSe.Configuracoes.Geral.ConsultaLoteAposEnvio := True; ACBrNFSe.Configuracoes.WebServices.AguardarConsultaRet := 5000; // tempo padrão que vai aguardar para consultar após enviar a NF-e ACBrNFSe.Configuracoes.WebServices.IntervaloTentativas := 3000; // Intervalo entre as tentativas de envio ACBrNFSe.Configuracoes.WebServices.Tentativas := 4; // quantidade de tentativas de envio (anteriormente tinha colocado mil vezes o que creio que esteja ocasionando o loop infinito na "pedição" do certificado) ACBrNFSe.Configuracoes.WebServices.AjustaAguardaConsultaRet := False; Porém não tive sucesso. 3 - Código para pegar o certificado: ACBrNFSe.Configuracoes.Certificados.NumeroSerie := qryBuscaParametrosNfseCERTIFICADO_SERIE.AsString; Alguém já passou por isso? Teve problemas semelhantes? Precisava de uma ajuda....
  3. Estou tendo sempre esse retorno quando tento me comunicar com a Tinus a partir de São Gonçalo, já tentei atualizar e reinstalar, e não resolveu, o estranho que minha aplicação compilada de alguns meses atrás (novembro) consegue enviar normalmente, já procurei alguma mudança no log e não encontrei, mesmo o Demo não consegue comunicação, alguém tem alguma ideia do que pode ser?
  4. Estou tendo problemas com a ssl para nota fiscal de servico ginfes estou usando essas configurações, mais fica dando os erros de ssl, como posso resolver obrigado ACBrNFSe1.SSL.SSLType := TSSLType.LT_all; ACBrNFSe1.Configuracoes.Geral.SSLLib := libWinCrypt; ACBrNFSe1.Configuracoes.Geral.SSLCryptLib := cryWinCrypt; ACBrNFSe1.Configuracoes.Geral.SSLHttpLib := httpWinHttp; ACBrNFSe1.Configuracoes.Geral.SSLXmlSignLib := xsMsXml;
  5. Bom dia senhores... estou passando apuro com um erro em um cliente, onde de cada 50 nfse emitidas, 20 da esse erro... e nao tem nada que eu olhe que eu consiga identificar o errro... e nao consigo gerar o erro pra saber como resolver... é exporadico... so acontece no cliente AcBrNFSeGeraLog : ERRO:Erro Interno: 0Erro HTTP: 500
  6. Bom dia, estou tentando emitir uma NFSe para o servidor fisslex, no municipio de pimenta bueno RO, e esta dando a mensagem de "municipio não encontrado". Exista a possibilidade do componente ainda nao atender esse municipio ? caso sim, tem um prazo pra isso acontecer?
  7. Bom dia! hoje uso a rotina abaixo para enviar notas para Belo Horizonte e funciona perfeitamente, estou implantando em um cliente em são paulo, envio a nfse ela fica emitida no site da prefeitura mas não consigo pegar o retorno para atualizar o lote como processado, conto com ajuda de vcs . Obrigado Paulo Sergio ACBrNFSe1.Enviar(dm.cds_consulta_lote.fieldbyname('nro_lote').asinteger,false); dm.cds_lote.close; dm.cds_lote.Params[0].AsInteger := dm.cds_consulta_lote.fieldbyname('id_lote').asinteger; dm.cds_lote.Open; dm.cds_lote.Edit; dm.cds_lote.fieldbyname('status_lote').asstring := ACBrNFSe1.NotasFiscais.Items[0].NFSe.Situacao; dm.cds_lote.post;
  8. boa tarde italo. alguma novidade sobre esse assunto. também vou ter que desenvolver essa NFes para araçatuba. Obrigado
  9. Pessoal, trocamos a pouco tempo para o trunk2 do ACBrNFSe e percebemos que os arquivos de envio e retornos não são mais colocados dentro da pasta 'Ger'. Pesquisando vi que realmente foi retirado... Até não seria problema, mas do jeito que está agora parece que tem alguma configuração errada. Optamos por gerar o 'path mensal', ou seja, os arquivos são agrupados por mês e ano. Só que esses arquivos de envio e retornos que antes era colocados na Ger agora são todos colocados dentro do diretório base. Exemplo, se o diretório de arquivos for 'C:\XML', o componente cria dentro dele o diretório mensal 201806, e dentro do diretório 201806 os diretórios Notas e Recibos. Mas os arquivos de envio e retornos não ficam dentro do diretório mensal 201806, eles ficam todos dentro de C:\XML. É assim mesmo ou estou configurando algo errado?
  10. Bom dia. Usei o FRCE para criar a impressão de uma NFSe de uma cidade que não usa o padrão ABRASF e portanto não tem no ACBR. Deu tudo certo com a criação mas não estou conseguindo fazer com que o filtro de PDF apareça na opção de salvar, mesmo já tendo colocado o componente PDFFilter no relatório. Alguém já passou por isso ou sabe o que pode ser? Obrigado.
  11. Bom dia, Gostaria de saber se alguém já passou pelo seguinte problema, instalei os fontes do ACBr e refiz a instalação da Suite novamente, porem ao arrastar um componente TACBrNFSeDANFSeFR para o DataMobule um Acess Violation é levantado. A solução foi criar o componente em RunTime, porem sempre utilizei o componente em Design Time e nunca tive este problema, não atualizei versão do Delphi nem do Fast Report, o componente TACBrNFeDANFEFR funciona perfeitamente. Se alguém tiver alguma sugestão agradeço Obrigado.
  12. Bom dia, pessoal, sou novo por aqui e estou implementando um código para a emissão de NFSE, vi que existe alguns fontes de exemplo em delphi se entendi direito, gostaria de saber qual link posso fazer o download dos projetos, e se existe algum outro exemplo em outras linguagens. Enfim agradeço a atenção,
  13. Boa tarde senhores, estou tentando usar a função "gerar" para emitir uma nfse, e me deparo com esse erro.... alguem sabe me orientar ? 'SoapAction não definido para: TNFSeGerarNFSe' 791-rps.xml
  14. Boa tarde pessoal do ACBR, Estou com o fonte do ACBR de fevereiro de 2018, e quando tento exportar 1 NFSe, exporta com sucesso, quando tento exportar um lote com umas 5 NFSe, ocorre essa mensagem de erro: Erro Interno: 0 Erro HTTP: 0 exception class ESOAPHTTPException with message 'O tempo limite da operação foi atingido URL: https://homologacao.ginfes.com.br/ServiceGinfesImpl - SOAPAction: "". Quando utilizo fonte do ACBR mais antigo de 2017, o funcionamento está ok. Não posso atualizar o ACBR agora porque não temos mais tempo aqui para testar novamente as possíveis mudanças e por isso preciso corrigir o problema pontualmente. Grata
  15. Boa tarde estou importando um xml de nfse de Paranavaí Servidor Betha e esta pulando a segunda nota. de 154 pula 155 e pega o próximo 156. voltei a revisão da ultima revisao 14590. e voltou a funcionar normal, pode ser que a alteração interferiu no provedor Betha. Obrigado .
  16. Constatei que alguns provedores tem nos dados de contato do tomador o telefone e outros o ddd e o telefone. No mapeamento das classes tem os campos DDD e Telefone e aqui passamos separadamente. Para os provedores que tem XML com DDD e Telefone fica correto, mas por exemplo o provedor BHIss tem somente telefone, e pelo menos em POA eles estão retornando com erro, pois acusa não ter o DDD. Então ajustei o componente para que nos provedores que tem somente a tag Telefone o sistema concatene junto o DDD. Testei e ficou correto. pnfsNFSeW_ABRASFv1.pas pnfsNFSeW_ABRASFv2.pas
  17. Bom dia a todos, Estou querendo implementar um sistema de envio de nota de serviço para um cliente de Araçatuba, São Paulo. Porém, analisei aqui e verifiquei que a cidade de Araçatuba não contém no arquivo Cidades.ini. Estou usando a versão 2 do ACBR. Tem alguma razão para a cidade não estar contida neste arquivo?
  18. Olá a todos, Tenho um sistema que emite NFSe utilizando o ACBr e até o momento não tive nenhum problema com emissão, tanto no meu computador como em computadores de terceiros. Na última semana, me deparei com seguinte erro em um computador de um cliente na hora de Emitir NFSe: (Detalhe, esse mesmo computador emite NFe normalmente); Codigo: 1206 Mensagem: Assinatura do RPS incorreta. Codigo Hash gerado para o campo assinatura do RPS esta invalido. O codigo hash apos;6ec49860718e7146a97369bbb15e64071da850dfapos; gerado para o campo Assinatura do RPS nao esta valido. O campo Assinatura deveria estar com o conteudo apos;00000342414NF 00000000004720180417H NN000000000000100000000000000000062091000058315458000110apos; convertido no padrao SHA1 para o valor apos;692c93dde2609bc351781414dfd053974bfac133apos;. Esse erro em questão, eu consegui simular em um outro notebook que tenho aqui. Atualmente estou verificando as DLLs, pois mesmo com as DLLs padrões que outros clientes usam, o erro persiste nessa máquina. Outro detalhe, é que utilizando o mesmo certificado, com a mesma NFSe, em um computador funciona normal e em outro acontece esse erro de Assinatura do RPS incorreta. O que me faz pensar que o erro seja de configuração do windows. Alguém já passou por isso? Obrigado 3518042364184700015056000000000000047-rps.xml
  19. Boa noite, Estou tendo problema para o provedor IssDSF (Sorocaba) no momento da Impressão. Acontece que o ACBrNFSeDANFSeRL até possui algumas propriedades para eu preencher manualmente. Mas o CNPJ do Emissor não possui o campo e fica sempre 0000000000000. Conforme image m anexo. Poderiam me ajudar? Existe alguma maneira de imprimir igual ao da prefeitura ou ao menos uma impressão correta? Para o provedor Ginfes de Jundiái, a impressão está normal, quando uso IssDsf de Sorocaba, sai conforme o anexo. Obrigado;
  20. pessoal, boa tarde trabalho no vb.net e preciso fazer a nfse para governador valadares / mg. Uso ja o acbr para NFe .. e queria utilizar o NFSe. como faco para utilizar a NFSe no ACBr ???
  21. Pessoal, boa noite! Tenho autorizado NFS-e com a propriedade "ConsultarLoteAposEnvio" marcada, então o componente faz a abstração da comunicação com o WS. Estou desenvolvendo o envio de RPS em lote. A impressão do RPS está disponível no componente? Se sim, qual método devo utilizar? Desde já, obrigado.
  22. Bom dia, estou com um problema ao consultar algumas RPS: no ambiente de produção está ocorrendo um erro ao gerar as assinatura do XML de algumas RPS Segue em anexo as mensagens de erro e os XML para analise. 172-env-lot.xml 172-env-lot-soap.xml 172NF-rps.xml 173-env-lot.xml 173-env-lot-soap.xml 173NF-rps.xml 174-env-lot.xml 174-env-lot-soap.xml 174NF-rps.xml 175-env-lot.xml 175-env-lot-soap.xml 175NF-rps.xml 176-env-lot.xml 176-env-lot-soap.xml 176NF-rps.xml 177-env-lot.xml 177-env-lot-soap.xml 177NF-rps.xml
  23. Bom dia pessoal, após a atualização do ACBR na data de ontem (21/03/2017 - revisão 14885) notei que o envio de e-mail pelo componente parou de funcionar quando configurado para enviar PDF da DANFSe junto. O erro era em relação ao anexo. A imagem abaixo mostra o arquivo gerado pelo componente e o caminho, este arquivo foi realmente gerado em disco e encontra-se no caminho correto. . Após isso, é atribuído o arquivo ao anexo, só que gera novamente o nome do arquivo e este é diferente do que foi gerado acima. Após muita tentativa efetuei uma alteração no fonte de ACBrNFSeDANFSeFR, que segue para análise dos responsáveis. A alteração consiste em alterar a função de conversão do numero da NFSe, pois com a atual retorna somente zeros, como pode ser visto na primeira imagem. Foi alterado para : Assim, gerando o arquivo com o nome no mesmo padrão que gera função GetNumID de ACBrNFSe.pas ACBrNFSeDANFSeFR.pas
  24. Boa tarde, Senhores. Estou implementando a emissão de NFS-e para uma empresa no município de Sorriso - MT, que utiliza o provedor Agiliv2 (De acordo com o arquivo cidades.ini). E estou com o seguinte problema: Dentro do método TDFeHttpWinHttp.Enviar existe a chamada do método ConfigurarHTTP(AURL, ASoapAction, AMimeType); onde são passados os seguintes valores para os parâmetros : AURL : 'http://homolog.nfse.prefsorriso-mt.agilicloud.com.br/api/GerarNfse' ASoapAction : 'http://nfse.abrasf.org.br/GerarNfse' AMimeType : 'application/xml' Dessa forma temos o seguinte bloco: function TDFeHttpWinHttp.Enviar(const ConteudoXML: String; const AURL: String; const ASoapAction: String; AMimeType: String): String; var Resp: TMemoryStream; begin Result := ''; ConfigurarHTTP(AURL, ASoapAction, AMimeType); Resp := TMemoryStream.Create; try try // Enviando, dispara exceptions no caso de erro // FWinHTTPReqResp.Execute(ConteudoXML, Resp); // DEBUG // Resp.SaveToFile('c:\temp\ReqResp.xml'); Resp.Position := 0; Result := String( ReadStrFromStream(Resp, Resp.Size) ); // Verifica se o ResultCode é: 200 OK; 201 Created; 202 Accepted // https://www.w3.org/Protocols/rfc2616/rfc2616-sec10.html if not (FWinHTTPReqResp.HTTPResultCode in [200, 201, 202]) then raise EACBrDFeException.Create(''); except On E: Exception do begin raise EACBrDFeException.CreateDef( Format( cACBrDFeSSLEnviarException, [InternalErrorCode, HTTPResultCode] ) + sLineBreak + E.Message ) ; end; end; finally Resp.Free; end; end; Onde o valor de FWinHTTPReqResp.HTTPResultCode está sempre 503, dando o erro "Erro interno:0 Http 503". O xsd utilizado é o XSDAgili.xsd Alguém sabe dizer se o problema pode estar nas URLs passadas como parametro ou no conteúdo do meu xml que é passado ?
  25. Bom dia Por favor, segue alteração para envio para o repositório do servidor de homologação no arquivo Cidades.ini para a cidade de Sapucaia do Sul/RS, provedor Infisc. De: homol.sapucaiadosul.infisc.com.br Para: sapucaiadosul-homol.infisc.com.br [4320008] Nome=Sapucaia Do Sul UF=RS Provedor=Infisc-v11 NomeURL_H=sapucaiadosul-homol.infisc.com.br NomeURL_P=nfse.sapucaiadosul.rs.gov.br Obrigado desde já! Cidades.ini
×
×
  • Create New...