Jump to content

Assista click.png tectoy.png

C6 chamada_c6.png botao.png

Erro Ao Enviar E-Mail Com O Pdf


Go to solution Solved by André Ferreira de Moraes,
  • Este tópico foi criado há 2736 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Membros Pro

Atualizei o ACBrNFEMonitor2 para a versão 0.8.11.2 e ao tentar enviar um email com os arquivos esta dando a seguinte mensagem

 

Comando: 

NFe.EnviarEmail("[email protected]", "D:\Focus SoftHouse\MjbSistemas\ArquivosNFe\35141103389016000126550010000001301000001303-nfe.xml", "1","","")
 
Retorno:
ERRO: Erro ao enviar email
Cannot open file "D:\Focus SoftHouse\MjbSistemas\ArquivosNfe\35141103389016000126550010000001301000001303.pdf". O sistema não pode encontrar o arquivo especificado.
 
Ele gera o PDF na pasta, mas o arquivo PDF gerado contem .....-nfe.pdf no final, mas o retorno de erro vejo que não consta, gostaria de saber quem pode me ajudar, se é alguma configuração.
 
Márcio.
Link to comment
Share on other sites

Uso A OpenSSL , o zip acima esta com  a capicom.

 

Boa Tarde

 

Vou continuar no Topico ainda , mas o assunto e email ao enviar email , ao final da Nfe , ele me mostra a seguinte mensagem ,

 

NFe.EnviarEmail([email protected],H:\INTEGRAD\XML\201411\25141102019761000110550010005373931020197615-nfe.xml,1,NFe Autorizada Empresa:LOJAO DUFERRO LTDA - NFe No:537393)
ERRO: Erro ao enviar email
Cannot open file "H:\INTEGRAD\PDF\25141102019761000110550010005373931020197615.pdf". O sistema não pode encontrar o arquivo especificado

 

fazendo a rotina em separado tambem da o mesmo erro , notei ao usar tambem a

 

NFe.ImprimirDANFEPDF(H:\INTEGRAD\XML\201411\25141102019761000110550010005373931020197615-nfe.xml)

 

ele esta gerando o arquivo igual o nome do XML com -nfe.pdf ao final do arquivo , mas acho que na função do enviar email , como e gerado automaticamente , nela não consta o -nfe.pdf e ele fica buscando o .PDF e não consegue localizar.

 

e isso mesmo ou existe alguma diferença ou parametro novo que não consegui acompanhar.

 

atualmente para conseguir enviar o email , eu mando gerar com Nfe.ImprimirDanfePDF , depois pelo sistema , renomeio o arquivo tirando o -nfe.pdf e depois mando enviar o email novamente , mas isso esta levando um certo tempo.

 

obrigado antecipamente por qualquer ajuda.

Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.