Jump to content

Delphi chamada_delphi.png acbr.png

C6 chamada_c6.png botao.png

Manifestar - Manifestação Do Destinatário


Go to solution Solved by hetoandrade,
  • Este tópico foi criado há 2676 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Membros Pro

estou enviando o comando:

 

NFE.EnviarEvento("[EVENTO], "1", [EVENTO001], "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx", 35, "xxxxxxxxxxxxxx", 10/02/2014 07:37:38, 2")
ERRO: ERRO: Nenhum Evento adicionado ao Lote
 

esse comando esta correto? tem algum exemplo usando Monitor?

 

obs: onde esta "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx", "xxxxxxxxxxxxxx" informa o nr da chave e cnpj.

Link to comment
Share on other sites

  • Moderadores

Vc não deve colocar aspas dentro do comando.

Ex:

NFE.EnviarEvento("[EVENTO]
idLote=2
[EVENTO001]
chNFe=351109XXXXXXXXXXXXXX550010000055661000055660
cOrgao=35
CNPJ=XXXXXXXXXXXXXX
dhEvento=09/09/11 10:55:00
nSeqEvento=10
xCorrecao=TESTE DE CORRECAO DE NFE")

djsystem-logo.png
 youtube.png facebook.png instagram.png linkedin.png
André Ferreira de Moraes | Analista de Sistemas
www.djsystem.com.br | www.djpdv.com.br
www.tefhouse.com.br | www.lambretinha.com.br
Link to comment
Share on other sites

  • Membros Pro

No manual do acbr pag. 18 diz:

 

Sintaxe dos Comandos ACBr
OBJETO.Comando [( param1 [,param2, param3, paramN...])] ....
§ Texto ou “String”: Para especificar "Strings" nos parâmetros use sempre aspas duplas (").

 

Outra duvida no seu comando esta:

NFE.EnviarEvento("[EVENTO] idLote=2...

 

no meu:

NFE.EnviarEvento("[EVENTO], "1",...

 

tenho que colocar a palavra "idLote=" no comando?

 

obs: tentei sem as aspas e deu o mesmo erro.

 

NFE.EnviarEvento("[EVENTO], 1, [EVENTO001], XXXXXXXXXXXXXXXXXXX0550010000066101000066100, 91, XXXXXXXXX00170, 22/01/2015 09:11:50, 4")
ERRO: ERRO: Nenhum Evento adicionado ao Lote
 

Link to comment
Share on other sites

  • Moderadores

O comando para evento é usado um INI, assim como o comando para criar NFe, não é passado parâmetro por parâmetro.

 

Como todo o evento é apenas um parâmetro ele não pode possuir aspas dentro dele.

djsystem-logo.png
 youtube.png facebook.png instagram.png linkedin.png
André Ferreira de Moraes | Analista de Sistemas
www.djsystem.com.br | www.djpdv.com.br
www.tefhouse.com.br | www.lambretinha.com.br
Link to comment
Share on other sites

  • Moderadores

No manual do acbr pag. 18 diz:

 

Sintaxe dos Comandos ACBr

OBJETO.Comando [( param1 [,param2, param3, paramN...])] ....

§ Texto ou “String”: Para especificar "Strings" nos parâmetros use sempre aspas duplas (").

 

Outra duvida no seu comando esta:

NFE.EnviarEvento("[EVENTO] idLote=2...

 

no meu:

NFE.EnviarEvento("[EVENTO], "1",...

 

tenho que colocar a palavra "idLote=" no comando?

 

obs: tentei sem as aspas e deu o mesmo erro.

 

NFE.EnviarEvento("[EVENTO], 1, [EVENTO001], XXXXXXXXXXXXXXXXXXX0550010000066101000066100, 91, XXXXXXXXX00170, 22/01/2015 09:11:50, 4")

ERRO: ERRO: Nenhum Evento adicionado ao Lote

 

Veja 

djsystem-logo.png
 youtube.png facebook.png instagram.png linkedin.png
André Ferreira de Moraes | Analista de Sistemas
www.djsystem.com.br | www.djpdv.com.br
www.tefhouse.com.br | www.lambretinha.com.br
Link to comment
Share on other sites

  • Este tópico foi criado há 2676 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.