Jump to content

Promoção de Natal SAC Mensal

Contrate e ganhe 1 Kit agenda + Caneta
Saiba mais

LANÇAMENTO
Curso Completo - Dominando o ACBrMonitor

Conheça o Curso

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

Reinaldo Silveira

ANSWERED trunk2 - Falha na validação dos dados da nota "A name contained an invalid character"

Recommended Posts

Bom dia a todos.

Estou fazendo alguns testes com os fontes do trunk2 e me deparei com o seguinte erro ao validar as notas fiscais (todas que testei):

"Falha na validação dos dados da nota: 23535
Não foi possível carregar o arquivo.
Err: -1072896763, Lin: 1, Pos: 2892 - A name contained an invalid character."

Lembrando que o diretório de Schemas está atualizado e as mesmas NFs são validadas normalmente com a versão atual do trunk. Consulto a NF da seguinte forma:

ACBrNFe1.NotasFiscais.Clear;
ACBrNFe1.NotasFiscais.LoadFromFile(OpenDialog1.FileName);
ACBrNFe1.NotasFiscais.Valida;

Anexei o xml para análise, ficarei grato se alguém puder dar uma olhada...

Muito obrigado pela ajuda!

NFe-35150709155042000176550000000235351697502048.xml

Share this post


Link to post
Share on other sites

Tentou utilizar o Demo?

como está fazendo os teste ? me outro micro ? outra instalação nova do ACBr

Juliomar, estou fazendo os testes em uma VM zerada (instalação nova Windows 7 + Delphi XE2)

Não estou conseguindo testar pelo demo, está apresentando a mensagem "Error: unable to parse"

Share this post


Link to post
Share on other sites
Em 2015-10-1 at 07:50, Reinaldo Silveira disse:

Bom dia, pessoal.

Baixei os fontes ontem (revisão 10.130) e o problema não ocorreu mais.

Muito obrigado, ACBr team!

 

2 horas atrás, flaviomotta disse:

estou como o mesmo problema... e já não encontro mais alternativas... alguém passando por isso ?

 


Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP

Share this post


Link to post
Share on other sites

Tambem estou com este problema... e não encontro uma luz .

Usando o Projeto ACBr Revisao: 13368,  Autor: juliomar com Data: 2017/05/29 18:23:14
e a Versão do delphi: Delphi 10 Seattle, Plataforma: Win32

 

Edited by Vlademir Pereira de Lima

Share this post


Link to post
Share on other sites
14 minutos atrás, Vlademir Pereira de Lima disse:

Tambem estou com este problema... e não encontro uma luz .

Usando o Projeto ACBr Revisao: 13368,  Autor: juliomar com Data: 2017/05/29 18:23:14
e a Versão do delphi: Delphi 10 Seattle, Plataforma: Win32

 

por que postou o log do svn? tu viu o que foi subido? tu viu que não interfere em nada que está sendo falado aqui?


Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP

Share this post


Link to post
Share on other sites

Eu desinstalei o ACBr por completo seguindo os procedimentos contidos no artigo "Como instalar o Trunk2 do ACBr" Escrito por Régys  e o erro ainda persiste. 

Falha na validação dos dados da nota: 1
Não foi possível carregar o arquivo.
Err: -1072896763, Lin: 1, Pos: 11 - A name contained an invalid character."

Onde posso estar errando.

 

 

Share this post


Link to post
Share on other sites

Depois que atualizei também estou com o mesmo problema, estou fazendo mais testes pra ver se descubro algo.

Não foi possível carregar o arquivo.
Err: -1072896763, Lin: 1, Pos: 11 - A name contained an invalid character."

Share this post


Link to post
Share on other sites

Também estou com o mesmo problema. Cheguei a pegar versões anteriores do meu software usando o mesmo acbr e deu o mesmo erro novamente. Acabei de atualizar o acbr também e o erro persistiu.

Alguém sabe o que pode ser? Vou tentar copiar um acbr de outro máquina que está com 15 dias sem atualizar.

Share this post


Link to post
Share on other sites
10 minutos atrás, paulo aquino disse:

Voltei uma versão de 15 dias atrás e funcionou. Sei que o tópico é NFSE mas o erro acontece para NFE ao validar.

Verdade estar acontecendo comigo com a NF-e acabei de atualizar novamente agora e ainda acontece o erro. Já testei em 3 computadores com SO's Windows 7 e Windows 8 com IDE's Delphi XE4 e Delphi 10 Seattle.

Edited by Vlademir Pereira de Lima

Share this post


Link to post
Share on other sites

Pelo que testei o problema acontece nas revisões do dia 24/05/2017 pq até a revisão do dia 23/05/2017 (13341) esta funcionando, ou seja, limpei a pasta e baixei a revisão 13341 e esta funcionando normal.

Share this post


Link to post
Share on other sites

Aparentemente o tópico não tinha nada a haver com NFS-e, e sim com NFe. Movido.

Quem está tendo erro, forneçam um passo a passo, usando o Demo do ACBrNFe, onde o erro ocorre.


Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Share this post


Link to post
Share on other sites

O tópico original, é de 2015... mas a causa do erro, é não chamar o método "Assinar", antes de chamar "Validar"

  • Like 2

Consultor SAC ACBr

Daniel Simões de Almeida
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites
1 hora atrás, Daniel Simoes disse:

O tópico original, é de 2015... mas a causa do erro, é não chamar o método "Assinar", antes de chamar "Validar"

Daniel acontecer simplesmente depois de montar a NFe e  chamar o método "Validar".E isto não ocorre com a versão anterior do ACBr na mesma codificação de minha aplicação.

Irei proceder um teste no Demo do ACBr para ver se acontece o mesmo.

Se alguém descobrir antes favor relatem.

Segue em anexo uma trecho do código onde ocorre a exceção.

 

Trecho Codigo.pas

Share this post


Link to post
Share on other sites
1 hora atrás, Vlademir Pereira de Lima disse:

Daniel acontecer simplesmente depois de montar a NFe e  chamar o método "Validar".E isto não ocorre com a versão anterior do ACBr na mesma codificação de minha aplicação.

Você precisa assinar o XML antes de validar.

Anteriormente o ACBr assinava automaticamente quando se chamava o método Validar, isso foi retirado.


Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Share this post


Link to post
Share on other sites
19 minutos atrás, BigWings disse:

Você precisa assinar o XML antes de validar.

Anteriormente o ACBr assinava automaticamente quando se chamava o método Validar, isso foi retirado.

Mesmo assinando antes o erro persiste em todos os 3 computadores. Eu fiz o que recomendou Nortsys, limpei a pasta e baixei a revisão 13341 do dia 23/05/2017  e esta funcionando normal.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...