Jump to content

Erro ao instalar trunk2 Can't load package W10


Go to solution Solved by Igor Bastos,
  • Este tópico foi criado há 1507 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Olá Pessoal, estou instalando o trunk2 via instalador e funciona normalmente ! Mas quando vou abrir o Delphi2007 dá as seguintes mensagens

 

Can't load package D:\projetos\acbr\Lib\Delphi\LibD11\ACBr_NFe.bpl.

Can't load package D:\projetos\acbr\Lib\Delphi\LibD11\ACBr_NFCeECFVirtual.bpl.

Can't load package D:\projetos\acbr\Lib\Delphi\LibD11\ACBr_NFeDanfeESCPOS.bpl.

Can't load package D:\projetos\acbr\Lib\Delphi\LibD11\ACBr_CTe.bpl.

Can't load package D:\projetos\acbr\Lib\Delphi\LibD11\ACBr_NFSe.bpl.

Can't load package D:\projetos\acbr\Lib\Delphi\LibD11\ACBr_MDFe.bpl.

Can't load package D:\projetos\acbr\Lib\Delphi\LibD11\ACBr_SATExtratoESCPOS.bpl.

Can't load package D:\projetos\acbr\Lib\Delphi\LibD11\ACBr_NFeDanfeFR.bpl.

 

Já tentei instalar manualmente e a mensagem é a mesma!

 

O que poderia ser? Estou usando Windows 10 e é a primeira instalação!

 

Grato

Zanona

Link to comment
Share on other sites

  • Consultores

Dll? marcou para copiar as necessárias?

  • Like 1
Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

 

Link to comment
Share on other sites

  • 2 weeks later...
Em 11/01/2016 at 12:01, zanona disse:

Valeu pela força! Joguei os fontes no c:\acbr\ e agora o Delphi reconheceu!

 

Vai entender :S

estou com mesmo problema...

 

[Window Title]
Error

[Content]
Can't load package C:\ACBR\trunk2\Lib\Delphi\LibD20\ACBr_NFe.bpl.
Não foi possível encontrar o módulo especificado.
Do you want to attempt to load this package the next time a project is loaded?

[Yes] [No]

 

 

no windows 10 com o XE6....

 

alguem sabe o q pode ser?

10 minutos atrás, Buffon disse:

estou com mesmo problema...

 

[Window Title]
Error

[Content]
Can't load package C:\ACBR\trunk2\Lib\Delphi\LibD20\ACBr_NFe.bpl.
Não foi possível encontrar o módulo especificado.
Do you want to attempt to load this package the next time a project is loaded?

[Yes] [No]

 

 

no windows 10 com o XE6....

 

alguem sabe o q pode ser?

esta ok...era dll...valew

Link to comment
Share on other sites

  • Consultores

Você deve ter fontes do trunk ainda no micro e bpls!

exclua as pastas dos fontes antigos do acbr

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

 

Link to comment
Share on other sites

  • 2 months later...
  • 1 month later...
  • 7 months later...

Após instalar o ACBr no Windows 10,

ao abrir o Delphi XE5, dava o erro: Can't load package ...\ACBr_NFe.bpl.

No meu caso resolveu seguindo as dicas dos colegas acima, que são:

1) Executar o Instala.bat da pasta:  ACBr\DLLs\Capicom

2) Copiando as dll´s da pasta: ACBr\DLLs\XMLSec  para pasta: \windows\system32

 

Abrindo sem erro agora. Sucesso !

Obrigado aos colegas pelas dicas.

Att,

Fernando.

Link to comment
Share on other sites

  • Consultores

No caso é só marcar no instalador para copiar as dll para os local correto e se possível executar ele como administrador!

  • Like 1
Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

 

Link to comment
Share on other sites

  • 3 months later...
Em 2016-4-17 at 12:17, flavio80s disse:

Resolveu copiando as dlls da xmlsec para system32...

Estava com o mesmo problema no Windows 10 x64 com Rad Studio Tokyo 10.2, na hora de abrir o Delphi, dava o erro Can't load package ...\LibD25\ACBr_NFe.bpl, etc... Mas apenas copiei as dlls da XMLSec para C:\Windows\SysWOW64 e parou de dar erro, tudo funcionando... Obrigado...

Link to comment
Share on other sites

  • 1 month later...
  • Solution
Em 11/01/2016 at 11:18, zanona disse:

Olá Pessoal, estou instalando o trunk2 via instalador e funciona normalmente ! Mas quando vou abrir o Delphi2007 dá as seguintes mensagens

 

Can't load package D:\projetos\acbr\Lib\Delphi\LibD11\ACBr_NFe.bpl.

Can't load package D:\projetos\acbr\Lib\Delphi\LibD11\ACBr_NFCeECFVirtual.bpl.

Can't load package D:\projetos\acbr\Lib\Delphi\LibD11\ACBr_NFeDanfeESCPOS.bpl.

Can't load package D:\projetos\acbr\Lib\Delphi\LibD11\ACBr_CTe.bpl.

Can't load package D:\projetos\acbr\Lib\Delphi\LibD11\ACBr_NFSe.bpl.

Can't load package D:\projetos\acbr\Lib\Delphi\LibD11\ACBr_MDFe.bpl.

Can't load package D:\projetos\acbr\Lib\Delphi\LibD11\ACBr_SATExtratoESCPOS.bpl.

Can't load package D:\projetos\acbr\Lib\Delphi\LibD11\ACBr_NFeDanfeFR.bpl.

 

Já tentei instalar manualmente e a mensagem é a mesma!

 

O que poderia ser? Estou usando Windows 10 e é a primeira instalação!

 

Grato

Zanona

Depois de ter que reinstalar o ACBr o problema aconteceu comigo.

  • Windows 10 64 Bits
  • instalando ACBr selecionado Plataforma Win32
  • Remover arquivos antigos do disco
  • Marcado para copiar todas DLLs para diretório System Windows

Depois de horas reinstalando, apagando e copiando DLLs, o problema foi resolvido copiando as DLLs de ACBr\DLLs\XMLSec\MinGW\32 para \Windows\SysWOW64 logo após a instalação, ou seja, depois que limpei tds DLLs referentes ao ACBr, instalar com a opção "Remover arquivos antigos" e copiar as DLLs para pasta que mencionei, o problema foi resolvido.

Eu fiz vários testes com as DLLs de 32 na SysWOW64, DLLs 64 na pasta System32, 32 na 32 e 64 na 64, até conseguir da forma como descrevi.

Espero que minha solução ajude alguém.

Edited by Igor Bastos
  • Like 1
  • Thanks 3
Link to comment
Share on other sites

  • 2 weeks later...

Olá! Estou com o mesmo problema. Uso Rad Studio 10.2 e a instalação do ACBr ocorre normalmente, mas ao abrir o Delphi dá o erro 

Can't load package C:\ACBR\trunk2\Lib\Delphi\LibD20\ACBr_NFe.bpl.Não foi possível encontrar o módulo especificado.Do you want to attempt to load this package the next time a project is loaded?

Essa mensagem ocorre para cada componente do ACBr.

Tentei todas as soluções descritas acima e nada.

Não sei mais o que fazer. Alguém poderia dar uma sugestão?

Link to comment
Share on other sites

Obrigado Felipe! Mas não funcionou. O mesmo erro continua. Já tentei de tudo. Pensei que poderia ser algo de permissão do Windows ou firewall, mas desabilitei o firewall do windows, Avast e baixei o nível de permissão do usuário. Sem sucesso. O que percebi é que parece ter algo errado na compilação. Ele não está gerando nenhum .bpl. Não teria que ser gerado os .bpl na pasta LibD25?

Link to comment
Share on other sites

Em 12/07/2017 at 16:52, Igor Bastos disse:

Depois de ter que reinstalar o ACBr o problema aconteceu comigo.

  • Windows 10 64 Bits
  • instalando ACBr selecionado Plataforma Win32
  • Remover arquivos antigos do disco
  • Marcado para copiar todas DLLs para diretório System Windows

Depois de horas reinstalando, apagando e copiando DLLs, o problema foi resolvido copiando as DLLs de ACBr\DLLs\XMLSec\MinGW\32 para \Windows\SysWOW64 logo após a instalação, ou seja, depois que limpei tds DLLs referentes ao ACBr, instalar com a opção "Remover arquivos antigos" e copiar as DLLs para pasta que mencionei, o problema foi resolvido.

Eu fiz vários testes com as DLLs de 32 na SysWOW64, DLLs 64 na pasta System32, 32 na 32 e 64 na 64, até conseguir da forma como descrevi.

Espero que minha solução ajude alguém.

Funcionou!

Muito obrigada!

Link to comment
Share on other sites

  • 3 months later...
Em 12/07/2017 at 16:52, Igor Bastos disse:

Depois de ter que reinstalar o ACBr o problema aconteceu comigo.

  • Windows 10 64 Bits
  • instalando ACBr selecionado Plataforma Win32
  • Remover arquivos antigos do disco
  • Marcado para copiar todas DLLs para diretório System Windows

Depois de horas reinstalando, apagando e copiando DLLs, o problema foi resolvido copiando as DLLs de ACBr\DLLs\XMLSec\MinGW\32 para \Windows\SysWOW64 logo após a instalação, ou seja, depois que limpei tds DLLs referentes ao ACBr, instalar com a opção "Remover arquivos antigos" e copiar as DLLs para pasta que mencionei, o problema foi resolvido.

Eu fiz vários testes com as DLLs de 32 na SysWOW64, DLLs 64 na pasta System32, 32 na 32 e 64 na 64, até conseguir da forma como descrevi.

Espero que minha solução ajude alguém.

Funcionou pra mim também! Valeu!!

Link to comment
Share on other sites

  • 4 months later...

Estava com o mesmo problema com Tokyo + Win10, porém só deu certo fazendo as dicas dos usuários "pcpag" e "IgorBastos". Mas de reinstalar o ACBR removi toda a referencia no Delphi sobre os componentes e pacth do libary.. e iniciei a IDE sem dar problemas.. ai sim executei o batch do ACBR "apagarAcbr.bat" e depois segui os passos de instalação supracitados. Valeu.

Link to comment
Share on other sites

  • 1 month later...
Em 12/07/2017 at 16:52, Igor Bastos disse:

Depois de ter que reinstalar o ACBr o problema aconteceu comigo.

  • Windows 10 64 Bits
  • instalando ACBr selecionado Plataforma Win32
  • Remover arquivos antigos do disco
  • Marcado para copiar todas DLLs para diretório System Windows

Depois de horas reinstalando, apagando e copiando DLLs, o problema foi resolvido copiando as DLLs de ACBr\DLLs\XMLSec\MinGW\32 para \Windows\SysWOW64 logo após a instalação, ou seja, depois que limpei tds DLLs referentes ao ACBr, instalar com a opção "Remover arquivos antigos" e copiar as DLLs para pasta que mencionei, o problema foi resolvido.

Eu fiz vários testes com as DLLs de 32 na SysWOW64, DLLs 64 na pasta System32, 32 na 32 e 64 na 64, até conseguir da forma como descrevi.

Espero que minha solução ajude alguém.

Meu amigo, muito obrigado. Depois de 3 horas aqui tentando várias formas, do jeito funcionou de primeira. Muito obrigado!

Link to comment
Share on other sites

  • 4 weeks later...

Boa tarde,

Estou tentando instalar o ACBr Trunk2 no Delphi XE7 64bits, utilizo o Windows 7 64bits.

Na instalação não acontece nenhum erro, segue com sucesso, no entanto quando abro o Delphi recebo mensagens dizendo que não foi possível carregar os pacotes da pasta: C:\ACBr\Lib\Delphi\LibD21\. Os pacotes são: ACBrComum.bpl, ACBr_OpenSSL.bpl, ACBr_Diversos.bpl, etc.

Tentei as soluções acima mas nenhuma funcionou, de fato no meu caso não achei que funcionaria já que após o fim da instalação quando procuro algum arquivo bpl na pasta LibD21 não encontro nenhum. 

Alguém tem alguma outra solução?

Link to comment
Share on other sites

Boa noite!

 

Pessoal, estou com o mesmo problema, ou seja, minha máquina é Windows 10 64bits e utilizo a versão do Delphi Seatle, ao fazer a instalação do ACBr através do Trunk2, o processo ocorre sem problemas (inclusive marquei a opção "remover arquivos antigos" e "copiar as dll's..."), porém, ao iniciar o delphi, ocorre o erro de "Can't load packet... não foi possível encontrar o módulo especificado..."! Já tentei vários procedimentos mencionados por nossos nobres colegas aqui, porém, sem sucesso. Inclusive o procedimento mencionado pelo @Igor Bastos, porém, pra mim, diferentemente de outros colegas aqui que eu vi, não surtiu efeito. Continuo com o mesmo problema. Eu tentei instalar o Fortes Report, achando que esse poderia ser o motivo da falha, porém, até ele dar erro na hora de carregar o Delphi, ou seja, da o mesmo erro, informando que não foi possível encontrar o módulo especificado.

Se alguém tiver mais alguma ideia ou sugestão, eu agradeço!

image.png.7f3065989241cd11973d8c6dbfcab982.png

 

Link to comment
Share on other sites

  • Este tópico foi criado há 1507 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.