Jump to content

click.png

click.png

click.png

click.png click.png click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

NFSe - O identificador não está no estado correto para o operação solicitada


icozeira
  • Este tópico foi criado há 1975 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Membros Pro

Após a atualização do ACBR não tenho conseguido enviar NFSe p/o provedor Saatri, Prefeitura de Boa Vista.

Estou usando o comando Gerar para o envio, como sempre fiz, da seguinte forma:

ACBrNFSe1.Gerar(StrToInt(nfse.NFSe.NumeroRps));

Estou enviando em anexo o arquivo INI do Saatri , porque não sei se o problema é nele.

A única informação que tenho é que esse Provedor Saatri não requer assinatura com certificado digital, apenas o envio do CPF e senha do emitente.

Segue também uma copia do xml com o gerar soap.

O estranho que às vezes consulto o Portal da Prefeitura e a NFSe está lá.

Não tenho conseguido consultar pelo meu Sistema usando o ACBR também, apresenta o mesmo erro.

 

 

Saatri.ini

10098-ger-nfse-soap.xml

erroNfse.jpg

Link to comment
Share on other sites

  • Membros Pro

Régys,

Boa noite e muito obrigado pela atenção.

Fiz o teste alterando o arquivo .ini e deu erro de validade do certificado.

Então, alterei a configuração para não verificar a validade do certificado (VerificarValidade = False), mas, infelizmente apresentou o mesmo erro.

Tenho percebido que o xml está sendo entregue ao servidor do Saatri, o problema creio eu, estar no retorno.

Digo isso, porque faço o envio e consulto pelo Portal do Saatri e a Nota consta lá.

Também faço o envio e utilizo um executável antigo do meu sistema para fazer a Consulta e a Nota já está lá.

Só quando faço a consulta pelo novo executável, dá o erro do Identificador não está no estado correto.

 

Link to comment
Share on other sites

  • Consultores

Bom dia Icozeira,

Pela mensagem do seu primeiro post ela se refere ao consumo do Web Services GerarNfse e não a Consulta.

Isso é estranho pois não deveria ocorrer o envio.

Se o envio ocorre, então quer dizer que a mensagem de erro é levantada logo após o envio.

O componente esta configurado como: libCapicom, libCapicomDelphiSoap ou libOpenSSL ?

Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

  • Membros Pro

Bom dia Italo,

Obrigado pela atenção dispensada.

Limpei o ACBR da minha maquina, fiz a atualização dos fontes, copiei novamente todos os arquivos INI, mas, infelizmente persiste o problema.

"O Identificador não está no estado correto".

Link to comment
Share on other sites

  • Consultores

Boa tarde Icozeira,

Bom agora o problema é outro?

Pois antes se tratava de Requisição não enviada, agora é Identificado não está no estado correto.

Nesse novo teste após a atualização dos fontes qual é o valor de SSLLib?

Tentou mudar?

Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

  • Membros Pro

Boa tarde Italo,

Me desculpe, não me expressei e nem passei direito os detalhes no post anterior.

Para o SSLLib = libCapicom o erro é o mesmo -> Requisição não enviada.

Para o SSLLib = libCapicomDelphiSoap o erro é também o mesmo apresentado anteriormente - > O Identificador não está no estado correto.

No arquivo ini do Saatri alterei UseCertificado=0 (false);

Link to comment
Share on other sites

  • Membros Pro

Boa tarde Italo,

Muito obrigado pela tua atenção.

Alterei o UseCertificado p/ = 1 e o erro permanece.

Fiz as opções alternando com libCapicomlibCapicomDelphiSoap na propriedade  SSLLib  e não consegui resultado positivo.

O que mais intriga é que na minha maquina (windows 7 ultimate com o sistema operacional totalmente atualizado) não tenho conseguido resultado positivo.

Na maioria dos meus clientes também estou com problemas.

Mas, por incrível que pareça sem alterar nada, em um cliente está funcionando perfeitamente e também utiliza o windows 7 ultimate totalmente atualizado.

O pior é que nesses Clientes que não estão funcionando, quando utilizo o executável antigo funciona perfeitamente. E, também o sistema operacional é na maioria dos casos é semelhante.

Link to comment
Share on other sites

  • Consultores

Bom dia icozeira,

Compare o arquivo INI do provedor que encontra-se na maquina do cliente que esta funcionando com o da sua que não esta.

Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

  • Membros Pro

Bom dia Italo,

Mais uma vez obrigado pela atenção.

Peguei o arquivo INI do Saatri do Cliente e copiei para minha maquina.

Não funcionou.

Se tiver mais alguma sugestão, estou disposto a testar pra tentar resolver meu problema.

De toda maneira, fico muito agradecido pela atenção dispensada.

Link to comment
Share on other sites

  • Consultores

Bom dia icozeira,

Se com o arquivo INI não resolveu o problema, tem que partir para a configuração do Internet Explorer, antivírus, firewall, proxy, ....

Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

  • Membros Pro

Boa tarde Italo,

Muito obrigado pela atenção.

Desde segunda feira tenho tentado o teste em vários micros, com diferentes configurações de antivirus, desabilitando firewal e não tenho conseguido resultados positivos.

Queria te pedir um grande favor.

Estou anexando um arquivo rar onde está um rps, os arquivo ini da cidade, saatri e configuração do cliente pelo Demo do ACBRNFSe.

Peço por gentileza que tente fazer a consulta por RPS dessa nota pelo teu Demo do ACBR.

Pode ser que dessa maneira, você consiga identificar qual é o problema que está ocorrendo.

O Emitente está habilitado para fazer o uso do Ambiente de homologação por mais alguns dias.

Quando tiver um tempo disponível, por favor, me auxilie nessa solução.

TesteACBR.rar

Link to comment
Share on other sites

  • Consultores

Bom dia icozeira,

O arquivo Cidades.INI em relação o que esta disponível no SVN o seu esta desatualizado. Por outro lado o Saatri.INI esta exatamente igual ao que esta no SVN.

Como você mesmo disse que em um determinado cliente esta funcionando, o problema é na sua maquina e de outros clientes, correto?

Sendo assim podemos descartar o componente e a aplicação.

O foco agora é com o sistema operacional, talvez alguma atualização do Windows possa esta faltando ou não deveria ter sido feita.

Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.