Jump to content
Notícias do ACBr

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


Saiba mais

beneficios.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png click.png click.png

Não consigo nem instalar os componentes


  • Este tópico foi criado há 1817 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Recommended Posts

Quando clico no Instalador Trunk2, DE CARA aparece a mensagem dcc32.exe not found. Clico OK e ele abre o wizard. Se o Delphi está aberto, ele manda fechar. Quando fecho, ele não detecta nenhuma versão instalada, sendo que tenho a Seattle e o antigo 7.

Baixei tudo pelo SVN e da última vez que executei o arquivo, ele detectou a versão 7, mas tive outros problemas para instalar. Agora nem isso mais. Tenho a impressão que o executavel simplesmente mudou da última vez que cliquei.

Parece brincadeira isso, eu nunca vi algo tão complicado de instalar feito esses componentes ACBr.

Link to comment
Share on other sites

  • Consultores
23 minutes ago, potew said:

Quando clico no Instalador Trunk2, DE CARA aparece a mensagem dcc32.exe not found. Clico OK e ele abre o wizard. Se o Delphi está aberto, ele manda fechar. Quando fecho, ele não detecta nenhuma versão instalada, sendo que tenho a Seattle e o antigo 7.

Baixei tudo pelo SVN e da última vez que executei o arquivo, ele detectou a versão 7, mas tive outros problemas para instalar. Agora nem isso mais. Tenho a impressão que o executavel simplesmente mudou da última vez que cliquei.

Parece brincadeira isso, eu nunca vi algo tão complicado de instalar feito esses componentes ACBr.

Olhe só possuo 2 micros em casa um notebook e um desktop com XE3, XE6 Seattle Berlin!

10 micro na empresa com XE7 e Seattle!

e todos eles roda com o instalador!

Acho que falta um pouco de conhecimento ai!

primeiro o delphi deve de estar fechado, segundo se tem duas versões do delphi, deve de seguir o que o Isaque explica no blog dele para ter dois delphi no mesmo micro!

o instalador não funciona com versões trial pois o dcc32.exe é compilador do delphi e então não roda em linha de comando!

depois marque a opção de limpeza total, também para copiar as dll para o bin do delphi!

minha filha tem 11 anos e ela instalou pra mim no desktop o ACBr nos delphi pra mim usando o instalador!

pois ele é simples next next finish!

  • Like 1
Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil
Link to comment
Share on other sites

1 hora atrás, Juliomar Marchetti disse:

Olhe só possuo 2 micros em casa um notebook e um desktop com XE3, XE6 Seattle Berlin!

10 micro na empresa com XE7 e Seattle!

e todos eles roda com o instalador!

Acho que falta um pouco de conhecimento ai!

primeiro o delphi deve de estar fechado, segundo se tem duas versões do delphi, deve de seguir o que o Isaque explica no blog dele para ter dois delphi no mesmo micro!

o instalador não funciona com versões trial pois o dcc32.exe é compilador do delphi e então não roda em linha de comando!

depois marque a opção de limpeza total, também para copiar as dll para o bin do delphi!

minha filha tem 11 anos e ela instalou pra mim no desktop o ACBr nos delphi pra mim usando o instalador!

pois ele é simples next next finish!

Cara, muitoobrigado pela resposta, vou fazer este procedimento aqui e te falo :D 

Esse negócio tá me tirando do sério :P

Link to comment
Share on other sites

  • Consultores

O que escrevi acima está em diversos posts e até tópicos aqui no fórum!

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil
Link to comment
Share on other sites

  • Moderadores

Como precisei formatar um micro, ontem mesmo instalei o ACBr no Delphi 7 e no XE3 Ultimate. Instalou normalmente em ambos, a única coisa que tomei cuidado (por orientação de um colega aqui) foi instalar o ACBr em uma pasta fora da pasta Arquivo de Programas para não ter problemas de permissão e também instalar antes o FortesReport-ce. Minhas licenças são originais. O instalador do ACBr é muito fácil de usar e é auto-explicativo. Você só seleciona os componentes e clica num botão e ele faz tudo. Quem dera todos os instaladores fossem assim. Outra coisa: tenho as 2 versões do Delphi rodando ativas na mesma máquina.

  • Like 2
Link to comment
Share on other sites

10 minutos atrás, [email protected]@ disse:

Como precisei formatar um micro, ontem mesmo instalei o ACBr no Delphi 7 e no XE3 Ultimate. Instalou normalmente em ambos, a única coisa que tomei cuidado (por orientação de um colega aqui) foi instalar o ACBr em uma pasta fora da pasta Arquivo de Programas para não ter problemas de permissão e também instalar antes o FortesReport-ce. Minhas licenças são originais. O instalador do ACBr é muito fácil de usar e é auto-explicativo. Você só seleciona os componentes e clica num botão e ele faz tudo. Quem dera todos os instaladores fossem assim. Outra coisa: tenho as 2 versões do Delphi rodando ativas na mesma máquina.

Você apenas instalou as duas IDEs e rodou o instalador ACBr ou executou o procedimento do Path override antes? E faz diferença ser original ou piratinha?

Link to comment
Share on other sites

  • Moderadores
29 minutos atrás, potew disse:

Você apenas instalou as duas IDEs e rodou o instalador ACBr ou executou o procedimento do Path override antes? E faz diferença ser original ou piratinha?

Eu instalei as duas IDEs e rodei o instalador ACBr. O procedimento que o Isaque Pinheiro citou no blog eu não conhecia, vou até ler com mais tempo, parece ser uma dica boa.

Agora, se faz diferença ser original ou piratinha não sei, não uso o piratinha. :-D

  • Like 1
Link to comment
Share on other sites

4 horas atrás, [email protected]@ disse:

Eu instalei as duas IDEs e rodei o instalador ACBr. O procedimento que o Isaque Pinheiro citou no blog eu não conhecia, vou até ler com mais tempo, parece ser uma dica boa.

Agora, se faz diferença ser original ou piratinha não sei, não uso o piratinha. :-D

Tenho um amigo com o CD do original, depois posto o resultado, só pode ser isso.... rodei outra versão do instalador, ele reconheceu apenas o D7 mas fica dando esse erro do DCC32 na hora H. Parece brincadeira!

Link to comment
Share on other sites

  • Consultores
10 hours ago, potew said:

Tenho um amigo com o CD do original, depois posto o resultado, só pode ser isso.... rodei outra versão do instalador, ele reconheceu apenas o D7 mas fica dando esse erro do DCC32 na hora H. Parece brincadeira!

Veja então o que informou lá no primeiro post não é uma verdade que o ACBr é complicado de instalar!

e sim é como está instalando os delphis!

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil
Link to comment
Share on other sites

2 horas atrás, Juliomar Marchetti disse:

Veja então o que informou lá no primeiro post não é uma verdade que o ACBr é complicado de instalar!

e sim é como está instalando os delphis!

Espero que seja assim, vou instalar o D7 original e ver se procede mesmo! Rsrsrs

Quando vc falou versão trial no começo quis se referir a instalações piratas? Como o instalador sabe diferenciar?

Link to comment
Share on other sites

  • Moderadores

Software shareware (trial) são programas proprietários com limitações de uso, podendo ser de tempo ou funcionalidades (não ter todas as funções). Também são gratuitos, mas apenas para divulgação, após algum tempo perdem sua validade (não funcionam mais, devendo ser apagado do computador ou comprado do seu fabricante). Num termo mais comum, seria uma “amostra grátis”, uma forma de divulgação do produto, sendo protegido por direitos autorais. Ninguém é obrigado a pagar por seu registro, ao menos, que goste ou queria ficar com este software.

Software pirata é o software craqueado e não licenciado e é crime. Inclusive, as suas perguntas sobre pirata não são pertinentes aqui no grupo ACBr. Leia as normas antes de postar.

  • Like 3
Link to comment
Share on other sites

  • 3 weeks later...

Comemorei cedo... quando seleciono os componentes de relatórios ele dá erro na hora da compilação quando chega neles. Presumi que seja a instalação do Fast/Fortes. Instalei ambos e nada. Tudo bem. Desmarquei estes componentes e o resto compilou/instalou. Abro o Delphi e........ mensagem de libxml2.dll faltando. Adiciono a pasta de DLLs da ACBr no library path do Delphi. Mesmo erro persiste. É mole? Estou em tempos de desistir já...

Link to comment
Share on other sites

Na verdade é o Windows que apresenta o erro na hora que carrega a IDE. É uma mensagem do tipo -  O programa não pode ser iniciado porque está faltando libxml2.dll no seu computador..... E em seguida o Delphi fala que não pode carregar os pacotes (supostamente dependentes) dessa DLL, se deseja tentar novamente quando for carregar de novo. No caso o NFE e o OpenSSL. Depois disso abre mas sem os componentes!

Edited by potew
Acrescentar info
Link to comment
Share on other sites

  • Moderadores

Legal,

Poe as dll na pasta onde a IDE enxerga.

Uma das alternativas é a pasta Lib do seu Delphi ou na pasta %systemroot%\System32 para Windows 32 e %systemroot%\SysWOW64 para Windows 64

Dessa forma sua IDE encontra as dlls e resolve essa bronca.

Edited by Waldir Paim
Link to comment
Share on other sites

55 minutos atrás, Waldir Paim disse:

Legal,

Poe as dll na pasta onde a IDE enxerga.

Uma das alternativas é a pasta Lib do seu Delphi ou na pasta %systemroot%\System32 para Windows 32 e %systemroot%\SysWOW64 para Windows 64

Dessa forma sua IDE encontra as dlls e resolve essa bronca.

Mandei para a pasta do SysWOW64 e agora realmente abriu sem problemas. Mais uma cagada que eu estava fazendo ou deixando de fazer, pra variar.

Obrigado pela ajuda em plenas olimpíadas, rs

Agora é quebrar a cabeça com o Fortes Report!

Link to comment
Share on other sites

  • Este tópico foi criado há 1817 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.