Jump to content

logo_acbr_paygo.png

Chegou o TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


botao_saibamais.png

beneficios.png

Curso Dominando o ACBrMonitor
Novo Módulo Soluções de Varejo
Assine o SAC ACBr em qualquer plano e tenha acesso

Saiba Mais

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba Mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

Douglas Immobile

NFS-e retorno do xml (Índice de listagem fora da faixa (0))

  • Este tópico foi criado há 1448 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Recommended Posts

Bom dia, utilizo ACBR NFS-e para emissão das Notas... Estamos migrando para o TRUNK2, já está enviando as notas, no site da prefeitura fica tudo certinho, o único problema é o xml que o componente mesmo baixa da NFS-e, ele volta com erro, e ao tentar carregar o xml no componente para enviar por e-mail ou abrir em PDF..., sempre me retorna a mensagem de Exceção - Indice de Listagem Fora da Faixa (creio que porque o componente esteja vazio). Mas quando faço o download o xml diretamente do site da prefeitura funciona perfeitamente!!! Estou testando com o provedor de Porto Alegre - RS (BHISS). Teria Como me ajudar?

Segue xml de retorno (com problema e correto).

Desde já agradeço.

 

At,

 

Douglas Colombo

[email protected]

Notas.rar

Share this post


Link to post
Share on other sites

A mensagem que retorna, Lembrando que a mensagem a baixo apenas esta tratada, mas é a mensagem que retorna o componente. Este erro ocorre no:

 

ACBrNFSeWebServices - procedure TNFSeGerarLoteRPS.DefinirDadosMsg >- FNotasFiscais.ValidarLote(FPDadosMsg, FPConfiguracoes.Arquivos.PathSchemas  + FPConfiguracoesNFSe.Geral.ConfigSchemas.ServicoEnviar).

Estou a alguns dias atras disto, agradeço desde já!!!

Sem título.jpg

Edited by Douglas Immobile

Share this post


Link to post
Share on other sites

Boa tarde

tentou marcar e debugar pra achar?

por tente achar o ponto onde carrega o xml errado!

  • Like 1

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

Share this post


Link to post
Share on other sites
13 horas atrás, Juliomar Marchetti disse:

Boa tarde

tentou marcar e debugar pra achar?

por tente achar o ponto onde carrega o xml errado!

Bom dia, obrigado pelo retorno... ao validar a nfs-e para emitir, ele esta dando erro nesta parte, e acaba caindo no raise e informando a imagem que mandei anteriormente...

Renomeei os arquivos .pas da NFS-e, e atualizei o ACBR, mas continuou igual... Parece erro de schemas, mas peguei os schemas do BHISS da pasta do ACBR Trunk2, utilizando capicom.dll

Saberia o que pode ser?

ValidarLote.jpg

NotaEhValida.jpg

Fim.jpg

Share this post


Link to post
Share on other sites

Desconsidera a mensagem com as fotos anteriores, o problema esta na assinatura, pois a variavel xIdSignature vem sem valor nenhum então acaba não conseguindo assinar. Lembrando que no Trunk1 funciona normalmente

V1.jpg

V2.jpg

V3.jpg

Share this post


Link to post
Share on other sites

Primeira situação desconsidere o trunk pois não tem mais a ver um código com  outro!

Como está configurado no ini para esse provedor e cidade?

  • Like 1

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

Share this post


Link to post
Share on other sites
  • Este tópico foi criado há 1448 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...