Jump to content

Curso Dominando o ACBrMonitor
Novo Módulo Soluções de Varejo
Assine o SAC ACBr em qualquer plano e tenha acesso

Saiba Mais

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba Mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

Adhelmar Rondon

DANFE apenas mostrando os itens

  • Este tópico foi criado há 1382 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Recommended Posts

21 horas atrás, Adhelmar Rondon disse:

Muito bom dia a todos

Será que alguém pode me ajudar, percebi também que se emito DANFE em modo paisagem o preview também esta mostrando errado sem os dados, apena no modo retrato que os dados estão corretos e como não tenho uma versão mais atualizada do fast reports eu não consigo usa-lo no lugar do fortes reports, 

 

21 horas atrás, Adhelmar Rondon disse:

na impressão do DANFE em PDF os dados não saem, impressão sem ser PDF aparece normal, se salvo em PDF pelo preview os dados também não aparecem

 

35160812187272000121550020000016001000016000-nfe.pdf

35160812187272000121550020000016001000016000-nfe.xml

 

Share this post


Link to post
Share on other sites

Bom dia

primeiro aguarde com calma, lembre-se é fórum aberto então deve ter paciência ou pode ser chamado a atenção !

acabei de pegar o exemplo do ACBr e pegar seu xml e rodar!

tem certeza que está com o fortes correto? frce e nome do pacote e está no github para qualquer um baixar! lembrando de remover as versões antigas

Untitled.png

 


Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

Share this post


Link to post
Share on other sites
24 minutos atrás, Adhelmar Rondon disse:

Bom dia

 

Desculpe não quero atrapalhar ninguém não.

obrigado!

 

Pegou o demo e testou com ele?


Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

Share this post


Link to post
Share on other sites

Então é assim, tenho um projeto pelo Delphi 7 e ele esta com trunk2, fortes esta com frce e quando o sistema gera em PDF sai tudo certinho, e eu tenho um outro projeto que em Delphi XE2 e esta com a ultima versão do ACBr e esta também usando o frce, o sistema gera a NF tudo certinho, é autorizado perfeito, aparece a DANFE na tela perfeita outro dia que eu percebi que essa mesma DANFE que na tela aparece perfeita quando exporta para o PDF ela fica errada, fiz o teste de pelo preview gerar a DANFE em PDF e também sai errado, só que não tem como depurar isso para tentar entender porque não exporta igual o que esta no preview

desde de já agradeço seu desempenho, sei que tem é uma pessoa muito ocupada 

Share this post


Link to post
Share on other sites

bom não estou entendendo a sua última frase que voltou a repetir!

seu delphi está no mesmo S.O. ?

se sim tratou corretamente? e os drivers da impressora está também instalado correto?


Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

Share this post


Link to post
Share on other sites

Utilizo VM e todas as VM estou usando Windows XP ou seja todas com o mesmo sistema operacional

Nas VM eu não tenho impressora instalada.

Eu fiz outro teste deixei o tipo da DANFE como resumido e nesse teste o PDF é gerado corretamente ao enviar o e-mail o PDF mostrou todos os dados coisa que não ocorre no modo retrato

Fiz um teste deixando o tipo da DANFE modo paisagem dessa vez no próprio preview já sai errado 

quando digo preview é o comando de imprimir do componente ACBrNFe

Share this post


Link to post
Share on other sites

Muito obrigado, pelo seu tempo comigo, então pelo que eu percebi essa propriedade abaixo:

 

 ACBrNFe1.DANFE.MostrarStatus:= False; 

deixando falsa estava fazendo a DANFE sair faltando dados, não usei mais essa propriedade em tempo de execução deixando ela como padrão que é True e consegui enviar a DANFE por e-mail

mais uma vez agradeço e parabenizo a todos da ACBr pelo excelente trabalho que vocês fazem e pelo tempo que se dedicam a esse projeto

ps. o que acho estranho é que não estou conseguindo testar os exemplos pelo Windows XP

Share this post


Link to post
Share on other sites
  • Este tópico foi criado há 1382 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...