Jump to content

Assista tectoy.png

chamada diadoacbr

Configurar o ACBrMonitor Plus para usar chave RSA


jjw.roberto
Go to solution Solved by jjw.roberto,
  • Este tópico foi criado há 2117 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Pessoal, boa tarde.

Estou tentando utilizar a geração de arquivos do PAF com assinatura EAD, porém não estou conseguindo configurar a chave RSA.

Não consegui encontrar nenhum lugar nas configurações para informá-la.

Na documentação não encontrei nada.

Quando chamo o comando ocorre o seguinte erro:

ECF.PafMF_LMFS_Espelho("01/08/2016", "21/08/2016", "D:\EspLMFSPeriodo.txt")
ERRO: Chave RSA Privada não especificada.
- Selecione a aba "Chave RSA"
- Calcule sua Chave Privada
- Salve as configurações
- Distribua a sua Chave Privada com o arquivo 
  criptografado "swh.ini"

Já fiz o cadastro básico na sessão "Configurações > Cadastros > Software House" informando:

- Razao social

- CNPJ

- Aplicativo

- Numero

- Versao

 

Preciso informar mais coisas? O que posso fazer para resolver isso?

  • Like 1
Link to comment
Share on other sites

  • 4 weeks later...
  • Solution

Como sou de Santa Catarina, infelizmente temos que usar PAF-ECF, e neste caso não tenho como não usar o recurso de EAD.

Acabei de descobrir desbravando os fontes do ACBr Monitor Plus como configurar ela, segue o passo à passo:

  • Entre nas configurações do ACBr Monitor Plus
  • Vá até a sessão "RFD"
  • Selecione a checkbox "GerarRFD"
  • Clique em salvar
  • Provavelmente você será redirecionado para a sessão "Monitor" (se não for, passe ao próximo item)
    • Neste momento é necessário informar uma senha de sua preferência na opção "Proteger Configurações"
    • Esta senha serve para criptografar a sua chave privada dentro das configurações, assim ninguém terá acesso à ela sem esta senha
    • Clique em salvar
  • Agora você vai ser redirecionado para a sessão secreta "Cadastros > Software House"
    • Nessa sessão vai ter um texto informando "ATENÇÃO: Chave RSA Privada NÃO pode ser lida no arquivo "swh.ini"."
    • Se você já tem uma chave RSA, clique no botão Importar e a selecione
    • Se não, clique em "Gerar Chave Privada"
    • Vai aparecer ali no campo, no lugar do texto, a chave RSA
  • Clique novamente em Salvar para concluir a configuração
  • Pronto, agora você já pode assinar os arquivos com o EAD

Se esqueci de algo, por favor me corrijam. 

Obrigado.

  • Like 2
Link to comment
Share on other sites

  • Este tópico foi criado há 2117 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.