Ir para conteúdo
  • Cadastre-se

Recommended Posts

ACBrMonitorPLUS - SAC

Visulizar Arquivo

ACBrMonitorPLUS - Última versão disponível apenas a usuários do SAC.

- Versão oficial compilada pela equipe do ACBr. Assinada digitalmente com o certificado da DJSystem.


 

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 29/09/2016 at 10:31, Celso disse:

ACBrMonitorPLUS - SAC

Visulizar Arquivo

ACBrMonitorPLUS - Última versão disponível apenas a usuários do SAC.

- Versão oficial compilada pela equipe do ACBr. Assinada digitalmente com o certificado da DJSystem.


 

@José M. S. Junior, obrigado pela dica, mas não deu certo.

Fiz o procedimento seguindo o PDF que vc mandou, mas não resolveu, se quiser mando as imagens da configuração pra ver se está tudo certo e o cupom impresso.

Detalhe, observa que não corta no final, corta os itens do 42 ao 47 e finaliza o danfe normal.

Se for preciso eu envio a minha impressora pra vocês testarem aí com o XML que anexei, acabei de receber outra reclamação de cliente dizendo que o "cupom" saiu incompleto.

 

erro impressão nfce em mais de uma linha.txt

52171126948596000140650010000018019000179127-NFE.XML

Compartilhar este post


Link para o post
Compartilhar em outros sites
41 minutos atrás, lfernandolopes disse:

Detalhe, observa que não corta no final, corta os itens do 42 ao 47 e finaliza o danfe normal.

Isso mesmo, realizei teste aqui com o seu XML e com a mesma impressora MP-4200 TH. Esse problema aconteceu aqui também... devido a configuração do driver da impressora. Fazendo esse procedimento resolveu...

Veja abaixo como deve ficar, depois configure em (Preferências de Impressão) e (Propriedades da Impressora) com a nova configuração do Tamanho do Papel. Encerre o ACBrMonitor e execute novamente antes imprimir.

Cupom.png

MP4200.png

  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
16 minutos atrás, José M. S. Junior disse:

Isso mesmo, realizei teste aqui com o seu XML e com a mesma impressora MP-4200 TH. Esse problema aconteceu aqui também... devido a configuração do driver da impressora. Fazendo esse procedimento resolveu...

Veja abaixo como deve ficar, depois configure em (Preferências de Impressão) e (Propriedades da Impressora) com a nova configuração do Tamanho do Papel. Encerre o ACBrMonitor e execute novamente antes imprimir.

Cupom.png

MP4200.png

Deu certo, eu não havia reiniciado o ACBrMonitor. Muito obrigado.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
36 minutos atrás, Racional Mario disse:

Amigo gostaria de baixar a versão do acbr para emitir notas fiscais e implementar no meu sistema .. 

o que eu preciso fazer ???  é só pagar o SAC ?

 

Pra ter acesso ao ACBrMonitor compilado semanalmente você precisa contratar o ACBrSAC.

Veja os links:

Sobre o ACBr SAC.

Para cadastrar.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 29/09/2016 at 10:31, Celso disse:

ACBrMonitorPLUS - SAC

Visulizar Arquivo

ACBrMonitorPLUS - Última versão disponível apenas a usuários do SAC.

- Versão oficial compilada pela equipe do ACBr. Assinada digitalmente com o certificado da DJSystem.


 

@Celso,   boa tarde, a impressão do logo da NFc-e tinha sido corrigido e voltou com problemas a partir da penúltima versão liberada.

O que saiu inteiro é a versão 1.1.0.33-20170905, o que está errado é a atual, verifique por favor.

Outra coisa, para cupons com muitos itens, conforme eu reclamei anteriormente, só com o ACBr acontece de cortar itens, eu testei com várias outras soluções, mas não queria substituir o ACBrMonitor, uso faz muitos anos e sou fã, veja o que consegue por favor, se quiser até te mando uma solução que recebi para testes com um XML que "come" itens.

Aguardo retorno, obrigado.

 

Nfce antes.jpg

NFC-e.jpg

Compartilhar este post


Link para o post
Compartilhar em outros sites
27 minutos atrás, lfernandolopes disse:

O que saiu inteiro é a versão 1.1.0.33-20170905, o que está errado é a atual, verifique por favor.

Boa tarde, não houve alterações recentes quanto ao logo, pode ser o tamanho da imagem. Por favor anexe o logo que está utilizando para que possamos testar.

 

28 minutos atrás, lfernandolopes disse:

Outra coisa, para cupons com muitos itens, conforme eu reclamei anteriormente, só com o ACBr acontece de cortar itens, eu testei com várias outras soluções, mas não queria substituir o ACBrMonitor, uso faz muitos anos e sou fã, veja o que consegue por favor, se quiser até te mando uma solução que recebi para testes com um XML que "come" itens.

Verifique se ao visualizar em tela ocorre o corte dos itens. Se na visualização estiver ok é configuração da impressora conforme descrito acima (Pode ocorrer com algumas impressoras, sendo necessário configurá-las). Se possível anexe também o xml para verificação.  

Compartilhar este post


Link para o post
Compartilhar em outros sites
22 minutos atrás, José M. S. Junior disse:

Boa tarde, não houve alterações recentes quanto ao logo, pode ser o tamanho da imagem. Por favor anexe o logo que está utilizando para que possamos testar.

 

Verifique se ao visualizar em tela ocorre o corte dos itens. Se na visualização estiver ok é configuração da impressora conforme descrito acima (Pode ocorrer com algumas impressoras, sendo necessário configurá-las). Se possível anexe também o xml para verificação.  

@José M. S. Junior, em anexo a imagem, mas se vc observar eu mandei a imagem do cupom com a versão 1.1.0.33-20170905 que citei e com a última versão disponibilizada, com a mesma configuração e a mesma imagem. Mas de qualquer forma segue em anexo.

O tamanho da imagem é de 8 cm de largura (feito pelo Photoshop).

Quanto aos itens que citei, eu fiz uma configuração na Bematech MP-4200 TH e deu certo, na Epson TM T20 não consegui, mas como eu disse, testando outras soluções, imprime o cupom inteiro, sem mexer em nenhuma configuração da impressora.

Desculpe a insistência, quero continuar usando o ACBrMonitor, mas em supermercados que geralmente tem muitos itens tenho vários problemas. Aí tenho que pegar o XML e mandar imprimir por outro aplicativo.

Mais uma observação, nos itens do Danfe NFC-e o valor total está desalinhado, sendo impresso parte embaixo do valor unitário, verifique por favor no Danfe que enviei.

Se precisar de mais alguma informação ou algum arquivo só dizer.

Obrigado

 

 

 

 

52171126948596000140650010000018019000179127-NFE.XML

ACBrMonitor.ini

LogoNFCe.png

Tamanho da imagem.jpg

Faltou anexar a imagem mostrando o tamanho do logo.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa tarde 

Note que na imagem anexa onde está editando o logo,  a dimensão é de 472 pixels (muito grande para o cupom), deixe com a mesma configuração do campo "largura" do ACBrMonitor: 302 pixels. (Configure em pixels) Lembrando que nas versões atuais do componente NFCe o usuário define o tamanho do logo, se desejar deixar a imagem bem pequena é possível, porém se a imagem for muito grande vai ultrapassar os limites do cupom...

Quanto a impressão,  fique a vontade para postar as sugestões... mas chegou a realizar testes com a configuração EscPos? Vale considerar pois evitará problemas com configurações de impressora, a impressão é via comandos.logo.png

 

monitor.png

 

 

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
7 minutos atrás, José M. S. Junior disse:

Boa tarde 

Note que na imagem anexa onde está editando o logo,  a dimensão é de 472 pixels (muito grande para o cupom), deixe com a mesma configuração do campo "largura" do ACBrMonitor: 302 pixels. (Configure em pixels) Lembrando que nas versões atuais do componente NFCe o usuário define o tamanho do logo, se desejar deixar a imagem bem pequena é possível, porém se a imagem for muito grande vai ultrapassar os limites do cupom...

Quanto a impressão,  fique a vontade para postar as sugestões... mas chegou a realizar testes com a configuração EscPos? Vale considerar pois evitará problemas com configurações de impressora, a impressão é via comandos.logo.png

 

monitor.png

 

 

 

 

@José M. S. Junior, obrigado pelo retorno. Consegui ajustar o logo alterando em píxeis. Quanto ao Danfe com muitos itens eu estou desenvolvendo outra solução, vou usar a impressão do ACBr, só em alguns casos.

Mas você verificou o alinhamento do valor total do item?

Aguardo, abraço.

 

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 29/09/2016 at 10:31, José M. S. Junior disse:

ACBrMonitorPLUS - SAC

Visulizar Arquivo

ACBrMonitorPLUS - Última versão disponível apenas a usuários do SAC.

- Versão oficial compilada pela equipe do ACBr. Assinada digitalmente com o certificado da DJSystem.


 

 

Bom dia, coloquei isso nos comentários, mas acho que foi em lugar errado.

Baixei a última versão, aACBrMonitorPLUS-1.2.0.0-20180522-Windows-Instalador.exe.zip e ao utilizar o comando NFe.SetFormaEmissao("1") gerando o arquivo ent01.txt ele retorna sai.txt e não sai01.txt como deveria.

Não encontrei mais nenhum outro comando com esse erro, mas seria bom revisar todos.

Obrigado.

 

 


 

 

Editado por lfernandolopes

Compartilhar este post


Link para o post
Compartilhar em outros sites
3 horas atrás, lfernandolopes disse:

Baixei a última versão, aACBrMonitorPLUS-1.2.0.0-20180522-Windows-Instalador.exe.zip e ao utilizar o comando NFe.SetFormaEmissao("1") gerando o arquivo ent01.txt ele retorna sai.txt e não sai01.txt como deveria.

Estou verificando... Se possível anexe seu arquivo ACBrMonitor.ini, para facilitar simulação do problema.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom dia! 
A versão 1.2.0.0-20180522 realmente estava com este probleminha. 
O José disponibilizou a 1.2.0.1-20180523 (hoje)  e nesta não deu o problema. 
Por favor baixe a nova versão e volte a testar.

Compartilhar este post


Link para o post
Compartilhar em outros sites
1 minuto atrás, Kiko Fernandes disse:

Bom dia! 
A versão 1.2.0.0-20180522 realmente estava com este probleminha. 
O José disponibilizou a 1.2.0.1-20180523 (hoje)  está não foi encontrado o problema. 
Por favor baixe a nova versão e volte a testar.

Bom dia, já baixei e testei, está OK..

Muito obrigado.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Srs Bom dia , 

estou usando o acbrnfemonitorplus v1.2.0.2 com certificado A3, ja a dias estou lendo posts e tentando estabelecer conexão com WS em homologação sem sucesso. de antemão posso adiantar q testei muitas variações de configuracões. alem disso quando mando consulta de status em producao funciona normal, inclusive consigo emitir a NFe em produção. estou precisando fazer testes para NFe 4.0 para tal preciso funcionar em homologação. 

 

quando uso config: libWinCrypt nao consigo consultar nem em producao. so consegui fazer funcionar usando libCapicom

nas configuracoes de internet ja testei todas as variações ssl tls 


23/05/2018 10:07:52 - WebService Consulta Status serviço:
- Inativo ou Inoperante tente novamente.
Erro Interno: 12029
Erro HTTP: 0
Erro: Requisição não enviada.
Erro: 12029 - Conexão com o Servidor falhou

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

uma outra questão q estou com duvida é a respeito do FCP , fiz alguns ajustes para o sistema mandar as tags FCP conforme a NT_2016_002_v1.42, porem após a validação do xml pelo monitor essas tags foram retiradas do xml, neste caso a emissão foi de uma empresa simples nacional para o csosn 500 , venda dentro do estado, pelo q entendi na NT devera ser obrigatorio. 

vou anexar os arquivos. 

de antemão agradeço pela atenção. 

000000205.xml

35180513441937000144550010000002041000000047-nfe.xml

Compartilhar este post


Link para o post
Compartilhar em outros sites

Por favor, abra um tópico para cada assunto, para não poluir.

53 minutos atrás, nanosolusoftsuporte disse:

quando uso config: libWinCrypt nao consigo consultar nem em producao. so consegui fazer funcionar usando libCapicom

Usando WinCrypt e OpenSSL você deve alterar a configuração "SSL Type" no ACBrMonitorPLUS.

Apenas CAPICOM (SSL HttpLib = httpWinInet ou httpIndy) depende das configurações do IE.

17 minutos atrás, nanosolusoftsuporte disse:

uma outra questão q estou com duvida é a respeito do FCP , fiz alguns ajustes para o sistema mandar as tags FCP conforme a NT_2016_002_v1.42, porem após a validação do xml pelo monitor essas tags foram retiradas do xml, neste caso a emissão foi de uma empresa simples nacional para o csosn 500 , venda dentro do estado, pelo q entendi na NT devera ser obrigatorio. 

Atenção para a atualização da NT: a última versão dela é a 2016.002 v.1.51.

As tags aceitas para o CSOSN 500 são vBCFCPSTRet, pFCPSTRet e vFCPSTRet. Da forma informada no teu XML elas serão ignoradas mesmo.

Novamente, se ainda tiver problemas, abra um novo tópico.

  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

boa tarde , usando ssl lib :=libWinCrypt consigo comunicação com WS ate o nivel LT_TLSv1_1 ja 1_2 nao funciona. Agora usando em homologacao nao funciona em nenhum.  

estou usando o windows 8.1 porém eu não atualizo , pode ser problema com a crypt32.dll ? 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 25/05/2018 at 16:48, nanosolusoftsuporte disse:

boa tarde , usando ssl lib :=libWinCrypt consigo comunicação com WS ate o nivel LT_TLSv1_1 ja 1_2 nao funciona. Agora usando em homologacao nao funciona em nenhum.  

estou usando o windows 8.1 porém eu não atualizo , pode ser problema com a crypt32.dll ? 

 

A WinCrypt utiliza dlls nativas do Windows é importante estar atualizado para funcionar com TLS1_2. Atualize também os fontes, houve atualizações recente nas URLs.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom dia,  Estou tendo  rejeição 806 Operação com ICMS-ST sem informação do CEST em qualquer versão 3.10 ou 4.00. Estou informando a tag CEST mais o monitor não está gerando ela no xml.

Alguém sabe se é algum erro, ou tenho que especificar algumas coisa a mais pra poder aceitar?

58-1.ini

Editado por mearimsistemas
correção ortografica

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caros, boa tarde.

 

Alguém poderia me passar um código em c# para geração do arquivo .INI, semelhante ao do DELPHI, que já trata tudo, inclusive, eu acho, que trata té para postos de combustível.

Desde já agradeço.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora

×