Jump to content

2 Dia do ACBr

Ingressos esgotados! Agradecemos a todos os inscritos.
Site do Evento

Nova Loja Oficial
loja.projetoacbr.com.br
Ajude o projeto a crescer, com estilo

Comprar

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

Nelson  A Sousa

Erro ao gerar novo instalador

Recommended Posts

Olá,

Ao gerar um novo arquivo de instalação com o ACBrMonitorPLUS.iss ao final da instalação não consigo rodar o AcbrMonitorPlus pois acontece um erro, conforme a imagem anexo.

No arquivo ISS só fiz 2 alterações, comentei as linhas:

;SignTool=Standard /d $qACBrMonitorPLUS - SAC ACBr$q /du $qhttp://www.projetoacbr.com.br$q $f
;Source: {#ACBrDIR}\Exemplos\ACBrSerial\ACBrECF\Lazarus\ECFTeste.exe; DestDir: {app}; Flags: ignoreversion sign; Components: programa
 

Alguém pode me dar uma ajuda?

erro.jpg

  • Like 1

Share this post


Link to post
Share on other sites

Olha funciona  100% o executável gerado no SAC e é o mesmo!

a única coisa pode acontecer é seus pacotes e lazarus estarem bugados ou usando versão errada do mesmo.


Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP

Share this post


Link to post
Share on other sites

Estou baixando a versão 1.6.2 do Lazarus.

Vou tentar refazer a coisa toda, e ver no que dá.

Volto neste mesmo tópico para dar uma resposta.

Existe uma sequencia correta para instalação dos pacotes?

Edited by Nelson A Sousa

Share this post


Link to post
Share on other sites

Tudo o que você precisa saber sobre a instalação e configuração, esta nesse video:

http://www.infocotidiano.com.br/2016/05/instalando-componentes-acbr-no-lazarus.html


Att, 
 
Vinicius Gonçalves | Engenheiro de Software 
LogoEmail.png [email protected] 
  

LogoMs.png 

 

Antes de imprimir, pense na sua responsabilidade e compromisso com o Meio Ambiente.
        Já imprimiu? Utilize o verso. 

Share this post


Link to post
Share on other sites

Olá, 

Obrigado pelas dicas.

Instalei tudo e compilei.

A compilação foi efetuada sem erros, gerou o executável do AcbrMonitorPlus, porém o erro acima persiste.

Creio ser alguma configuração nas opções do projeto. Vi que o Lazarus permite importar essas opções.

Como sou usuário C# .net, não tenho muita intimidade com o Lazarus.

Alguém poderia disponibilizar o arquivo das configurações/opções do projeto para eu importar?

Vejam o erro abaixo:

 

erro.jpg

Share this post


Link to post
Share on other sites
2 horas atrás, Nelson A Sousa disse:

Olá, 

Obrigado pelas dicas.

Instalei tudo e compilei.

A compilação foi efetuada sem erros, gerou o executável do AcbrMonitorPlus, porém o erro acima persiste.

Creio ser alguma configuração nas opções do projeto. Vi que o Lazarus permite importar essas opções.

Como sou usuário C# .net, não tenho muita intimidade com o Lazarus.

Alguém poderia disponibilizar o arquivo das configurações/opções do projeto para eu importar?

Vejam o erro abaixo:

 

erro.jpg

Boa tarde

se não tem muita intimidade com o Lazarus queria convidar a conhecer o SAC!

http://www.projetoacbr.com.br/forum/sacv2/sobre/


Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP

Share this post


Link to post
Share on other sites

Depois de muito tempo acordadoooo...

Já cansado de tanto sofrer...

Essa noite vou dormir um pouquinhooo...rsrsrs

 

Descobri onde estava o erro, a linha abaixo do arquivo ACBrMonitorPLUS.iss estava setada na pasta ..\32\..

Source: {#ACBrDIR}\DLLs\XMLSec\MinGW\64\*.dll; DestDir: {app}; Components: programa
 

Fiz a mudança pra 64 e funcionou legal...

Desculpem a brincadeira...é alegria de ter conseguido.

Obrigado a todos pela ajuda.

Tópico resolvido!

Edited by Nelson A Sousa

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...