Jump to content

Promoção 25 Anos de Delphi
25% de desconto em todas as versões

Saiba mais

Ganhe o curso Tributação NF-e para Desenvolvedores

Assinando o SAC Anual este mês
botao.png

 

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba Mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

André Ferreira de Moraes

Integrador Fiscal MFE Ceará - Como usar com o ACBr

Recommended Posts

4 minutos atrás, André Ferreira de Moraes disse:

Poste os passos para reproduzir o problema utilizando o demo.

Deu certo!

Exclui a pasta ACBrSAT deste caminho e atualizei novamente e funcionou.
C:\Acbr_XE7\Exemplos\ACBrSAT\

Obg.

Share this post


Link to post
Share on other sites
Em 28/04/2017 at 09:32, André Ferreira de Moraes disse:

O que é perceptível é q o integrador demora alguns segundos(em média 3 segundos) para apagar o arquivo da pasta input, se a leitura fosse mais rápida talvez o tempo de emissão fosse ainda menor.

Está em testes uma nova versão do Integrador que baixa esse tempo para menos de 1 segundo, nao importando se o cupom tem 1 ou 50 itens. Tiraram o java, o negocio decolou kkkk

  • Like 2

Share this post


Link to post
Share on other sites
4 horas atrás, Janio disse:

Está em testes uma nova versão do Integrador que baixa esse tempo para menos de 1 segundo, nao importando se o cupom tem 1 ou 50 itens. Tiraram o java, o negocio decolou kkkk

As alterações para utilizar o MF-e-Giz já estão no SVN.


djsystem-logo.png
 youtube.png facebook.png instagram.png linkedin.png
André Ferreira de Moraes | Analista de Sistemas
www.djsystem.com.br | www.djpdv.com.br
www.automacaototal.com.br

Share this post


Link to post
Share on other sites

Bom dia, atualizei agora e está dando erro aqui: property XML : String read FXML write SetXMLString;

[dcc32 Error] pcnVFPe.pas(294): E2008 Incompatible types
[dcc32 Fatal Error] pcnVFPe.pas(2317): F2063 Could not compile used unit 'pcnVFPeW.pas'

mudando o setxmlString pra XML funciona, tenho que fazer algo ou está realmente errado?

 

Share this post


Link to post
Share on other sites
7 horas atrás, André Ferreira de Moraes disse:

As alterações para utilizar o MF-e-Giz já estão no SVN.

Estas alterações no nome para -Giz são apenas para efeito de teste, quando for lançado o Release com as modificações o nome deve voltar ao que era sem o -Giz!

 

Share this post


Link to post
Share on other sites
1 hora atrás, Giovanne Fontenele Trevia disse:

O meu aconteceu o problema

eu simplesmente reinstalei e pronto estava resolvido

Colega o meu está com o mesmo problema, removi e instalei mas não de certo.

pcnVFPe.pas(113) Error: E2008 Incompatible types


Obrigado a todos!

Share this post


Link to post
Share on other sites
1 minuto atrás, eduardo.mrj disse:

Colega o meu está com o mesmo problema, removi e instalei mas não de certo.

pcnVFPe.pas(113) Error: E2008 Incompatible types

Atualize seus fontes e teste novamente.


djsystem-logo.png
 youtube.png facebook.png instagram.png linkedin.png
André Ferreira de Moraes | Analista de Sistemas
www.djsystem.com.br | www.djpdv.com.br
www.automacaototal.com.br

Share this post


Link to post
Share on other sites
27 minutos atrás, André Ferreira de Moraes disse:

Atualize seus fontes e teste novamente.

Já havia atualizado mais cedo, atualizei novamente, deu certo, valeu André.


Obrigado a todos!

Share this post


Link to post
Share on other sites

Boa tarde,

Estou em processo de adequação do sistema para comunicação com o Integrador e estou com as seguintes dificuldades:

Envio a venda da seguinte forma:

    PreencheCFe;

    xml := ACBrSAT1.CFe.GerarXML( True );

    ACBrSAT1.IniciaComando;
    ACBrSAT1.FinalizaComando( TACBrSATMFe_integrador_XML(ACBrSAT1.SAT).EnviarDadosVenda(xml));

Xml de Venda e de Retorno em anexo.

 Até ai tudo bem.

Só que na hora de imprimir

ACBrSAT1.ImprimirExtrato;

É retornado o seguinte: Nenhum CFe carregado na memória.

Identifiquei que no método VerificaCondicoesImpressao existe o seguinte:

if (CFe.infCFe.ID = '') then
      raise EACBrSATErro.Create( 'Nenhum CFe carregado na memória' ) ;

1ª pergunta: Onde essa variável é preenchida? Deveria informar o numero sessão para ela?

2ª pergunta: Caso na hora da impressão não tenha comunicação com a impressora, como poderia proceder para reimprimir um CFe? Pois o integrador consome o XML de venda e apaga da Pasta Input, assim como apaga o retorno na Pasta Output. Gravo o Xml de Venda assim como o Retorno em outras Pastas?

Obs: Estou utilizando ACBrSATExtratoFortes para impressão.

Desde já agradeço a atenção.

Att,

db8ab1ffba4f4aafb874ec9c31d8b1ed20170504164741.xml

EnviarDadosVenda-104881.xml

Share this post


Link to post
Share on other sites

Pessoal, Alguém está conseguindo fazer o SATTeste (exemplo) funcionar com o VFP-e? Como deve ser o procedimento ?

Edited by eduardo.mrj

Obrigado a todos!

Share this post


Link to post
Share on other sites
5 horas atrás, eduardo.mrj disse:

Pessoal, Alguém está conseguindo fazer o SATTeste (exemplo) funcionar com o VFP-e? Como deve ser o procedimento ?

Basta seguir o descrito neste post: 

 

8 horas atrás, Alisson CRT SISTEMAS disse:

 

    PreencheCFe;

    xml := ACBrSAT1.CFe.GerarXML( True );

    ACBrSAT1.IniciaComando;
    ACBrSAT1.FinalizaComando( TACBrSATMFe_integrador_XML(ACBrSAT1.SAT).EnviarDadosVenda(xml));

 

Vc não precisa chamar o IniciaComando e FinalizaComando.


djsystem-logo.png
 youtube.png facebook.png instagram.png linkedin.png
André Ferreira de Moraes | Analista de Sistemas
www.djsystem.com.br | www.djpdv.com.br
www.automacaototal.com.br

Share this post


Link to post
Share on other sites

@André Ferreira de Moraes eu até segui e está em parte funcionando só que quando mando o pagamento fica aguardando e alterei o fonte do teste e está retornando um except informando que o integrador não respondeu;

Amanhã (mais tarde) posto o xml enviado.

Consigo receber a consulta do SAT e estado operacional, então ele está respondendo.

E se mando sem o envio pagamento retorna erro que os valores de pagamento não bate.

Edited by eduardo.mrj

Obrigado a todos!

Share this post


Link to post
Share on other sites

Eu consegui passar pela parte dos pagamento. Só que quando eu vou enviar os dados da venda, retorna a mensagem MÓDULO NÃO RESPONDE. Um detalhe é que estou sem o aparelho do sat. Mas copiei o debug.dbg para a pasta do integrador e nada.

Share this post


Link to post
Share on other sites
52 minutos atrás, magnosystem disse:

Eu consegui passar pela parte dos pagamento. Só que quando eu vou enviar os dados da venda, retorna a mensagem MÓDULO NÃO RESPONDE. Um detalhe é que estou sem o aparelho do sat. Mas copiei o debug.dbg para a pasta do integrador e nada.

Aparentemente a versão 1.6.86 não está respeitando o arquivo debug.dbg


djsystem-logo.png
 youtube.png facebook.png instagram.png linkedin.png
André Ferreira de Moraes | Analista de Sistemas
www.djsystem.com.br | www.djpdv.com.br
www.automacaototal.com.br

Share this post


Link to post
Share on other sites
15 horas atrás, eduardo.mrj disse:

@André Ferreira de Moraes eu até segui e está em parte funcionando só que quando mando o pagamento fica aguardando e alterei o fonte do teste e está retornando um except informando que o integrador não respondeu;

Amanhã (mais tarde) posto o xml enviado.

Consigo receber a consulta do SAT e estado operacional, então ele está respondendo.

E se mando sem o envio pagamento retorna erro que os valores de pagamento não bate.

Foi bobeira minha está funcionando tudo ok, até o momento.


Obrigado a todos!

Share this post


Link to post
Share on other sites
4 horas atrás, André Ferreira de Moraes disse:

Aparentemente a versão 1.6.86 não está respeitando o arquivo debug.dbg

Instalei a versão 1.5.86 e a resposta mudou quando eu envio a venda.

RESPOSTA: NOCONNECT

E logo depois quando clico em RESPOSTAFISCAL me retorna isto:

  Gravando XML Venda enviado: C:\MagnoSystem\Dropbox\Componentes\ACBr\Exemplos\ACBrSAT\Delphi\Enviado\08723218000186\201705\AD20170505202242-024262-env.xml
NumeroSessao: 24262 - Resposta:NOCONNECT
NumeroSessao: 345324
RespostaFiscal( <Integrador><Identificador><Valor>345324</Valor></Identificador><Componente Nome="VFP-e"><Metodo Nome="RespostaFiscal"><Construtor><Parametros><Parametro><Nome>chaveAcessoValidador</Nome><Valor>25CFE38D-3B92-46C0-91CA-CFF751A82D3D</Valor></Parametro></Parametros></Construtor><Parametros><Parametro><Nome>idFila</Nome><Valor>1674068</Valor></Parametro><Parametro><Nome>ChaveAcesso</Nome><Valor>35170408723218000186599000113100000279731880</Valor></Parametro><Parametro><Nome>Nsu</Nome><Valor>1674068</Valor></Parametro><Parametro><Nome>NumerodeAprovacao</Nome><Valor>1234</Valor></Parametro><Parametro><Nome>Bandeira</Nome><Valor>VISA</Valor></Parametro><Parametro><Nome>Adquirente</Nome><Valor>STONE</Valor></Parametro><Parametro><Nome>CNPJ</Nome><Valor>08723218000186</Valor></Parametro><Parametro><Nome>ImpressaoFiscal</Nome><Valor/></Parametro><Parametro><Nome>NumeroDocumento</Nome><Valor>1674068</Valor></Parametro></Parametros></Metodo></Componente></Integrador> )
NumeroSessao: 345324 - Resposta:<?xml version="1.0" encoding="utf-8"?>
<Integrador>
  <Identificador>
    <Valor>345324</Valor>
  </Identificador>
  <IntegradorResposta>
    <Codigo>AP</Codigo>
    <Valor>Arquivo processado</Valor>
  </IntegradorResposta>
  <Resposta>
    <retorno>1454</retorno>
  </Resposta>
</Integrador>

Ainda não consegui pelo demo imprimir o comprovante.

 

Share this post


Link to post
Share on other sites

Olá,

Antes da atualização do Integrador, estava com tudo funcionando utilizando os componentes ACBr.

Fiz a atualização dos componentes, integrador e driver da MFe e quando tento enviar a venda, sempre da a exception Sem resposta do Integrador, mesmo gerando o xml de resposta. Alguem saberia me dizer o que seria?

 

Share this post


Link to post
Share on other sites

Afinal de contas, tem como trabalhar sem o equipamento. Voltei a versão do integrador para 1.5 e agora me retorna NOCONNECT. O monitor MFE fica desconectado mesmo ? Estou meio perdido sobre a forma correta de testar as rotinas sem o equipamento.

4 horas atrás, igorc disse:

Olá,

Antes da atualização do Integrador, estava com tudo funcionando utilizando os componentes ACBr.

Fiz a atualização dos componentes, integrador e driver da MFe e quando tento enviar a venda, sempre da a exception Sem resposta do Integrador, mesmo gerando o xml de resposta. Alguem saberia me dizer o que seria?

 

Eu acredito que seja o que o André falou. A última versão do integrador não reconhece o arquivo DEBUG.DBG. Estava tendo este problema e essa exception sumiu quando reinstalei a penúltima versão do integrador. Agora dá NOCONNECT.

Share this post


Link to post
Share on other sites
16 horas atrás, magnosystem disse:

Afinal de contas, tem como trabalhar sem o equipamento. Voltei a versão do integrador para 1.5 e agora me retorna NOCONNECT. O monitor MFE fica desconectado mesmo ? Estou meio perdido sobre a forma correta de testar as rotinas sem o equipamento.

Eu acredito que seja o que o André falou. A última versão do integrador não reconhece o arquivo DEBUG.DBG. Estava tendo este problema e essa exception sumiu quando reinstalei a penúltima versão do integrador. Agora dá NOCONNECT.

Para funcionar com as versões anteriores a 1.6.86, abra o arquivo ACBrSATMFe_integrador.pas, altere a linha "cNomeComponente = 'MF-e-Giz';" para "cNomeComponente = 'MF-e';"  e recompile o pacote ACBrSAT


djsystem-logo.png
 youtube.png facebook.png instagram.png linkedin.png
André Ferreira de Moraes | Analista de Sistemas
www.djsystem.com.br | www.djpdv.com.br
www.automacaototal.com.br

Share this post


Link to post
Share on other sites
1 hora atrás, André Ferreira de Moraes disse:

Para funcionar com as versões anteriores a 1.6.86, abra o arquivo ACBrSATMFe_integrador.pas, altere a linha "cNomeComponente = 'MF-e-Giz';" para "cNomeComponente = 'MF-e';"  e recompile o pacote ACBrSAT

Oi André. Vi este seu comentário no outro grupo de MFE e segui esta orientação. Fiquei no seguinte cenário:

1 - Instalei a versão 1.5 do validador (penúltima versão) juntamente com a última versão do módulo.

2 - Criei o arquivo debug.dbg na pasta do validador.

3 - Alterei a linha "cNomeComponente = 'MF-e-Giz';" para "cNomeComponente = 'MF-e'

Com este exemplo consegui fechar uma venda sem passar velo VFP-e tanto no programa exemplo do acbr como no meu sistema e ambos imprimiram o mesmo cupom onde consta um adoçante, juntamente com um pagamento em cartão (embora eu tenha fechado em dinheiro) e como emissor do cupom a TANCA. Independente dos itens que eu passo, o cupom é sempre este. Acredito que seja o próprio integrador que retorne este cupom, estou correto?

O próximo passo agora é passar pelo VFP-e e imprimir o cupom. Após feito isto, sem o aparelho de MFE como eu faço para homologar meu sistema no CE. Pelo que entendi me parece que tem que ser enviada uma venda para lá e só conseguiria isto com o aparelho, correto?

Share this post


Link to post
Share on other sites
Agora, magnosystem disse:

Com este exemplo consegui fechar uma venda sem passar velo VFP-e tanto no programa exemplo do acbr como no meu sistema e ambos imprimiram o mesmo cupom onde consta um adoçante, juntamente com um pagamento em cartão (embora eu tenha fechado em dinheiro) e como emissor do cupom a TANCA. Independente dos itens que eu passo, o cupom é sempre este. Acredito que seja o próprio integrador que retorne este cupom, estou correto?

O modo debug do emulador sempre retorna o mesmo XML, então não importa a venda que vc envie, sempre receberá a mesma resposta.

1 minuto atrás, magnosystem disse:

O próximo passo agora é passar pelo VFP-e e imprimir o cupom. Após feito isto, sem o aparelho de MFE como eu faço para homologar meu sistema no CE. Pelo que entendi me parece que tem que ser enviada uma venda para lá e só conseguiria isto com o aparelho, correto?

Não fazem nenhum teste referente a verificar se a venda chegou realmente lá. Eles testam venda com dinheiro, cancelamento, venda com cartão informado no POS e como seu programa se comporta na ausência do Integrador.


djsystem-logo.png
 youtube.png facebook.png instagram.png linkedin.png
André Ferreira de Moraes | Analista de Sistemas
www.djsystem.com.br | www.djpdv.com.br
www.automacaototal.com.br

Share this post


Link to post
Share on other sites
1 minuto atrás, magnosystem disse:

E como é feita esta homologação ? Com um técnico disponibilizado por eles de maneira remota ?

Fiz com o Luiz Abade via Team Viewer.


djsystem-logo.png
 youtube.png facebook.png instagram.png linkedin.png
André Ferreira de Moraes | Analista de Sistemas
www.djsystem.com.br | www.djpdv.com.br
www.automacaototal.com.br

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...