Jump to content

Delphi chamada_delphi.png acbr.png

C6 chamada_c6.png botao.png

erro obter a Chave Publica de <erro x509Certificate>


  • Este tópico foi criado há 1687 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Membros Pro

Boa tarde.

Estou com um cliente que faz NFe de remessa de produtor rural e ao assinar a NFe dá a seguinte mensagem :

erro obter a Chave Publica de <erro x509Certificate>

Porém este mesmo cliente já fez 51 notas sem nenhum erro, começou a dar o erro do nada.

Segue em anexo o .XML 35171001723510000150550010000000521000000524-nfe.xml da nota.

Incluso também o .TXT 35171001723510000150550010000000521000000524-nfe.txt

O que pode ser ?

_____________________________________

Junior - Rhovanion Tecnologia

(11) 4224.6543

Link to comment
Share on other sites

  • Membros Pro
44 minutos atrás, José M. S. Junior disse:

Bom dia, em que momento ocorre esse erro? pois está gerando a chave do certificado no XML. É possível simular esse erro utilizando o ACBrNFeDemo ?

Muito obrigado por responder.

O erro ocorre ao tentar assinar a NFe. Ocorre o mesmo erro usando o ACBrNFeDemo.

_____________________________________

Junior - Rhovanion Tecnologia

(11) 4224.6543

Link to comment
Share on other sites

  • Membros Pro
1 hora atrás, José M. S. Junior disse:

Dê uma olhada nas configurações do Certificado... Qual SSLLib / XMLSignLib está utilizando? 

O XML aparentemente está ok...

Estou usando WynCript e já testei com Capicom tb.

_____________________________________

Junior - Rhovanion Tecnologia

(11) 4224.6543

Link to comment
Share on other sites

  • Membros Pro
18 minutos atrás, José M. S. Junior disse:

Qual o passo a passo que está fazendo para poder simular o erro no ACBrNFe.demo? Com esse XML apenas chamando o método Assinar aqui está realizando corretamente.

Já consegui detectar o problema. Está na instalação do certificado digital na máquina do cliente. Alguma instalação ou atualização de aplicativo está bloqueando o acesso do certificado na web.

Eu instalei o certificado digital na minha máquina aqui no escritório e copiei o banco de dados do cliente e assinou e emitiu a NFe normalmente. Estou tentando verificar o que pode ser.

Depois de muito tentar eu desinstalei todos os certificados e  reinstalei o mesmo e o erro mudou.

Agora aparece o seguinte erro :

Citar

O atributo 'Algorithm' tem valor 'http://www.w3.org/2001/04/xmldsig-more#rsa-sha256' que não corresponde ao valor fixo 'http://www.w3.org/2000/09/xmldsig#rsa-sha1' do DTD ou no esquema

O que pode ser ??

 

_____________________________________

Junior - Rhovanion Tecnologia

(11) 4224.6543

Link to comment
Share on other sites

  • Membros Pro

Atualizei as dlls sim.

Pesquisei bastante sobre o erro e ví um post aqui mesmo que fala sobre registrar as dlls

Registrei a dll msxml5.dll e funcionou. Porém fiquei surpreso, pois já havia feito o procedimento na instalação do sistema, tanto que estavam emitindo NFe normalmente. Muito estranho parar de funcionar. 

Muito Obrigado pela ajuda.

_____________________________________

Junior - Rhovanion Tecnologia

(11) 4224.6543

Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.