Jump to content
Notícias do ACBr

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


Saiba mais

beneficios.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png click.png click.png

Bloco X - Alterações no envio


Guilherme Verardi
  • Este tópico foi criado há 1270 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Recommended Posts

  Estou trabalhando em uma homologação na versão 02.05 para o estado de SC, e nos meus testes encontrei alguns erros ao tentar consumir as funções do webservice de homologação. Baseado nos problemas ocorridos, percebi que os schemas e funções do webservice foram modificadas, porém não encontrei nenhum documento esse novo layout.

  Como preciso fazer a homologação acabei fazendo alguns ajustes nos fontes do ACBr. As alterações foram as seguintes:

  ACBrBloxoX_Comum.pas:
  
  Função "GerarDadosEstabelecimento": Somente é necessário o preenchimento do campo "Ie".
  Função "GerarDadosPafECF": Somente é necessário o preenchimento do campo "NumeroCredenciamento".
  
  
  ACBrBlocoX_ReducaoZ.pas:
  
  Função "GerarXML": 
  - Somente é necessário preencher o campo "NumeroFabricacao" no bloco da ECF.
  - Campos "VendaBrutaDiaria"  e "GT", alterados para formatar o valor sem cadas decimais e com zeros a esquerda.
  
  
  ACBrBloxoX_WebServices.pas:
  - Funções "Validar" e "Enviar" unidas em uma só, pois agora como a função "Consultar", elas utilizam a mesma estrutura para Estoque ou Redução Z.

 

  No momento na função "Enviar" estou recebendo o retorno "Erro Interno: 0 Erro HTTP: 500". O que parece ser algo em relação ao arquivo de envio não estar de acordo com o esperado pelo servidor. Os arquivos estão no anexo, para alguém comitar eles e testar nos servidores de produção.

ACBrBlocoX_Comum.pas

ACBrBlocoX_ReducaoZ.pas

ACBrBlocoX_WebServices.pas

  • Thanks 1
Link to comment
Share on other sites

2 minutos atrás, Guilherme Verardi disse:

Sobre o problema do "Erro Interno: 0 Erro HTTP: 500". Acredito que tenha sido algo no servidor, pois hoje está funcionando normalmente.

Acostume-se, webservice do Bloco X funciona quando quer... Eles estão em constante mudança.

Link to comment
Share on other sites

Testei hoje pela manhã com estes fontes e funcionou. Só ainda não entendi se o quando o retorno contém o "Recibo", porém o código do "EstadoProcessamentoCodigo" é "0" significa que eles receberam. Porque pelo que vi nos documentos do bloco o código "0' seria para o status "Aguardando".

Link to comment
Share on other sites

27 minutos atrás, Guilherme Verardi disse:

Testei hoje pela manhã com estes fontes e funcionou. Só ainda não entendi se o quando o retorno contém o "Recibo", porém o código do "EstadoProcessamentoCodigo" é "0" significa que eles receberam. Porque pelo que vi nos documentos do bloco o código "0' seria para o status "Aguardando".

Então, até um tempinho atrás o meu retornava o recibo e status 0 - Aguardando no recibo, pensei que fosse demora do web service para processar, mas no dia seguinte consultei o número do recibo e retornou "Não encontrado", bem estranho.

Link to comment
Share on other sites

Agora, naiaragomesp disse:

Então, até um tempinho atrás o meu retornava o recibo e status 0 - Aguardando no recibo, pensei que fosse demora do web service para processar, mas no dia seguinte consultei o número do recibo e retornou "Não encontrado", bem estranho.

Ao consultar meu envio de hoje de manhã, esta ocorrendo a mesma coisa. Porém estou no servidor de homologação, ainda não sei como está funcionando no de produção.

Mas como o procedimento de envio retorno o recibo, parece que se houver algum problema é no próprio servidor. Acho que ainda esta passando por um processo de aprimoramento.

Link to comment
Share on other sites

A saga continua...hehe.

Agora o arquivo de retorno, dentro do bloco Result das operações teve o campo "EstadoProcessamentoCodigo" e "EstadoProcessamentoDescricao", alterado para "SituacaoProcessamentoCodigo" e "SituacaoProcessamentoDescricao" respectivamente. Segue no anexo os arquivos alterados.

ACBrBlocoX.zip

Link to comment
Share on other sites

  • Consultores
21 horas atrás, Guilherme Verardi disse:

A saga continua...hehe.

Agora o arquivo de retorno, dentro do bloco Result das operações teve o campo "EstadoProcessamentoCodigo" e "EstadoProcessamentoDescricao", alterado para "SituacaoProcessamentoCodigo" e "SituacaoProcessamentoDescricao" respectivamente. Segue no anexo os arquivos alterados.

ACBrBlocoX.zip

Desculpe mas seu código está defasado.

tirou processos que definem endereços e outras coisas.

acho que precisa rever.

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil
Link to comment
Share on other sites

30 minutos atrás, Juliomar Marchetti disse:

Desculpe mas seu código está defasado.

tirou processos que definem endereços e outras coisas.

acho que precisa rever.

Boa tarde. Mas a minha pasta "ACBrBlocoX", está na ultima revision disponível (13945).

Sobre os processos, o que fiz foi unir as funções de Consulta e Envio de Estoque e Redução Z dentro do ConsultaBlocoX e EnviaBlocoX.

Não consegui encontrar alguma função que esqueci de mover, consegue me dar um exemplo?

Link to comment
Share on other sites

Em 17/10/2017 at 09:31, Guilherme Verardi disse:

Sobre o problema do "Erro Interno: 0 Erro HTTP: 500". Acredito que tenha sido algo no servidor, pois hoje está funcionando normalmente.

Olá, para mim quando envio está dando "Erro Interno: 0 Erro HTTP: 500". pelo que li vocês comentando é um problema no servidor e é intermitente.

Pergunto: Este tipo de coisa da só em homologação ou alguém já teve isto em produção?

Link to comment
Share on other sites

1 hora atrás, Moisés disse:

Olá, para mim quando envio está dando "Erro Interno: 0 Erro HTTP: 500". pelo que li vocês comentando é um problema no servidor e é intermitente.

Pergunto: Este tipo de coisa da só em homologação ou alguém já teve isto em produção?

Sobre a sua pergunta. Ainda não consegui testar em produção, pois estou esperando a liberação do laudo para testar em um cliente.

E sobre o erro, talvez você precise recompilar os seus arquivos do ACBr, pois testei aqui no servidor de homologação e a comunicação está ocorrendo, inclusive e estou recebendo o retorno com o recibo.

Link to comment
Share on other sites

Olá Guilerme,

Desinstalei o componente do BlocoX e suas dependências. Peguei novamente o instalador (ACBrInstall_Trunk2.exe) no site. Instalei novamente. Recompilei meu projeto e continuou dando "Erro Interno: 0 Erro HTTP: 500".

Resolvi pegar o exemplo que vem no componente (ACBrBlocoXDemo) e acrescentei o envio. Deu no mesmo "Erro Interno: 0 Erro HTTP: 500"

Não sei mais o que fazer. Estou enviando o fonte (do Demo) caso você queira ver como fiz (o executável esta junto)

ACBrBlocoXDemo.rar

59f77152284db_ImagemdoErro.png.cc341c1df4e0a0780817b44987f9bf53.png

Link to comment
Share on other sites

16 horas atrás, Moisés disse:

Olá Guilerme,

Desinstalei o componente do BlocoX e suas dependências. Peguei novamente o instalador (ACBrInstall_Trunk2.exe) no site. Instalei novamente. Recompilei meu projeto e continuou dando "Erro Interno: 0 Erro HTTP: 500".

Resolvi pegar o exemplo que vem no componente (ACBrBlocoXDemo) e acrescentei o envio. Deu no mesmo "Erro Interno: 0 Erro HTTP: 500"

Não sei mais o que fazer. Estou enviando o fonte (do Demo) caso você queira ver como fiz (o executável esta junto)

ACBrBlocoXDemo.rar

59f77152284db_ImagemdoErro.png.cc341c1df4e0a0780817b44987f9bf53.png

 

Fiz umas alterações no seu Demo na opção de gerar arquivos para Estoque, seguindo o que tenho aqui na ultima versão dos arquivos. Talvez você não consiga compilar o projeto, pois utilizo o Delphi XE8, mas você vai ter um .exe e os fontes para analisar.

Uma coisa que percebi, é que talvez você esteja usando os arquivos do início do tópico, mas mais abaixo eu anexei um zip com mais algumas mudanças. Porque se você prestar atenção, não utilizo mais a função EnviarReducaoZ ou EnviarEstoque, e sim a EnviarBlocoX.

 

ACBrBlocoXDemo.zip

  • Like 1
Link to comment
Share on other sites

23 horas atrás, Moisés disse:

Olá Guilerme,

Desinstalei o componente do BlocoX e suas dependências. Peguei novamente o instalador (ACBrInstall_Trunk2.exe) no site. Instalei novamente. Recompilei meu projeto e continuou dando "Erro Interno: 0 Erro HTTP: 500".

Resolvi pegar o exemplo que vem no componente (ACBrBlocoXDemo) e acrescentei o envio. Deu no mesmo "Erro Interno: 0 Erro HTTP: 500"

Não sei mais o que fazer. Estou enviando o fonte (do Demo) caso você queira ver como fiz (o executável esta junto)

ACBrBlocoXDemo.rar

59f77152284db_ImagemdoErro.png.cc341c1df4e0a0780817b44987f9bf53.png

Você não vai mesmo conseguir enviar seus arquivos... o erro que está ocorrendo é por causa das novas alterações do web service... Esse erro acontecerá para você independente se for ambiente de homologação ou produção... Dê uma olhada nas alterações do web service e layout tbm... Ouve alteração da forma de envio... Antes as funções eram separadas por estoque e redução z, agora não é mais... 

http://webservices.sathomologa.sef.sc.gov.br/wsDfeSiv/Recepcao.asmx?op=Enviar

https://sathomologa.sef.sc.gov.br/tax.NET/sat.dfe.siv.web/xsd/reducaoz.xsd

https://sathomologa.sef.sc.gov.br/tax.NET/sat.dfe.siv.web/xsd/estoque.xsd

Edited by naiaragomesp
  • Like 1
Link to comment
Share on other sites

Em 31/10/2017 at 09:26, Guilherme Verardi disse:

 

Fiz umas alterações no seu Demo na opção de gerar arquivos para Estoque, seguindo o que tenho aqui na ultima versão dos arquivos. Talvez você não consiga compilar o projeto, pois utilizo o Delphi XE8, mas você vai ter um .exe e os fontes para analisar.

Uma coisa que percebi, é que talvez você esteja usando os arquivos do início do tópico, mas mais abaixo eu anexei um zip com mais algumas mudanças. Porque se você prestar atenção, não utilizo mais a função EnviarReducaoZ ou EnviarEstoque, e sim a EnviarBlocoX.

 

ACBrBlocoXDemo.zip

Olá, obrigado por responder

Acho que estou com o componente BlocoX desatualizado, pois não existe a função EnviarBlocoX. Como faço pra obter a versão mais atual. O link pra download, se for possível.

Uso Delphi 7 e o instalador do componente que usei foi "ACBrInstall_Trunk2.exe". Talvez o processo pra escolhas dos pacotes antecessores obrigatórios não esteja escolhendo correto.

59f9c0374753f_InstalaoBlocoX.png.84eaf86fb04cbec0638d857fb192589a.png

 

Link to comment
Share on other sites

  • Consultores

Bom dia

estou tratando ele o componente pois o mesmo necessita de mais ajustes.

favor aguardar.

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil
Link to comment
Share on other sites

Em 01/11/2017 at 11:03, Juliomar Marchetti disse:

no site do sefaz tem e na documentação

Sim eu criei o meu baseado na documentação que é o correto! Porém na hora de validar (https://sathomologa.sef.sc.gov.br/tax.NET/sat.dfe.siv.web/validacao.aspx) ele diz que o CNPJ é inválido por esse motivo queria um xml que esteja validando nesse link para eu ver o que tem de diferente... Ou se devo realizar algum cadastro do CNPJ no site!  

Link to comment
Share on other sites

Em 03/11/2017 at 11:51, IGOR ALEXANDRO SCHERER disse:

Sim eu criei o meu baseado na documentação que é o correto! Porém na hora de validar (https://sathomologa.sef.sc.gov.br/tax.NET/sat.dfe.siv.web/validacao.aspx) ele diz que o CNPJ é inválido por esse motivo queria um xml que esteja validando nesse link para eu ver o que tem de diferente... Ou se devo realizar algum cadastro do CNPJ no site!  

Na ultima vez que procurei, a documentação oficial estava defasada. Se você seguir os schemas, do post da @naiaragomesp, verá que não bate com o da documentação.

Link to comment
Share on other sites

Em 03/11/2017 at 11:51, IGOR ALEXANDRO SCHERER disse:

Sim eu criei o meu baseado na documentação que é o correto! Porém na hora de validar (https://sathomologa.sef.sc.gov.br/tax.NET/sat.dfe.siv.web/validacao.aspx) ele diz que o CNPJ é inválido por esse motivo queria um xml que esteja validando nesse link para eu ver o que tem de diferente... Ou se devo realizar algum cadastro do CNPJ no site!  

Oii, segue o xml... 

ReducaoZ_25_10_17.Zip

Estoque_09_17.Zip

Link to comment
Share on other sites

1 hora atrás, naiaragomesp disse:

Perfeito o seu xml está validando no link (https://sathomologa.sef.sc.gov.br/tax.NET/sat.dfe.siv.web/validacao.aspx), porém me surgiu uma dúvida esse layout está diferente do último publicado (https://www.confaz.fazenda.gov.br/legislacao/despacho/2017/dp045_17) estou me baseando no layout correto ou houve outra publicação do layout? 

 

 

Link to comment
Share on other sites

  • Este tópico foi criado há 1270 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.