Jump to content

LANÇAMENTO
Curso Completo - Dominando o ACBrMonitor

Conheça o Curso

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

Recommended Posts

Boa tarde,

 

Estou usando a versão 1.1.0.27 do Monitor, estou tendo um problema ao usar o método  NFE.ImprimirDanfe(), Se eu usar este método pra imprimir uma NFe funciona, se imprimir uma NFCe funciona, porém, se após ter impresso uma NFCe eu tentar imprimir uma NFe a nota sai cortada, como se tivesse imprimindo em uma impressora térmica. Alguém já presenciou isso? 

 

 

Em anexo segue o exemplo. 

 

 

29180103748056000117550010000040141788875780.pdf

Share this post


Link to post
Share on other sites

Boa tarde, pode estar mantendo as configurações da NFCe, vamos corrigir para as próximas versões...


Consultor SAC ACBr

José Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites

Amigo, estou usando a versão 1.1.0.27, já é bem antiga, porém por ser algo que bastante gente use, será que realmente pode ser problema com versão?  Já não teriam vários relatos? 

Share this post


Link to post
Share on other sites

Não tem relatos, talvez esteja configurado a mesma impressora nos dois campos... Tente visualizar em tela antes para ver se o problema ocorre?


Consultor SAC ACBr

José Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites

O problema estava sendo causado por estar passando um valor indevido, "0", no parâmetro [cImpressora] enquanto deveria estar passando a string vazia pra que o Monitor pegasse a padrão definida. 

 

Obrigado pela resposta!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...