Jump to content

Embarcadero Conference 2019

22/10 - Visite o Stand do ACBr
Saiba mais

Nova Loja Oficial
loja.projetoacbr.com.br
Ajude o projeto a crescer, com estilo

Comprar

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

Recommended Posts

Bom dia,

 

Estou usando o método  NFE.ConsultarNFe("XML DA NOTA") , para NFCe está funcionando perfeitamente, porém quando tento com uma NFE sempre retorna  "Rejeicao: NF-e nao consta na base de dados da SEFAZ"

Todas as notas consultadas receberam o Status de "Autorizado o uso da NF-e" no momento da transmissão. Já aguardei mais de uma hora entre a transmissão e a consulta porém o retorno é sempre o mesmo.

 

Alguém sabe o que pode ser?

Share this post


Link to post
Share on other sites

Boa tarde!


Quando você alterna a consulta de NFCe para NFe você está setando o modelo correto?
Exemplo:  NFE.setmodelodf("55")  - após consulta o modelo 55,  trocar para NFE.setmodelodf("65") e consultar uma NFCe.
Pois se vc não alterar o modelo a consulta permanecerá na ultima opção selecionada.  Se estiver em 65 permanecerá nela. 

  • Thanks 1


logoacbr.pngConheça o Portal do Projeto ACBr

Ajude o Projeto ACBr crescer - Assine o SAC ACBr
Assine um dos planos de longa duração do SAC ACBr, obtenha Descontos Especiais, Parcele no Cartão e ainda ganhe Brindes Exclusivos. Saiba mais aqui

Conheça o ACBrLib, o ACBr de forma nativa para qualquer linguagem de programação. Saiba mais aqui

 

 

 

 

Share this post


Link to post
Share on other sites

Verificou se a nfe q esta consultando foi emitida/autorizada no mesmo ambiente (homologação/ produção) onde vc esta consultando? 

Att

Ricardo

Share this post


Link to post
Share on other sites
13 horas atrás, AMS disse:

Estou setando o modelo antes da consulta, assim como orientou, porém o retorno persiste.. 

Bom dia!

Então com isto verificado, restou o que o RicardoVoigt comentou.  Verificar se a consulta está sendo feita no mesmo ambiente.  Se emitir em homologação, a consulta deve ser em ambiente de homologação, se emitiu em ambiente de produção, a consulta deverá ser em ambiente de produção. 

Em últimos casos, configure o log (caso não esteja ativado)  e anexe o arquivo log, após vc fazer estes procedimentos que vc comentou. 



logoacbr.pngConheça o Portal do Projeto ACBr

Ajude o Projeto ACBr crescer - Assine o SAC ACBr
Assine um dos planos de longa duração do SAC ACBr, obtenha Descontos Especiais, Parcele no Cartão e ainda ganhe Brindes Exclusivos. Saiba mais aqui

Conheça o ACBrLib, o ACBr de forma nativa para qualquer linguagem de programação. Saiba mais aqui

 

 

 

 

Share this post


Link to post
Share on other sites

@AMS, vou ter que conferir os endereços dos webservices depois com mais tempo no arquivo ACBrNFeServicos.ini ou  então vc dar a certeza que vc está com o arquivo ACBrNFeServicos.ini atualizado.

O que posso garantir para vc é que a nota consta no ambiente de homologação da sefaz/BA. (Porém no portal estadual) no nacional pelo que vi não está sincronizando, mas ai a falha seria deles. 

Em anexo a consulta da nota no portal estadual de homologação da SEFAZ/BA.

 

 

nf.png

  • Thanks 1


logoacbr.pngConheça o Portal do Projeto ACBr

Ajude o Projeto ACBr crescer - Assine o SAC ACBr
Assine um dos planos de longa duração do SAC ACBr, obtenha Descontos Especiais, Parcele no Cartão e ainda ganhe Brindes Exclusivos. Saiba mais aqui

Conheça o ACBrLib, o ACBr de forma nativa para qualquer linguagem de programação. Saiba mais aqui

 

 

 

 

Share this post


Link to post
Share on other sites

Estou usando o arquivo de endereços que veio na versão 1.1.0.27 do monitor.

 

É possível que não estejam sincronizando mesmo, vou aguardar para ver se volta ao normal. 

 

Obrigado.

Share this post


Link to post
Share on other sites
32 minutos atrás, AMS disse:

Estou usando o arquivo de endereços que veio na versão 1.1.0.27 do monitor.
É possível que não estejam sincronizando mesmo, vou aguardar para ver se volta ao normal. 
Obrigado.

Foi só um comentário que fiz em relação ao fato de não encontrar no portal nacional no momento que consultei.
Porque a consulta pelo aplicativo é feito no ambiente estadual.  Se o endereço não estiver errado, teria que ter funcionado.
Vou ver melhor depois.

  • Thanks 1


logoacbr.pngConheça o Portal do Projeto ACBr

Ajude o Projeto ACBr crescer - Assine o SAC ACBr
Assine um dos planos de longa duração do SAC ACBr, obtenha Descontos Especiais, Parcele no Cartão e ainda ganhe Brindes Exclusivos. Saiba mais aqui

Conheça o ACBrLib, o ACBr de forma nativa para qualquer linguagem de programação. Saiba mais aqui

 

 

 

 

Share this post


Link to post
Share on other sites

boa Tarde

uso a versão 1.1.0.38 ela consulta apenas NFE modelo 55 independente de setar qualquer modelo e na consulta da NFCE aparece erro 500, 

setei para modelo 65, mas continua a mesma coisa, NFE modelo 55 tranquilo e modelo 65 sem retorno, tenho o xml completo, precisava da autorização poque vc gera e envia e dá erro, quando vai transmitir apresente Nota já transmitida, quando isso acontece na NFE vc consulta o XML e ele já atualiza, mas nfce não. essa nota 55 retorna não consta e não consta mesmo, mas a 65 da sempre erro

 

Claudio Souza

29171216263410000165650010000018411002623318-ped-sit.xml

29171216263410000165650010000018411002623318-ped-sit-soap.xml

293074665333483-pro-rec.xml

293074665333483-pro-rec-soap.xml

293074665333483-ped-rec.xml

293074665333483-ped-rec-soap.xml

1-rec.xml

1-rec-soap.xml

1-env-lot.xml

1-env-lot-soap.xml

29171221051221000169650010000013471000001600-ped-sit.xml

29171221051221000169650010000013471000001600-ped-sit-soap.xml

29171216440182000151550010000000051000000234-sit.xml

29171216440182000151550010000000051000000234-sit-soap.xml

29171216440182000151550010000000051000000234-ped-sit.xml

29171216440182000151550010000000051000000234-ped-sit-soap.xml

Share this post


Link to post
Share on other sites

Bom dia, atualize seu ACBrMonitor para realizar os testes, houve diversas atualizações de URLs da SEFAZ nas últimas versões do ACBrMonitor.


Consultor SAC ACBr

José Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites

Olá José,

Atualizei, o problema é o seguinte,quando a versão d0 ACBRMONITOR é 1.1.0.54

quando na tela  DFE - WEBSERVICE  a versão do NFE é 3.0   ele consulta apenas modelo 55, retornando erro de conexão no modelo 65

mas, quando é 4.0 ele consulta apenas modelo 65  retornando erro de conexão no modelo 55 ele inverte, acho que á questão, a nível de sugestão é ele ver o modelo na própria chave antes de selecionar o webservice.

Infelizmente eu uso os dois modelos, e a frequência com que dá erro de conexão e retorno de duplicidade é relevante

Claudio Souza

Share this post


Link to post
Share on other sites

O ACBrMonitor já faz isso... Pode consultar pela chave e já identifica se é modelo 55 ou 65... 

Verifique o ambiente que está consultando. Ex: se foi emitido em homologação... deve consultar neste mesmo ambiente

O erro pode ser alguma instabilidade SEFAZ na consulta da sua UF...

Qual XML apresenta o erro?


Consultor SAC ACBr

José Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites

Realmente o problema parece estar no Sefaz, a sincronização entre os servidores do Sefaz estadual e Nacional não está funcionando.

 

 

Tem alguma form de fazer essa consulta direto no WebService do estado? 

ScreenHunter 292.png

Share this post


Link to post
Share on other sites
4 horas atrás, AMS disse:

Tem alguma form de fazer essa consulta direto no WebService do estado? 

O ACBr já faz a consulta no WebService do estado. 
Tente usando o comando mesmo NFe.ConsultarNFe(cArqXML) e não o botão consultar do teste. 
Veja se muda algo.
 



logoacbr.pngConheça o Portal do Projeto ACBr

Ajude o Projeto ACBr crescer - Assine o SAC ACBr
Assine um dos planos de longa duração do SAC ACBr, obtenha Descontos Especiais, Parcele no Cartão e ainda ganhe Brindes Exclusivos. Saiba mais aqui

Conheça o ACBrLib, o ACBr de forma nativa para qualquer linguagem de programação. Saiba mais aqui

 

 

 

 

Share this post


Link to post
Share on other sites
1 hora atrás, Kiko Fernandes disse:

O ACBr já faz a consulta no WebService do estado. 
Tente usando o comando mesmo NFe.ConsultarNFe(cArqXML) e não o botão consultar do teste. 
Veja se muda algo.
 

Sempre uso este comando, usei o teste do Monitor apenas pra facilitar a demostração aqui no post.

O resultado usando "NFe.ConsultarNFe(cArqXML)" é sempre o mesmo: "OK: Rejeicao: NF-e nao consta na base de dados da SEFAZ"

 

Já nem sei mais o que fazer, se esgotaram todas as possibilidades... 

Share this post


Link to post
Share on other sites

Bom dia!
Realmente tem algo estranho ai. 

Vc tem outro certificado de outro cliente de outro estado, para fazer o teste em outra UF?
Ai se vc continuar tendo erro, pode ser algo em sua rotina, se der certo então teremos problema com a SEFAZ/BA em homologação. 
Outra pergunta, é possível vc fazer o envio e a consulta em produção para ver se tem o mesmo problema?
 



logoacbr.pngConheça o Portal do Projeto ACBr

Ajude o Projeto ACBr crescer - Assine o SAC ACBr
Assine um dos planos de longa duração do SAC ACBr, obtenha Descontos Especiais, Parcele no Cartão e ainda ganhe Brindes Exclusivos. Saiba mais aqui

Conheça o ACBrLib, o ACBr de forma nativa para qualquer linguagem de programação. Saiba mais aqui

 

 

 

 

Share this post


Link to post
Share on other sites

 

19 horas atrás, AMS disse:

Sempre uso este comando, usei o teste do Monitor apenas pra facilitar a demostração aqui no post.

O resultado usando "NFe.ConsultarNFe(cArqXML)" é sempre o mesmo: "OK: Rejeicao: NF-e nao consta na base de dados da SEFAZ"

 

Já nem sei mais o que fazer, se esgotaram todas as possibilidades... 

Boa tarde, se a NF-e não consta na SEFAZ base nacional mesmo depois de algum tempo, pode ser problema com a SEFAZ BA. Talvez deva entrar em contato com eles para saber o motivo...


Consultor SAC ACBr

José Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites

Boa tarde @José M. S. Junior

Embora tenha entrado no assunto do post o comentário sobre atualização na base nacional não é este o questionamento dele. 
O Sistema está consultando através do NFe.ConsultarNFe(cArqXml) e segundo ele vem a informação que não consta  a nota na base de dados. 
Até aonde eu sei o NFe.ConsultarNFe(cArqXml) consulta na UF emissora correto?   Se sim penso que o problema pode estar ou na SEFAZ/BA. 
Observe que acima ele comenta que está usando o NFe.ConsultarNFe()

22 horas atrás, AMS disse:

Sempre uso este comando, usei o teste do Monitor apenas pra facilitar a demostração aqui no post.

O resultado usando "NFe.ConsultarNFe(cArqXML)" é sempre o mesmo: "OK: Rejeicao: NF-e nao consta na base de dados da SEFAZ"

 



logoacbr.pngConheça o Portal do Projeto ACBr

Ajude o Projeto ACBr crescer - Assine o SAC ACBr
Assine um dos planos de longa duração do SAC ACBr, obtenha Descontos Especiais, Parcele no Cartão e ainda ganhe Brindes Exclusivos. Saiba mais aqui

Conheça o ACBrLib, o ACBr de forma nativa para qualquer linguagem de programação. Saiba mais aqui

 

 

 

 

Share this post


Link to post
Share on other sites

Bom dia,

Em 09/02/2018 at 10:27, Kiko Fernandes disse:

Bom dia!
Realmente tem algo estranho ai. 

Vc tem outro certificado de outro cliente de outro estado, para fazer o teste em outra UF?
Ai se vc continuar tendo erro, pode ser algo em sua rotina, se der certo então teremos problema com a SEFAZ/BA em homologação. 
Outra pergunta, é possível vc fazer o envio e a consulta em produção para ver se tem o mesmo problema?
 

Não temos clientes em outros estados.

Como poderia ser erro na rotina se, quando consultando pelo próprio demo do monitor é apresentado o mesmo retorno?

Acabei de tetar em ambiente de produção e funcionou perfeitamente, só resta pensar ser problema no ambiente de Homologação do Sefaz mesmo.

 

Em 09/02/2018 at 12:59, José M. S. Junior disse:

 

Boa tarde, se a NF-e não consta na SEFAZ base nacional mesmo depois de algum tempo, pode ser problema com a SEFAZ BA. Talvez deva entrar em contato com eles para saber o motivo...

Não são dos mais solícitos, mas vou tentar o contato!

 

Em 09/02/2018 at 17:03, José M. S. Junior disse:

Correto @Kiko Fernandes, pode ser problema na SEFAZ/BA.

@AMS, verifique também qual forma de emissão está configurada no ACBrMonitor. veja se não está Ambiente Nacional...

Já me certifiquei algumas vezes..

 

 

Obrigado pela força!

ScreenHunter 306.png

Share this post


Link to post
Share on other sites
Em 12/02/2018 at 09:33, AMS disse:

Acabei de tetar em ambiente de produção e funcionou perfeitamente, só resta pensar ser problema no ambiente de Homologação do Sefaz mesmo.

Boa noite. Então prob. com homologação SEFAZ/BA.
Se mais algum colega que emite na SEFAZ/BA puder fazer um teste em homologação, só para termos a certeza, agradeço.

  • Thanks 1


logoacbr.pngConheça o Portal do Projeto ACBr

Ajude o Projeto ACBr crescer - Assine o SAC ACBr
Assine um dos planos de longa duração do SAC ACBr, obtenha Descontos Especiais, Parcele no Cartão e ainda ganhe Brindes Exclusivos. Saiba mais aqui

Conheça o ACBrLib, o ACBr de forma nativa para qualquer linguagem de programação. Saiba mais aqui

 

 

 

 

Share this post


Link to post
Share on other sites

Prezados, 

 

Milagrosamente a consulta voltou a funcionar perfeitamente, pode ter sido algum problema que o Sefaz teve por um período.

 

Agradeço a colaboração de todos!

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...