Jump to content

Promoção de Natal SAC Mensal

Contrate e ganhe 1 Kit agenda + Caneta
Saiba mais

LANÇAMENTO
Curso Completo - Dominando o ACBrMonitor

Conheça o Curso

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

Recommended Posts

Olá, Italo, obrigado pelo retorno.

1) Atualizei a pasta Trunk2;

image.png.a82c8ffd7c0610d86dd30dfe4cffc945.png

2) Fiz a remoção completa do componente pelo apagarAcbr.bat

3) Reinstalei os componentes pelo ACBrInstall_Trunk2

4) E sim, configurei o componente para versão 1_03_02

image.png.8657263d29260eb73105484107013d28.png

 

Estou utilizando o Delphi Berlin 10.1

 

Share this post


Link to post
Share on other sites

Daniel,

O contribuinte é pessoa Jurídica ou Física?

Qual é o valor informado na propriedade de configuração: Configuracoes.Geral.TipoContribuinte ?

Ao alimentar o componente esta informando o numero de inscrição completo ao campo: ideContri.NrInsc ?


Consultor SAC ACBr Italo Jurisato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Share this post


Link to post
Share on other sites

Bom dia pessoal,

Atualizei os fontes da ACBr hoje cedo, estou  tentando enviar o registro R1000 esta sempre retornando este erro.

Estou tentando enviar pelo Exemplo da Acbr, também esta dando erro.

Podem me ajudar?

 

 

 

Erro REINF.jpg

Share this post


Link to post
Share on other sites

Olá Italo, ja achei o problema aqui.

Estava informando somente a raiz do CNPJ no campo :ideContri.NrInsc, e vi que devo informar o CNPJ completo.

Obrigado!

 

  • Like 1

Share this post


Link to post
Share on other sites

Bom dia a todos.

Alguém conseguiu enviar o evento R-1000 em ambiente de produção?

Estou tendo o retorno MS0038 - Para envio de eventos para a produção, o ambiente deve ser igual a 1. Para envio de eventos para a pré-produção, deve ser igual a 2.

Share this post


Link to post
Share on other sites
8 horas atrás, Italo Jurisato Junior disse:

Bom dia Charles,

E mesmo assim continua o problema?

Olá, italo,

Resolvi testar novamente hoje a tarde e consegui enviar normalmente.

Continuar testando.

Obrigado

  • Like 1

Share this post


Link to post
Share on other sites
Em 23/04/2018 at 11:31, Italo Jurisato Junior disse:

Bom dia Renato,

Primeiramente quero agradecer pela colaboração.

Segundo, eu reescrevi o componente ACBrReinf para que o mesmo ficasse parecido com o eSocial, logo será difícil aproveitar os seus fontes.

No momento estou trabalhando na adequação do programa exemplo para essa nova versão do componente.

Inclusive agora as units dos eventos possui uma rotina para a leitura do arquivo texto no formato INI, essa implementação é útil para que possamos em breve estar acrescentando o ACBrReinf no ACBrMonitor Plus, desta forma quem não desenvolve em Delphi ou Lazarus vai poder enviar o Reinf através do monitor.

A minha previsão que tudo (em relação ao componente) esteja pronto até o final deste mês.

Ai lhe peço que faça uma cópia do que você fez e atualize todos os fontes de todas as pastas e reinstale os componentes.

Acredito que essa nova versão do componente vai contemplar tudo, ficando apenas a limpeza da base de dados a ser implementada.

Desde já agradeço pela compreensão.

 

 

Bom dia @Italo Jurisato Junior,

Atualizei o componente, validei todos os eventos e está tudo ok.

Segue o programa de exemplo com a implementação da opção de Limpeza da Base disponível apenas para "Produção Restrita"

_TELAS.gif.767a2a6341e5e34770877bf9253ef5ea.gif

ACBr.rar

 

 


 

Renato Rubinho
Analista de Sistemas

Share this post


Link to post
Share on other sites
Em 02/05/2018 at 10:37, Fernando Lobato disse:

Bom dia a todos.

Alguém conseguiu enviar o evento R-1000 em ambiente de produção?

Estou tendo o retorno MS0038 - Para envio de eventos para a produção, o ambiente deve ser igual a 1. Para envio de eventos para a pré-produção, deve ser igual a 2.

Boa tarde Fernando,

caso não tenha resolvido sugiro olhar :

Tags  (caso não tenha atualizado os fontes )
ACBrReinf.IdeEvento.TpAmb  e  AACBrReinf.Configuracoes.WebServices.Ambiente

E se os endereços do webservice estão corretos :

(acbrReinf.configuracoes.webservices.params)

[Reinf_H]

EnviarLoteEventos=https://preprodefdreinf.receita.fazenda.gov.br/WsREINF/RecepcaoLoteReinf.svc
ConsultarLoteEventos=https://preprodefdreinf.receita.fazenda.gov.br/WsREINF/ConsultasReinf.svc

[Reinf_P]
EnviarLoteEventos=https://reinf.receita.fazenda.gov.br/WsREINF/RecepcaoLoteReinf.svc 
ConsultarLoteEventos=https://reinf.receita.fazenda.gov.br/WsREINF/ConsultasReinf.svc



Att

Fábio Amaral

Share this post


Link to post
Share on other sites

Boa tarde a Todos!

Estou tentando enviar o evento r-1000 mas estou recebendo o seguinte erro.  Alguém poderia me ajudar?

1455600276_erroreinf.jpg.fe525c14f8169332f718b3e5e6d3a22b.jpg

Share this post


Link to post
Share on other sites

Bom dia Italo.

 

Fiz outros testes mudando a opção do ssllib para OpenSSL e consegui enviar.  Consegui enviar o r1000 normalmente. Mas quando tento enviar o r2010 de teste sempre recebo um retorno com o erro MS0025 dizendo que nao foi possivel processar. Voce saberia me dizer o porque desse retorno? Outros tiveram esse problema? 

Obrigado

Share this post


Link to post
Share on other sites
Em 05/06/2018 at 15:32, Siagri Sistemas disse:

Boa tarde Fernando,

caso não tenha resolvido sugiro olhar :

Tags  (caso não tenha atualizado os fontes )
ACBrReinf.IdeEvento.TpAmb  e  AACBrReinf.Configuracoes.WebServices.Ambiente

E se os endereços do webservice estão corretos :

(acbrReinf.configuracoes.webservices.params)

[Reinf_H]

EnviarLoteEventos=https://preprodefdreinf.receita.fazenda.gov.br/WsREINF/RecepcaoLoteReinf.svc
ConsultarLoteEventos=https://preprodefdreinf.receita.fazenda.gov.br/WsREINF/ConsultasReinf.svc

[Reinf_P]
EnviarLoteEventos=https://reinf.receita.fazenda.gov.br/WsREINF/RecepcaoLoteReinf.svc 
ConsultarLoteEventos=https://reinf.receita.fazenda.gov.br/WsREINF/ConsultasReinf.svc



Att

Fábio Amaral

Boa tarde Fábio,

Consegui resolver sim, eu não estava setando o ambiente nas configurações gerais.

Obrigado

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...