Jump to content

Delphi Enterprise 
pela METADE DO PREÇO

botao_delphi.png

Curso Dominando o ACBrMonitor
Novo Módulo Soluções de Varejo
Assine o SAC ACBr em qualquer plano e tenha acesso

Saiba Mais

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba Mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

asamos

ANSWERED eSocial-Produção Restrita- Ver2.04.02

  • Este tópico foi criado há 776 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Recommended Posts

Olá

Estou iniciando os testes de envio de arquivos ao eSocial e enviei inicialmente o evento do Empregador e depois o de Rubrica. Apesar no Retorno o eSocial informar que o lote do evento Empregador  foi processado com sucesso, rejeita o evento  com a mensagem:"O evento somente será aceito após a data de início da obrigatoriedade do empregador ao eSocial". Eu estou usando o ambiente "Produção Restrita", como mostrado no arquivo em anexo, o Sistema não teria que aceitar ou indicar o erro da rejeição ?

Devido a este erro, o eSocial rejeita os eventos de Rubrica por não existir o evento do Empregador. Como sair desta ?

Agradeço a ajuda.

Aristarco

anexo arquivo enviado e respostas recebidas

 

20180410165157-env-lot-soap.xml

MensagemConsulta20180410.txt

RespostaEnvio20180410.xml

20180410165207-rec-soap.xml

Share this post


Link to post
Share on other sites

Boa tarde Aristarco,

Você configurou o componente para gerar o eSocial na versão 2.04.02, e na versão 2.04.01 ocorre o mesmo problema?


Consultor SAC ACBr Italo Jurisato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Share this post


Link to post
Share on other sites

O leiaute da produção restrita é 2.4.02, outra coisa a se atentar que a data inicial para usar em produção restrita tem que ser a partir de 01/08/2017 senão vai dar erro de data.


Consultor SAC ACBr Rafael Dias
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Desenvolvedor ACBrLib.

 

Share this post


Link to post
Share on other sites

Eu mudei para a versão 2.04.02 porque ao enviar com a versão 2.04.01, na consulta aparecia a crítica "Leiaute do evento inválido". Como no dia 9/04 o eSocial trocou a versão do Sistema, imaginei que o erro seria por este motivo. Com a observação feita pelo Rafael, refiz o teste com a versão 2.04.01 e identifiquei que na tabela de mensagens o erro 403 indicava erro na data do certificado digital. Estou utilizando um certificado A3, com data de vigência de 25/08/2015 a 24/08/2018, é provável então que o erro tenha ocorrido por eu estar utilizando um certificado A3.  Em janeiro/2018 vi algumas postagens informando haver um erro no componente ACBreSocial com este modelo de certificado, este erro já foi corrigido ?

  Em anexo a configuração utilizada no A3 e os arquivos enviados e recebidos do eSocial    

20180410233255-env-lot-soap.xml

20180410233302-rec-soap.xml

ConsultaLotesEnviados.xml

ConfiguracaoCertificado.jpg

ConsultaLoteEventos.txt

Historico.txt

XMLRetorno.xml

Share this post


Link to post
Share on other sites

Bom dia Aristarco,

No XML do evento não existe nenhuma tag que contem a versão do eSocial que esta sendo gerada.

Essa informação somente aparece no namespace da tag <eSocial>, isso deveria ser suficiente para o webservice saber em qual versão o XML foi gerado.

A mensagem de erro: "Leiaute do evento inválido" sugere que o evento foi gerado em uma versão e o webservice esta esperando em outra e essa outra o Layout contem diferenças.

O código de erro 403 que aparece no XML de retorno não tem nada haver com o erro 403 quanto tentamos consumir um webservice e este nega pelo fato do certificado digital não ter permissão para isso.

Sendo assim o problema não é o certificado digital e sim algo relacionado a versão do evento que implica em alguns evento alteração em seu layout.


Consultor SAC ACBr Italo Jurisato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Share this post


Link to post
Share on other sites

Prezado Ítalo

Não encontrei nenhum erro de leiaute, inclusive não existe diferenças dos leiautes dos eventos S1000 e S1010  entre a versão 2.04.01 a a versão 2.04.02. Verifiquei campo por campo, e os únicos campos faltantes são os opcionais.  Antes da apresentação desse erro, o eSocial devolveu indicando erro no código de natJurid, informando que o mesmo estava incompatível com o registro cadastral do CNPJ do Empregador na Receita Federal. Somente depois que corrigi os erros indicados é que foi apresentado este erro.

 

Aristarco

 

Share this post


Link to post
Share on other sites

Bom dia Aristarco,

Não sei se poderíamos chamar esse ambiente "Produção Restrita" como ambiente de teste (homologação), se sim, o que pode esta ocorrendo, nesse ambiente o webservice só esta aceitando a versão mais recente e no de produção a versão anterior.

São apenas suposições.


Consultor SAC ACBr Italo Jurisato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Share this post


Link to post
Share on other sites

Verifiquei agora no Site do eSocial e desde 9/04 o Webservice  aceita a versão 2.04.02 em produção restrita (tpAmb = 2). Desta forma, a minha interpretação da mensagem "Leiaute do evento inválido"  estava certa  e ter mudado para a versão 2.04.02.  O que não deu para entender é não terem aceito os eventos mesmo estando corretos. O problema é que o eSocial não responde a dúvidas específicas. Você conhece alguma empresa com faturamento abaixo de R$ 78 milhões e que esteja o componente ACBreSocial e fazendo os testes normalmente ? A única explicação seria um erro no código do Tipo de Ambiente, mas não identifiquei este erro. Por este motivo postei os arquivos XML para ver se alguém me ajuda a descobrir o motivo da mensagem.

Abraço

Aristarco

Share this post


Link to post
Share on other sites

×
×
  • Create New...