Ir para conteúdo
  • Cadastre-se
Entre para seguir isso  
Leonardo Henrique

RESPONDIDO Bloco X - "Não encontrei final do elemento: </ReducaoZ>"

Recommended Posts

Ao utilizar o comando ECF.AssinarBlocoXReducaoZ("Caminho do arquivo") estou recebendo no retorno a mensagem "ERRO: Não encontrei final do elemento: </ReducaoZ>".

Tentando fazer pelo comando ECF.AssinarBlocoXReducaoZ("Conteudo do XML") a assinatura é realizada porém ao validar ela no site da receita https://www.receita.fazenda.gov.br/Aplicacoes/SSL/ATBHE/assinadoc/ValidadorAssinaturas.app/valida.aspx, estou recebendo o retorno que está inválida.

Coloquei em anexo o XML que estou tentando assinar. A versão do ACBrPlus que estou utilizando é 1.1.0.60.

Sabem se tem algo que eu esteja fazendo errado no processo?

BlocoX_ReducaoZ_20180605.xml

Compartilhar este post


Link para o post
Compartilhar em outros sites
1 hora atrás, Leonardo Henrique disse:

Ao utilizar o comando ECF.AssinarBlocoXReducaoZ("Caminho do arquivo") estou recebendo no retorno a mensagem "ERRO: Não encontrei final do elemento: </ReducaoZ>".

Tentando fazer pelo comando ECF.AssinarBlocoXReducaoZ("Conteudo do XML") a assinatura é realizada porém ao validar ela no site da receita https://www.receita.fazenda.gov.br/Aplicacoes/SSL/ATBHE/assinadoc/ValidadorAssinaturas.app/valida.aspx, estou recebendo o retorno que está inválida.

Coloquei em anexo o XML que estou tentando assinar. A versão do ACBrPlus que estou utilizando é 1.1.0.60.

Sabem se tem algo que eu esteja fazendo errado no processo?

BlocoX_ReducaoZ_20180605.xml

Bom dia, Leonardo Henrique.

Acredito que está faltando o produto com seu totalizador "original".

ReducaoZ_ACBr.XML

Compartilhar este post


Link para o post
Compartilhar em outros sites
8 minutos atrás, Leonardo Henrique disse:

Obrigado @Felipe E. Resende Mesquita...  Observando o layout que você anexou notei algumas diferenças com o publicado aqui https://www.confaz.fazenda.gov.br/legislacao/despacho/2018/dp046_18 

No caso esse layout do site não seria o que deve ser implementado nos meus XML's? 

Peço desculpas, segue o arquivo correto.

ReducaoZ_25_10_17.xml

Compartilhar este post


Link para o post
Compartilhar em outros sites

Novamente agradeço pelo auxílio @Felipe E. Resende Mesquita, consegui entender o que estava causando o problema. O layout do meu XML estava de acordo com o que vc me passou. Assim procurei outro motivo e resolvi tentar alterar o nome da pasta.

Eu estava trabalhando diretamente dentro da pasta final que pedem para deixar como padrão que tem o nome "Arquivo com Informações da Redução Z do PAF-ECF". Quando utilizo uma pasta com nome mais simples, como TESTE por exemplo, os métodos de assinatura e validação ocorreram sem problemas.

Vou alterar meu sistema para que grave na pasta final somente após todos os procedimentos. 

Valeu demais!

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora
Entre para seguir isso  

×