Jump to content

dia-do-acbr-online.png

.Promoção do Suporte ACBr:
Ganhe o Curso Migração e Modernização de Aplicações Legadas

Saiba Mais


RAFAEL_E_ANGELO3.png

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


botao.png

beneficios.png

Erro 12175 - Um ou mais erros foram encontrados no certificado Secure Sockets Layer (SSL) enviado pelo servidor


Go to solution Solved by Marcelo Calvi Belanga,
  • Este tópico foi criado há 728 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Recommended Posts

Boa tarde, 

Estou com o seguinte problema ao enviar uma NF-e \ NFC-e:

12175 - Um ou mais erros foram encontrados no certificado Secure Sockets Layer (SSL) enviado pelo servidor

O Windows é o 7 e está acontecendo somente no estado de GO. Já tentei utilizar o TSSLType.LT_TLSv1_2 e o TSSLType.LT_all e o erro persiste.

Alguém tem alguma ideia do que pode estar provocando este problema?

Obrigado

Link to post
Share on other sites
  • Usuários SAC

Olá meu amigo... Tudo bom?

Qual a versão da NF-e?

Pergunto pois na NFe 4.00 + WinCrypt a falta de instalação das atualizações essenciais do Windows geram tal erro, se for o caso sugiro que as faça e tente novamente.

Abraços

  • Like 2
Link to post
Share on other sites
Em 13/06/2018 at 19:10, doidopb disse:

Olá meu amigo... Tudo bom?

Qual a versão da NF-e?

Pergunto pois na NFe 4.00 + WinCrypt a falta de instalação das atualizações essenciais do Windows geram tal erro, se for o caso sugiro que as faça e tente novamente.

Abraços

Obrigado pelo retorno.

A NF-e é a 4.00 + WinCrypt, fiz todas as atualizações recomendadas e opcionais do windows 7 ultimate e nada de funcionar. Atualizei os fontes do ACBr hoje 18/06 e mesmo assim não funcionou, ainda consta o erro 12175 - Um ou mais erros foram encontrados no certificado Secure Sockets Layer (SSL) enviado pelo servidor.

Link to post
Share on other sites
  • Usuários SAC

Pessoal, boa tarde, estou tendo este problema somente em um cliente (Erro: 12175 - Um ou mais erros foram encontrados no certificado Secure Sockets Layer (SSL) enviado pelo servidor), todas as vezes tenho que reconfigurar, verificar as configurações do IE, o certificado  o AcbrMonitorPlus e as conexões, variando entre os tipos.

Por vezes tenho que encerrar o monitor e executar novamente.

Obs: Este cliente ainda nem atualizei a versão da Nf-e.

[]s,

Edited by jorge andrade

Jorge Andrade

 

"Quem tem medo de perguntar, está fadado a eternizar-se na dúvida - [Jorge Andrade]";
 

"A soberba,  é o sentimento caracterizado pela pretensão de superioridade sobre as demais pessoas, levando a manifestações ostensivas de arrogância, por vezes sem fundamento algum em fatos ou variáveis reais - [Desconhecido";
 

"Aquele  que pesquisa antes de indagar, tem a grande chance de dirimir as suas dúvidas, fixar o aprendizado da pesquisa e evoluir para outros conhecimentos inesperados - [Jorge Andrade]";
 

"Os políticos e as fraldas devem ser trocados frequentemente e pela mesma razão - [Éça de Queiroz]".

Link to post
Share on other sites
  • Usuários SAC
1 minuto atrás, José M. S. Junior disse:

Está utilizando a ultima versão do ACBrMonitor 1.2.0.6?

1.2.0.5, penúltima, mas tenho vários clientes utilizando versões anteriores e não estou tendo este problema.

[]s,

 

Jorge Andrade

 

"Quem tem medo de perguntar, está fadado a eternizar-se na dúvida - [Jorge Andrade]";
 

"A soberba,  é o sentimento caracterizado pela pretensão de superioridade sobre as demais pessoas, levando a manifestações ostensivas de arrogância, por vezes sem fundamento algum em fatos ou variáveis reais - [Desconhecido";
 

"Aquele  que pesquisa antes de indagar, tem a grande chance de dirimir as suas dúvidas, fixar o aprendizado da pesquisa e evoluir para outros conhecimentos inesperados - [Jorge Andrade]";
 

"Os políticos e as fraldas devem ser trocados frequentemente e pela mesma razão - [Éça de Queiroz]".

Link to post
Share on other sites

Bom dia. 

O problema que tem sido recorrente é referente a configuração SSL = TLS1.2 utilizando WinCrypt, essa configuração utiliza recursos do Windows e muitos SO não tem essa atualização, mesmo estando aparecendo no IE. 

Testou com outras configurações?

image.png

Consultor SAC ACBr

José Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to post
Share on other sites
  • Usuários SAC
5 horas atrás, Edcarlos_rog disse:

Pra quem ainda não conseguiu corrigir esse erro, tentem fazer a seguinte atualização de acordo com o seu SO:

https://www.catalog.update.microsoft.com/Search.aspx?q=kb2992611

Fiz testes em diversas máquinas Windows 7 e todas deram certo!

Então a solução foi realmente atualizar? Resolveu o problema?

Link to post
Share on other sites
  • Usuários SAC
19 minutos atrás, doidopb disse:

Então a solução foi realmente atualizar? Resolveu o problema?

Bom, eu resolvi, atualizando o SO e alterando para OPENSSL.

 

[]s,

Jorge Andrade

 

"Quem tem medo de perguntar, está fadado a eternizar-se na dúvida - [Jorge Andrade]";
 

"A soberba,  é o sentimento caracterizado pela pretensão de superioridade sobre as demais pessoas, levando a manifestações ostensivas de arrogância, por vezes sem fundamento algum em fatos ou variáveis reais - [Desconhecido";
 

"Aquele  que pesquisa antes de indagar, tem a grande chance de dirimir as suas dúvidas, fixar o aprendizado da pesquisa e evoluir para outros conhecimentos inesperados - [Jorge Andrade]";
 

"Os políticos e as fraldas devem ser trocados frequentemente e pela mesma razão - [Éça de Queiroz]".

Link to post
Share on other sites
  • Usuários SAC
37 minutos atrás, jorge andrade disse:

Bom, eu resolvi, atualizando o SO e alterando para OPENSSL.

 

[]s,

Só um detalhe muito importante... OpenSSL NÃO depende de atualização do Windows para emissão da NFe 4.00, o que torna ele uma excelente opção, mas infelizmente o OpenSSL funciona apenas com A1.

  • Like 1
Link to post
Share on other sites
  • Fundadores
19 horas atrás, jorge andrade disse:

Bom, eu resolvi, atualizando o SO e alterando para OPENSSL.

EXATO... considerem com mais "carinho" essa opção...

Quanto custa o dia de um técnico (ou desenvolvedor) batendo a cabeça com atualizações de Windows Antigo, e instalação e reinstalação de certificado A3 ?

Não é mais barato mudar para OpenSSL e doar um certificado A1 para o Cliente Final ? (o próximo ele mesmo compra)

  • Like 4
  • Thanks 1
Consultor SAC ACBr

Daniel Simões de Almeida
O melhor TEF, é com o Projeto ACBr - Clique e Conheça
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to post
Share on other sites
  • Usuários SAC
1 hora atrás, Daniel Simoes disse:

EXATO... considerem com mais "carinho" essa opção...

Quanto custa o dia de um técnico (ou desenvolvedor) batendo a cabeça com atualizações de Windows Antigo, e instalação e reinstalação de certificado A3 ?

Não é mais barato mudar para OpenSSL e doar um certificado A1 para o Cliente Final ? (o próximo ele mesmo compra)

Disse tudo Daniel, eu tenho feito campanhas com os meus clientes, dos mais "retrógrados"/desinformados e outros nem tanto, mas por questão de "determinação"/instrução das contabilidades continuavam emitindo/contratando certificados A3.

Não canso de explicar as diferenças, seja na escravidão, custo e a falta de mobilidade, operacionalidade e versatilidade. Lembro que, mesmo que o A3 seja válido por 3 anos, o A1, além de ser bem mais em conta, se multiplicar por 3, o custo e todas as demais vantagens ganham de longe do A3 que é escravo ou escraviza a cpu onde está instalado.

Não vou citar o nome do emitente certificador aqui, embora sempre fiz pelos correios, mas passei a fazer por outro, cujo valor do A1 para empresas do tipo porte, ME, EPP, EIRELI e etc..., com horário agendado, estacionamento, água e cafezinho é de R$ 95,00.

[]s,

  • Like 2

Jorge Andrade

 

"Quem tem medo de perguntar, está fadado a eternizar-se na dúvida - [Jorge Andrade]";
 

"A soberba,  é o sentimento caracterizado pela pretensão de superioridade sobre as demais pessoas, levando a manifestações ostensivas de arrogância, por vezes sem fundamento algum em fatos ou variáveis reais - [Desconhecido";
 

"Aquele  que pesquisa antes de indagar, tem a grande chance de dirimir as suas dúvidas, fixar o aprendizado da pesquisa e evoluir para outros conhecimentos inesperados - [Jorge Andrade]";
 

"Os políticos e as fraldas devem ser trocados frequentemente e pela mesma razão - [Éça de Queiroz]".

Link to post
Share on other sites
  • Usuários SAC

Tentei baixar essa atualização disponibilizada no catálogo, porém recebi uma mensagem que a atualização já está presente no Windows..

Sendo assim, o Windows 7 já está atualizado, porém continua o erro !!

Alguém sabe qual a solução para o problema ?

Link to post
Share on other sites
  • Fundadores

O problema é o fato do Windows 7 ser um Sistema Operacional obsoleto...  Ele não suporta TLS1.2 com todos os Ciphers necessários...

Solução para quem insiste no uso de A3? Upgrade de Windows

Solução para quem tem A1 ? OpenSSL

Consultor SAC ACBr

Daniel Simões de Almeida
O melhor TEF, é com o Projeto ACBr - Clique e Conheça
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to post
Share on other sites
  • Fundadores

Achei alguns links a respeito do Windows 7 e TLS1.2... aparentemente além de requerer todas as atualizações disponíveis... é necessário alguns ajustes no Registry do Windows

https://support.microsoft.com/pt-br/help/3140245/update-to-enable-tls-1-1-and-tls-1-2-as-a-default-secure-protocols-in

https://support.cybersource.com/s/article/How-do-I-enable-TLS-1-2-on-Windows-7

  • Like 1
Consultor SAC ACBr

Daniel Simões de Almeida
O melhor TEF, é com o Projeto ACBr - Clique e Conheça
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to post
Share on other sites
  • Usuários SAC

Apenas para ter mais informações para o erro 12175.

Efetuando uma consulta de status do serviço, recebo o mesmo erro em homologação. Se altero para produção, a consulta funciona normalmente. Estou usando as seguintes configurações:

image.png.64db663dafe94b25c72462982c38c517.pngSSLType = LT_all

Para não apresentar o erro em Homologação, altero a propriedade HttpLib para httpWinNet.

Utilizo Windows 10 atualizado 100%.

Link to post
Share on other sites
  • Fundadores

Pode ser que o Servidor de homologação dessa SEFAZ esteja fazendo uso de alguma URL sem HTTPS (segura)

Qual a UF, versão e Serviço ? (qual a URL do WebService acessado ?)

  • Like 1
Consultor SAC ACBr

Daniel Simões de Almeida
O melhor TEF, é com o Projeto ACBr - Clique e Conheça
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to post
Share on other sites
  • Usuários SAC

@Daniel Simoes, pensei em algo parecido.

UF: SP, Versão: 4.0, Serviço: Consulta

Estou usando a configuração padrão do ACBr, como sei qual URL do WebService está sendo acessado? Acredito que estou acessando pelo link https://homologacao.nfe.fazenda.sp.gov.br/ws/nfestatusservico4.asmx

Meus LOG's não mostram o Webservice acessado, mostra apenas a solicitação e o retorno quando ocorre.

Link to post
Share on other sites
  • Fundadores
13 horas atrás, Marcelo Calvi Belanga disse:

SSLType = LT_all

Bom, a 4.0 exige TLS1.2, então a configuração acima não é valida... Você precisa necessariamente, configurar:

SSLType := LT_TLSv1_2

  pode ser que em produção estejam aceitando protocolos de segurança inferiores, temporariamente...

 

  • Like 2
Consultor SAC ACBr

Daniel Simões de Almeida
O melhor TEF, é com o Projeto ACBr - Clique e Conheça
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to post
Share on other sites
  • Este tópico foi criado há 728 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui
Guest
This topic is now closed to further replies.
×
×
  • Create New...