Jump to content

Assista click.png tectoy.png

C6 chamada_c6.png botao.png

Erro de Violação com


Go to solution Solved by Daniel Simoes,
  • Este tópico foi criado há 1436 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Membros Pro

Bom dia,

- AcbrNFe1.Configuracoes.Geral.SSLCryptLib := cryWinCrypt;
- AcbrNFe1Configuracoes.Geral.SSLHttpLib := httpWinINet;
- AcbrNFe1Configuracoes.Geral.SSLXmlSignLib := xsLibXml2;

Quando utilizo esta configuração (acima) dá erro de access violation.
Ainda não consegui debugar para ver onde exatamente ocorre o erro, pois só acontece em algumas máquinas de usuários. 

Já com esta configuração (abaixo), o erro não acontece.
- AcbrNFe1.Configuracoes.Geral.SSLCryptLib := cryWinCrypt;
- AcbrNFe1.Configuracoes.Geral.SSLHttpLib := httpWinHttp;
- AcbrNFe1Configuracoes.Geral.SSLXmlSignLib := xsLibXml2;

Alguma sugestão?

Obrigado.

Valdir Dill

Rio de Janeiro - RJ

 

 

Link to comment
Share on other sites

  • Consultores

Bom dia Valdir,

Não sei se você sabe, mas quando definimos o valor de SSLLib o componente se encarrega de definir os valores das demais propriedades.

Valores estes que na maioria dos casos vai funcionar sem nenhum problema.

  • Like 1
Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

  • Membros Pro
21 minutos atrás, Italo Jurisato Junior disse:

Bom dia Valdir,

Não sei se você sabe, mas quando definimos o valor de SSLLib o componente se encarrega de definir os valores das demais propriedades.

Valores estes que na maioria dos casos vai funcionar sem nenhum problema.

Bom dia Italo,

Obrigado pela ajuda.

Na verdade, meu problema começou esta semana em alguns usuários quando atualizei o sistema para usar TLS 1.2.

Na SSLHttpLib eu tinha configurado =  httpWinHttp,  mas em alguns usuários com Windows 7, começou a dar erro "12175..". Aí mudei SSLHttpLib para httpWinINet. Isso resolveu na maioria da máquinas. Mas algumas poucas máquinas, essa mudança para httpWinINet começou a dar esse erro de A.V. 

Obrigado.

Valdir Dill

Rio de Janeiro - RJ

 

 

Link to comment
Share on other sites

  • Consultores

Bom dia Valdir,

Pela sua primeira postagem o erro de AV, não é constante, correto?

Existem maquinas que nunca ocorreu o erro?

E as que ocorreram, é esporádico?

Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

  • Membros Pro
14 minutos atrás, Italo Jurisato Junior disse:

Bom dia Valdir,

Pela sua primeira postagem o erro de AV, não é constante, correto?

Existem maquinas que nunca ocorreu o erro?

E as que ocorreram, é esporádico?

Boa dia,

É constante. Ele ocorre algumas máquinas. Não consegui estabelecer o padrão ainda. Mas quando ocorre, ocorre sempre.

Vou tentar fazer debug na máquina do usuário para ver quando ocorre.

Obrigado

Valdir Dill

Rio de Janeiro - RJ

 

 

Link to comment
Share on other sites

  • Fundadores
  • Solution

httpWinINet usará uma API do Interner Explorer...

Pode ser que esteja faltando alguma atualização do I.E.

Veja um comparativo entre essas duas APIs do Windows

WinINet vs. WinHTTP

 

Consultor SAC ACBr

Daniel Simões de Almeida
O melhor TEF, é com o Projeto ACBr - Clique e Conheça
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.