Jump to content

erro ao enviar nfe 4.0 homologacao


  • Este tópico foi criado há 1497 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

bom dia pessoal, seguinte estou com um problema ,  quando envio pra sefaz em produção layout 4.0 vai tudo bem, agora quando tento enviar em homologação da erro http 500,  somente na sefaz sp.

estou achando que é o lance do protocolo TLS 1.2,  na base de homologação já não aceita mais, e na produção só vai mudar em 02/08/2018, por esse motivo eu consigo ainda enviar.

alguém tem alguma ideia de como resolver isso? 

 

 

Link to comment
Share on other sites

 frmPrincipal.ACBrNFe1.Configuracoes.Geral.SSLLib := libWinCrypt;
 frmPrincipal.ACBrNFe1.Configuracoes.Geral.SSLCryptLib := cryWinCrypt;
 frmPrincipal.ACBrNFe1.Configuracoes.Geral.SSLHttpLib := httpWinHttp;
 frmPrincipal.ACBrNFe1.Configuracoes.Geral.SSLXmlSignLib := xsLibXml2;

como define SSL Type?

ACBrNFe1.SSL.SSLType := LT_TLSv1_2;

 

Edited by e_r_r
Link to comment
Share on other sites

6 minutos atrás, e_r_r disse:

 frmPrincipal.ACBrNFe1.Configuracoes.Geral.SSLLib := libWinCrypt;
 frmPrincipal.ACBrNFe1.Configuracoes.Geral.SSLCryptLib := cryWinCrypt;
 frmPrincipal.ACBrNFe1.Configuracoes.Geral.SSLHttpLib := httpWinHttp;
 frmPrincipal.ACBrNFe1.Configuracoes.Geral.SSLXmlSignLib := xsLibXml2;

como define SSL Type?

ACBrNFe1.SSL.SSLType := LT_TLSv1_2;

 

Estava com o mesmo problema. Foi resolvido fazendo as configurações acima e, principalmente, atualizando o Windows do computador.

Link to comment
Share on other sites

descobri uma coisa,  na maquina que esta o delphi ta dando pau , windows 7, atualizei sp1,  agora mudou o erro ta dando erro de ssl  , porem testei num windows 10 do cliente funcionou perfeitamente.

vamos ter muitos problemas com isso. heeheh

 

 

 

Link to comment
Share on other sites

  • Fundadores
5 horas atrás, e_r_r disse:

vamos ter muitos problemas com isso. heeheh 

Não se você usar OpenSSL com certificado A1... nesse caso funcionaria até no XP...

 

Veja esse tópico:

 

Consultor SAC ACBr

Daniel Simões de Almeida
O melhor TEF, é com o Projeto ACBr - Clique e Conheça
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

Ainda estou tendo problemas com cliente, mesmo atualizado tudo no windows 10

ele ainda da um erro

Erro HTTP: 0

Falha no envio da Raquisicao

erro: 12030 - A conexão com o servidor foi redefinida ou encerrada, ou um protocolo SSL incompatível foi encontrado

testei hoje tbm num w7 atualizado foi tranquilo.

todos usando A1

    frmPrincipal.ACBrNFe1.SSL.SSLType := LT_TLSv1_2;
    frmPrincipal.ACBrNFe1.Configuracoes.Geral.SSLLib := libWinCrypt;
    frmPrincipal.ACBrNFe1.Configuracoes.Geral.SSLCryptLib := cryWinCrypt;
    frmPrincipal.ACBrNFe1.Configuracoes.Geral.SSLHttpLib := httpWinHttp;
    frmPrincipal.ACBrNFe1.Configuracoes.Geral.SSLXmlSignLib := xsLibXml2;

Link to comment
Share on other sites

  • Administradores

Fechado por falta de retorno do usuário

Consultora SAC ACBr

Juliana Tamizou
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.  Discord

Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil


Participe de nosso canal no Discord e fique ainda mais próximo da Comunidade !!

Link to comment
Share on other sites

  • Este tópico foi criado há 1497 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.