Jump to content

110.png

Curso Gratuito para todos Usuários
+ Super Treinamento Assinando o SAC Anual

botao_campanha_thulio.png

sem_ttulo-620.fw_-e1583866078274.png 

Curso Dominando o ACBrMonitor
Novo Módulo Soluções de Varejo
Assine o SAC ACBr em qualquer plano e tenha acesso

Saiba Mais

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba Mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

Joabe Geraldo

ANSWERED Consulta Cadastro não funciona em MG versão 4.0

Recommended Posts

Boa tarde

Não estou conseguindo fazer consulta de cadastro em MG com a versão 4.0 na NF-e.

Ao executar a consulta simplesmente não tenho nenhum retorno.

Se eu mudar a versão do componente para 3.1 ou 2.0 o retorno ocorre normalmente.

O mesmo problema ocorre usando o MonitorPLUS 1.1.0.54.

Com a versão 4.0 todos os serviços da NF-e estão executando corretamente, exceto a consulta ao cadastro.

Em anexo os arquivos de Pedido da Consulta e Retorno. Também envio o meu ACBrNFeServicos, que está atualizado pelo SVN.

Preciso desta rotina funcionando porque, estranhamente, a SEFAZ de MG está autorizando(e não denegando) notas fiscais para destinatários com o CNPJ Não Habilitado(suspenso). Desta forma o sistema iria informar se existe alguma pendência no cadastro do cliente antes da emissão da nota.

Obrigado

 

 

 

20180627084810-ped-cad.xml

20180627084815-cad.xml

ACBrNFeServicos.ini

  • Like 1

Share this post


Link to post
Share on other sites

Este problema é so em Minas Gerais? porque pelo que eu pesquisei aqui no fórum tem desenvolvedores de outros estados que estão conseguindo fazer a consulta.

Estranho que o método funciona nas versões 2.0 e 3.1.

O Método que eu estou usando para consulta é

<b>ACBrNFe1.WebServices.ConsultaCadastro.UF  := UF;

if Length(Documento) > 11 then
	ACBrNFe1.WebServices.ConsultaCadastro.CNPJ := Documento
else
    ACBrNFe1.WebServices.ConsultaCadastro.CPF := Documento;

ACBrNFe1.WebServices.ConsultaCadastro.Executar;</b>

Não estou usando o componente AcbrConsultaCPF ou AcbrConsultaCNPJ. Estou utilizando o AcbrNFe.

Share this post


Link to post
Share on other sites

MG está dando mensagem "Nenhum Retorno. Pode ser que o serviço de Consulta de Cadastro não esteja disponivel no SEFAZ"

MA está dando erro 12175 Falha no envio da requisição Um ou mais erros foram encontrados no certificado SSL enviado pelo servidor. 

só tenho certificado desses dois estados para testar. (ambiente de produção)

Share this post


Link to post
Share on other sites

Para MG é preciso definir a versão do componente como 3.10 já que não existe ainda a URL do webservice do método de consulta de cadastro na versão 4.00.

  • Thanks 1

Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Share this post


Link to post
Share on other sites
35 minutos atrás, Joabe Geraldo disse:

Vou fazer este procedimento, @BigWings

Mas será que com a desativação dos WebServices da versão 3.10 a consulta ao cadastro continuará funcionando?

Se for desativado sem informar um novo na versão 4.00, não.


Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Share this post


Link to post
Share on other sites

Aqui no RS também não está funcionando...

Anteriormente eu havia configurado o componente explicitamente para a versão 3.10 e estava funcionando, mas acredito que essa versão do webservice tenha sido desativada em definitivo.

Share this post


Link to post
Share on other sites

Foram disponibilizadas as URLs para consulta de cadastro versão 4.00 para MG em http://www.sped.fazenda.mg.gov.br/spedmg/nfe/webservices/

Porém ao efetuar a consulta retorna o seguinte XML:

<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope"><soap:Body><soap:Fault><soap:Code><soap:Value>soap:Receiver</soap:Value></soap:Code><soap:Reason><soap:Text xml:lang="en">Fault occurred while processing.</soap:Text></soap:Reason></soap:Fault></soap:Body></soap:Envelope>

Se alterar para versão 3.10 retorna os dados da consulta corretamente ainda.

Edited by everson.turossi

Share this post


Link to post
Share on other sites

Eu atualizei meu arquivo .ini, de acordo com os links do site SPED MG: http://www.sped.fazenda.mg.gov.br/spedmg/nfe/webservices/ . Mas ainda não consegui realizar a consulta do cadastro para o estado de MG.

Quando tentava realizar a consulta, antes de atualizar o arquivo .ini, eu tive o seguinte retorno:

<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope">
	<soap:Body>
		<soap:Fault>
			<soap:Code>
				<soap:Value>soap:Sender</soap:Value>
			</soap:Code>
			<soap:Reason>
				<soap:Text xml:lang="en">
					Message part {  http://www.portalfiscal.inf.br/nfe/wsdl/CadConsultaCadastro4}nfeDadosMsg was not recognized.  (Does it exist in service WSDL?)
				</soap:Text>
			</soap:Reason>
		</soap:Fault>
	</soap:Body>
</soap:Envelope>

Após atualizar o arquivo .ini, adicionando as seguintes URL's:

  [NFe_MG_H]
    NFeStatusServico_4.00=https://hnfe.fazenda.mg.gov.br/nfe2/services/NFeStatusServico4

  [NFe_MS_P]
    NfeConsultaCadastro_4.00=https://nfe.fazenda.mg.gov.br/nfe2/services/CadConsultaCadastro4

 

Também não foi possível realizar a consulta, e tive o seguinte retorno:

<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope">
	<soap:Body>
		<soap:Fault>
			<soap:Code>
				<soap:Value>soap:Receiver</soap:Value>
			</soap:Code>
			<soap:Reason>
				<soap:Text xml:lang="en">Fault occurred while processing.</soap:Text>
			</soap:Reason>
		</soap:Fault>
	</soap:Body>
</soap:Envelope>


Eu estou usando a versão 4.0. Para os outros estados a consulta funciona normalmente como por exemplo o estado de SP.
 

Share this post


Link to post
Share on other sites

 

Em 13/11/2018 at 15:57, lucasviniciosfs disse:

Estou obtendo esse erro ao realizar a consulta para GO

Alguém pode me ajudar?

image.png.5ec93fc76f5022be747700407f3e2632.png

 

2.2 - Permaneça no assunto - Quando tiver uma dúvida diferente do assunto no tópico, poste em novo tópico. Não use algo equivalente a "aproveitando o gancho... [dúvida não relacionada com o tópico aqui]". Favor leia as regras do fórum.


Equipe ACBr

Felipe Eduardo Resende Mesquita

Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

 

 

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...