Jump to content

Nova Loja Oficial
loja.projetoacbr.com.br
Ajude o projeto a crescer, com estilo

Comprar

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

Francisco IBS

ANSWERED 905 - Rejeicao: Campos do grupo Fatura nao informados

Recommended Posts

6 minutos atrás, Fabio Fredianelli disse:

Ta difícil de acompanhar... foi... nao foi... vai... não vai... 

Já atualizei os schemas, mas não vai... a melhor opção aqui foi a do piracaiasoft....

Estou achando que resposta dos moderadores só no SAC, acho que vou pagar...

da uma verificada se no teu arquivo "leiauteNFe_v4.00.xsd", as tag do faturamento estão assim:

image.png.9e887d682cf52699bf9d94e3649c61e2.png

Com o type="TDec_1302", pois na versao atual esta diferente, ai aponta para uma sequencia de caracteres da expressão regular diferente.

Share this post


Link to post
Share on other sites
5 minutos atrás, eduardoazambuja disse:

da uma verificada se no teu arquivo "leiauteNFe_v4.00.xsd", as tag do faturamento estão assim:

image.png.9e887d682cf52699bf9d94e3649c61e2.png

Com o type="TDec_1302", pois na versao atual esta diferente, ai aponta para uma sequencia de caracteres da expressão regular diferente.

O meu já está assim!  :-(

 


Reverson Nogueira Tricoletti

http://www.maxsofttecnologia.com.br

Share this post


Link to post
Share on other sites

Realmente PCEZAR, você toda razão. Esta SEFAZ está uma BAGUNÇA , até uma semana a traz estava tirando nota na empresa na versao 4.0 numa boa, agora  estão com estas frescuras.

Pois toa hora temos que fica mudando código por causa desta SEFAZ, acho que nem eles mesmo sabem o que estão fazendo

Share this post


Link to post
Share on other sites
1 hora atrás, Jeison Peres Rodrigues disse:

Bom dia,

em homologação até autoriza a NF-e, porém esses schemas ainda não estão em produção, e  provavelmente se você enviar com o vDesc zerado não vai validar.

Esses schemas entram em produção na próxima segunda-feira.

Desculpe a pergunta, mas de onde vc conseguiu essa informação?

6 minutos atrás, Reverson disse:

O meu já está assim!  :-(

 

e vc chegou a alterar o fonte do ACBR??

Share this post


Link to post
Share on other sites
4 minutos atrás, Jeison Peres Rodrigues disse:

Opa eduardoazambuja, não cheguei a alterar o fonte do ACBR, e também não testei em produção. Meu comentário foi baseado no documento NT_2016_002_v1_60.pdf.

image.png.c2be6ea7f03acfdc0750dc8cd5dc949e.png

1_60.thumb.png.fffdb7bd4337298e4a376ce4a8fac1e0.png

Share this post


Link to post
Share on other sites
1 minuto atrás, andepunk disse:

1_60.thumb.png.fffdb7bd4337298e4a376ce4a8fac1e0.png

Entendi.

fiz a alteração no fonte do acbr que outro amigo aqui do grupo sugeriu, atualizei os schemas pelo link que ja foi postado e consegui transmitir, em homologação.

 

Share this post


Link to post
Share on other sites
1 minuto atrás, eduardoazambuja disse:

Entendi.

fiz a alteração no fonte do acbr que outro amigo aqui do grupo sugeriu, atualizei os schemas pelo link que ja foi postado e consegui transmitir, em homologação.

 

Tem varias regras que ainda nao estao implementadas pelo menos em SP. Essa alteração do vDesc so funciona em homologação, coloquei em produção e não autorizou vai ser somente depois do dia 03/09 mesmo (Testado em SC).

Share this post


Link to post
Share on other sites
1 minuto atrás, andepunk disse:

Tem varias regras que ainda nao estao implementadas pelo menos em SP. Essa alteração do vDesc so funciona em homologação, coloquei em produção e não autorizou vai ser somente depois do dia 03/09 mesmo (Testado em SC).

Legal.

E será que algum dos moderadores vao alterar o fonte e liberar uma nova atualização?

Share this post


Link to post
Share on other sites
Citar

Unit pcnNfeW

 

Linha 2208..

trocar  Gerador.wCampo(tcDe2, 'Y05', 'vDesc  ', 01, 15, 0, nfe.Cobr.Fat.vDesc, DSC_VDESC);

por

Gerador.wCampo(tcDe2, 'Y05', 'vDesc  ', 01, 15, 1, nfe.Cobr.Fat.vDesc, DSC_VDESC);

Dessa forma a tag vDesc sempre será gerada..

Deu certo o envio do XML no ambiente de homologação aqui em SP

Share this post


Link to post
Share on other sites
12 minutos atrás, info02serraf disse:

Deu certo o envio do XML no ambiente de homologação aqui em SP

Aqui (SP) funcionou apenas em homologação. Em produção deu erro de schema.

Share this post


Link to post
Share on other sites
30 minutos atrás, eduardoazambuja disse:

Entendi.

fiz a alteração no fonte do acbr que outro amigo aqui do grupo sugeriu, atualizei os schemas pelo link que ja foi postado e consegui transmitir, em homologação.

 

Opa Eduardo, no meu entendimento os schemas serão atualizados dia 09/07/2018 em produção, e somente apartir dessa data será aceito o campo vDesc=0.

Share this post


Link to post
Share on other sites
Agora, Jeison Peres Rodrigues disse:

Opa Eduardo, no meu entendimento os schemas serão atualizados dia 09/07/2018 em produção, e somente apartir dessa data será aceito o campo vDesc=0.

pois é. foi o que eu entendi tbm... :)

Share this post


Link to post
Share on other sites
29 minutos atrás, Jeison Peres Rodrigues disse:

Opa Eduardo, no meu entendimento os schemas serão atualizados dia 09/07/2018 em produção, e somente apartir dessa data será aceito o campo vDesc=0.

Só espero que nesse dia eles aceitem tb como está hoje. Pq senão vai ser uma correria enorme atualizar todos os sistemas.

Share this post


Link to post
Share on other sites
17 horas atrás, LEANDRODOCOUTO disse:

Unit pcnNfeW

Linha 2208..

trocar  Gerador.wCampo(tcDe2, 'Y05', 'vDesc  ', 01, 15, 0, nfe.Cobr.Fat.vDesc, DSC_VDESC);

por

Gerador.wCampo(tcDe2, 'Y05', 'vDesc  ', 01, 15, 1, nfe.Cobr.Fat.vDesc, DSC_VDESC);

Dessa forma a tag vDesc sempre será gerada..

 

Realmente mudando esta linha no ACBR funcionou legal em SP Homologação.

obs. não confie exatamente no numero da linha a ser corrigido depende quanto baixou seu ACBR

no meu caso estava na linha 2194

//    Gerador.wCampo(tcDe2, 'Y05', 'vDesc  ', 01, 15, 0, nfe.Cobr.Fat.vDesc, DSC_VDESC);
    Gerador.wCampo(tcDe2, 'Y05', 'vDesc  ', 01, 15, 1, nfe.Cobr.Fat.vDesc, DSC_VDESC);

 

Share this post


Link to post
Share on other sites
21 minutos atrás, saverio disse:

Realmente mudando esta linha no ACBR funcionou legal em SP Homologação.

obs. não confie exatamente no numero da linha a ser corrigido depende quanto baixou seu ACBR

no meu caso estava na linha 2194

//    Gerador.wCampo(tcDe2, 'Y05', 'vDesc  ', 01, 15, 0, nfe.Cobr.Fat.vDesc, DSC_VDESC);
    Gerador.wCampo(tcDe2, 'Y05', 'vDesc  ', 01, 15, 1, nfe.Cobr.Fat.vDesc, DSC_VDESC);

 

Funciona perfeito em SP Homologação alterando a linha e o arquivo do leiauteNFe_v4.00.xsd

image.png.4066f5c86778b2597fa5ed6de40bd7ae.png

Edited by André Luis - Minf

 

André Luis
Minf Informática
11 3441-6788
www.minf.com.br
facebook.com/MinfInformatica

Share this post


Link to post
Share on other sites
9 minutos atrás, DOCFABIO disse:

No RS, homologação, coloquei assim para quebra-galho e passou legal:
Cobr.Fat.vDesc := 0.001;

em Produção não dá esses erros...

Share this post


Link to post
Share on other sites
26 minutos atrás, DOCFABIO disse:

No RS, homologação, coloquei assim para quebra-galho e passou legal:
Cobr.Fat.vDesc := 0.001;

sim é verdade também funcionou legal sem precisar mexer nos fontes do ACBR, mas aqui em SP mesmo em produção se não tiver esses quebra galhos não esta funcionando ainda.

Edited by saverio

Share this post


Link to post
Share on other sites

Galera.. uma sugestão.. voltem pra versão 3.1.. até o dia 09/07 ..aonde essas validações vão valer pro ambiente de produção.. eu, por exemplo, colocando 0.001 no vdesc não funcionou, e não tive problema nenhum com as tags de pagamento ..

Share this post


Link to post
Share on other sites
10 minutos atrás, Fabio Fredianelli disse:

 

 

 

Dizer que não gostei do suporte dado é comentário grosseiro ? 

Li o forum errado ou o workarround passa pela alteração do fonte do ACBR ?

 

 

ISSO É PROBLEMA NO SEFAZ ELES QUE VÃO TER QUE FAZER AS ALTERAÇÕES NECESSARIAS! Mas o pessoal já deixou 2 dicas aqui para ir quebrando o galho, atualiza seus Schemas com os que foram postados aqui e coloca Cobr.Fat.vDesc := 0.001;

enquanto o sefaz não toma um rumo vai usando assim ok

1 minuto atrás, LEANDRODOCOUTO disse:

Galera.. uma sugestão.. voltem pra versão 3.1.. até o dia 09/07 ..aonde essas validações vão valer pro ambiente de produção.. eu, por exemplo, colocando 0.001 no vdesc não funcionou, e não tive problema nenhum com as tags de pagamento ..

mas para Cobr.Fat.vDesc := 0.001; funcionar vc precisa atualizar os Schemas, neste post tem uns links para download dos novos Schemas

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...