Jump to content

Promoção 25 Anos de Delphi
25% de desconto em todas as versões

Saiba mais

Ganhe o curso Tributação NF-e para Desenvolvedores

Assinando o SAC Anual este mês
botao.png

 

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba Mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

7Master

Falha no schema XML NFe 4.0

Recommended Posts

Pessoal hoje atualizei e instalei o ACBR, copiei a pasta schema e ao emitir uma nfe dar esse erro: Falha no schema XML NFe e retorna o status zero(0);

Alguém sabe dizer se está com algum problema?

Untitled-1.gif

Share this post


Link to post
Share on other sites

Já esta com essas novas configurações e novos schemas, mas continua dando pau. O pessoal da SEFAZ aqui insiste em informar que está tudo ok com WS

Share this post


Link to post
Share on other sites
40 minutos atrás, 7Master disse:

Já esta com essas novas configurações e novos schemas, mas continua dando pau.

O que exatamente você configurou?

Anexe o XML para análise.


Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Share this post


Link to post
Share on other sites
9 horas atrás, 7Master disse:

Pessoal hoje atualizei e instalei o ACBR, copiei a pasta schema e ao emitir uma nfe dar esse erro: Falha no schema XML NFe e retorna o status zero(0);

Alguém sabe dizer se está com algum problema?

Untitled-1.gif

Estou com mesmo problema, estou emitindo um nota para o Ceará em homologação  e está retornando a rejeição 225 !!!! Anexei o meu xml se alguém puder ajudar agradeço !!!

23180722594086000160550010000000211000009597-nfe.xml

Edited by elixandre

Share this post


Link to post
Share on other sites
1 minuto atrás, elixandre disse:

Estou com mesmo problema, estou emitindo um nota para o Ceará em homologação  e está retornando o mesmo erro !!!! Anexei o meu xml !!!

23180722594086000160550010000000211000009597-nfe.xml

Chegou a ler o tópico que citei mais acima?

Em 17/07/2018 at 15:36, André Ferreira de Moraes disse:

Caso receba como retorno do envio "Falha no Schema XML" seu estado ainda não está aplicando a regra acima, neste caso a propriedade CamposFatObrigatorios deverá receber o valor FALSE.


Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Share this post


Link to post
Share on other sites
2 horas atrás, BigWings disse:

Chegou a ler o tópico que citei mais acima?

 

Li sim , se coloco CamposFatObrigatorios para False retorna :

905-Rejeição: Campos do grupo Fatura não informados

e se coloco CamposFatObrigatorios para True retorna :

Erro Retornado : Rejeicao: Falha no Schema XML da NFe

das duas forma o erro persiste !!!

 

Share this post


Link to post
Share on other sites
52 minutos atrás, elixandre disse:

Li sim , se coloco CamposFatObrigatorios para False retorna :

905-Rejeição: Campos do grupo Fatura não informados

e se coloco CamposFatObrigatorios para True retorna :

Erro Retornado : Rejeicao: Falha no Schema XML da NFe

das duas forma o erro persiste !!!

 

Depois de várias tentativas só conseguir fazer funcionar fazendo a "gambiara" sugerido pelo amigo no post citado sobre a regra de validação Y01-20.

deixei CamposFatObrigatorios para True, e fiz como algo parecido com

<fat>
  <nFat>000001</nFat>
   <vOrig>1.01</vOrig>
   <vDesc>0.01</vDesc>
   <vLiq>1.00</vLiq>
</fat>

somar no valor  original 0.01 para depois dar um desconto de 0.01 , para fechar o valor .... e assim conseguir autorizar. 

Mas dúvida esse "problema" só esta acontecendo em ambiente de homologação ou no de produção também está com mesmo erro ?

teremos que sempre informar um desconto para passar ???

Share this post


Link to post
Share on other sites
10 horas atrás, elixandre disse:

Mas dúvida esse "problema" só esta acontecendo em ambiente de homologação ou no de produção também está com mesmo erro ?

teremos que sempre informar um desconto para passar ???

Provavelmente a SEFAZ aplicou a regra mas esqueceu de atualizar os schemas que permitem que a regra seja aplicada.

Reporte o problema a eles, para que façam a correção.


Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Share this post


Link to post
Share on other sites
14 horas atrás, BigWings disse:

O que exatamente você configurou?

Anexe o XML para análise.

Estou com mesmo problema ainda, liguei para SEFAZ e fui informando que o suporte técnico da 4.0 foi passado para o SEBRAE  e não tem telefone, o suporte é por email. Até o momento não me responderam.

Estou com esse mesmo retorno conforme o amigo colocou.

905-Rejeição: Campos do grupo Fatura não informados

e se coloco CamposFatObrigatorios para True retorna :

Erro Retornado : Rejeicao: Falha no Schema XML da NFe

 

Infelizmente nosso estado em relação a parte fiscal a SEFAZ sempre deixou a desejar, não quero informar vDesc = 0.01, pois pode gerar um problema no futuro. Se os amigos do projeto ou nós mesmos aqui deste post conseguir vamos publicar aqui a solução para que outras pessoas possam ser ajudadas.

Conto com vcs e contem comigo, assim que eu tiver uma posição deles ou uma solução postarei aqui.

 

Abraço

7 minutos atrás, BigWings disse:

Provavelmente a SEFAZ aplicou a regra mas esqueceu de atualizar os schemas que permitem que a regra seja aplicada.

Reporte o problema a eles, para que façam a correção.

Verdade, pode ser. Já passei pra eles ontem

Share this post


Link to post
Share on other sites

Resposta deles

----- Mensagem original --------

Assunto: Re: Fwd: Re: O WS 4.0 está ok?
Data: Tue, 24 Jul 2018 16:12:30 -0300
De: Juliana Magalhaes 
Empresa: Secretaria da Fazenda
Para: Fabiano Ramos <[email protected]>, 



Fabiano,

Como vários contribuintes estão acessando os web services da versão 4.00 de NFE com sucesso, sugerimos que o contribuinte teste o acesso fora do sistema dele, usando alguma ferramenta simples, exemplo o SoapUI, para que assim ele possa ter certeza que nossos serviços estão disponíveis. 

O fato dele conseguir acessar a contingência não indica que ele esteja acessando corretamente os nossos serviços, inclusive as URLs...

Dica de como configurar o TLS no soapUI:
https://blogs.perficient.com/ibm/2016/02/19/4-steps-to-enable-tls-protocols-in-soap-ui/

Exemplo de URL de um dos web services para ser usada no teste:
https://nfeh.sefaz.ce.gov.br/nfe4/services/NFeStatusServico4?WSDL

Lembrando também que é necessário configurar as opções de SSL no soapUI (SSL Settings > KeyStore e KeyStore Password).

As URLs dos demais serviços estão disponíveis em:
http://nfeh.sefaz.ce.gov.br/pages/informacoes/web_services.jsf
 

-- 
Atenciosamente,

Juliana Magalhães
SEFAZ-CE / CAT / CESINF
 
1 minuto atrás, 7Master disse:

Resposta deles

----- Mensagem original --------

Assunto: Re: Fwd: Re: O WS 4.0 está ok?
Data: Tue, 24 Jul 2018 16:12:30 -0300
De: Juliana Magalhaes 
Empresa: Secretaria da Fazenda
Para: Fabiano Ramos <[email protected]>, 



Fabiano,

Como vários contribuintes estão acessando os web services da versão 4.00 de NFE com sucesso, sugerimos que o contribuinte teste o acesso fora do sistema dele, usando alguma ferramenta simples, exemplo o SoapUI, para que assim ele possa ter certeza que nossos serviços estão disponíveis. 

O fato dele conseguir acessar a contingência não indica que ele esteja acessando corretamente os nossos serviços, inclusive as URLs...

Dica de como configurar o TLS no soapUI:
https://blogs.perficient.com/ibm/2016/02/19/4-steps-to-enable-tls-protocols-in-soap-ui/

Exemplo de URL de um dos web services para ser usada no teste:
https://nfeh.sefaz.ce.gov.br/nfe4/services/NFeStatusServico4?WSDL

Lembrando também que é necessário configurar as opções de SSL no soapUI (SSL Settings > KeyStore e KeyStore Password).

As URLs dos demais serviços estão disponíveis em:
http://nfeh.sefaz.ce.gov.br/pages/informacoes/web_services.jsf
 

-- 
Atenciosamente,

Juliana Magalhães
SEFAZ-CE / CAT / CESINF
 

O status consulta normalmente, o problema ocorre ao enviar a NFe

Share this post


Link to post
Share on other sites

Boa tarde.

Este tópico está inativo a algum tempo e por isso será fechado, caso necessário favor criar um novo tópico.

Att.


Consultora SAC ACBr

Juliana Tamizou
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...