Jump to content

Assista tectoy.png

chamada diadoacbr

Impressão Fortes - Itens com descrição "cortada"


Murilo Sousa
Go to solution Solved by Murilo Sousa,
  • Este tópico foi criado há 1432 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Boa tarde.

Estou realizando alguns testes na impressão FortesReport e pude perceber que houveram alterações na maneira como os itens são impressos no cupom. Na rv 14513 do SVN, percebi inclusive que a fonte do RLMemo mLinhaItem foi alterada na unit ACBrSATExtratoFortesFr.pas juntamente com o cálculo de tamanho. Segundo o log, o motivo seria "Ajuste para que o calculo da altura da página, seja feito pelo próprio Fortes Report, através da nova propriedade: "UnlimitedHeight := True" (por: DSA)". 

Depois dessa atualização, alguns clientes passaram a reclamar que a descrição do item no cupom está saindo "cortada". Existe algum parâmetro ou propriedade para corrigir isso (com exceção da propriedade ACBrSATExtratoFortes1.ImprimeEmUmaLinha = True ) ?

Obrigado desde já!

Link to comment
Share on other sites

Bom dia, pessoal.

@Daniel Simoes eu não havia me atentado a isso.. Vou atualizar os fontes aqui e logo posto o resultado. Obrigado!

@André Ferreira de Moraes, é uma impressora VOX.. De acordo com a Elgin, essa impressora não suporta imprimir QRCode (nem mesmo atualizando o firmware).. Ja testei pelo EscPOS e não imprimiu o QR, apenas pelo Fortes, só que o fortes estava cortando a descrição do item.. Mas conforme o Daniel disse, saiu atualização para isso.. Vou atualizar aqui. Obrigado!

Link to comment
Share on other sites

Bom dia. Fiz a atualização do ACBrSATExtratoFortesFr e resolveu meu problema. O novo layout da impressão fortes ficou melhor. 

@André Ferreira de Moraes eu fiz esse procedimento. Porém, um cliente que é super mercado emite grande quantidade de itens por cupom. Um de seus argumentos é que a impressão sai muito grande ?‍♂️?

Obrigado, pessoal.

Link to comment
Share on other sites

Boa tarde Pessoal,

Atualizei hoje o ACBr, porém os dados do CF-e não estão aparecendo totalmente (Saindo  "cortado").

Estou usando a impressora Bematech MP-4200 TH com o Componente TACBrATExtratoFortes, com as configurações padrões do SATTeste.

Conforme os anexos:

4033da08-e13d-4ef3-9fba-25c990244eda.jpg

07c8b0f3-6499-46a6-95cc-dfd205f7d597.jpg

 

ddbeffdc-1939-43ff-ba59-6c75ee0f8b9d.jpg

Edited by cgarrotti
Link to comment
Share on other sites

  • Este tópico foi criado há 1432 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.