Jump to content

110.png

Curso Gratuito para todos Usuários
+ Super Treinamento Assinando o SAC Anual

botao_campanha_thulio.png

sem_ttulo-620.fw_-e1583866078274.png 

Curso Dominando o ACBrMonitor
Novo Módulo Soluções de Varejo
Assine o SAC ACBr em qualquer plano e tenha acesso

Saiba Mais

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba Mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

edjborges

Consulta situação cadastral - NFe 4.00 - SP - Rej 215 falha no schema

Recommended Posts

Boa tarde,

Desde o dia 02/08/2018 que ocorreu a virada para NFe 4.00 a consulta da situação cadastral no estado de SP está retornando rejeição 215: Falha no schema XML
 

- Já atualizei os schames;
- Já verifiquei URLs;
- Já fiz a mudança das DLLs para usar MinGW; estou usando OpenSSL e forçando TLS 1.2;
- Já tentei na versão ve200, ve310 e ve400; todas retornam o mesmo erro no estado de SP;

XML de Envio:
<?xml version="1.0" encoding="UTF-8"?><ConsCad xmlns="http://www.portalfiscal.inf.br/nfe" versao="4.00"><infCons><xServ>CONS-CAD</xServ><UF>SP</UF><CNPJ>47964911000100</CNPJ></infCons></ConsCad>

XML de Retorno:
<?xml version="1.0" encoding="UTF-8"?><retConsCad versao="2.00" xmlns="http://www.portalfiscal.inf.br/nfe"><infCons><verAplic>SP_NFE_PL009_V4</verAplic><cStat>215</cStat><xMotivo>Rejeição: Falha no schema XML</xMotivo><UF></UF><dhCons>0001-01-01T00:00:00+00:00</dhCons><cUF>35</cUF></infCons></retConsCad>

Alguém está conseguindo consultar ?

 

Share this post


Link to post
Share on other sites
1 hora atrás, edjborges disse:

Alguém está conseguindo consultar ?

Fiz o teste pelo demo do ACBrNFe e a consulta retornou normalmente, se configurado para ve400.

Configurando para ve310 a rejeição é a de falha no schema XML.


Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Share this post


Link to post
Share on other sites
Em 06/08/2018 at 16:41, edjborges disse:

Boa tarde,

Desde o dia 02/08/2018 que ocorreu a virada para NFe 4.00 a consulta da situação cadastral no estado de SP está retornando rejeição 215: Falha no schema XML
 

- Já atualizei os schames;
- Já verifiquei URLs;
- Já fiz a mudança das DLLs para usar MinGW; estou usando OpenSSL e forçando TLS 1.2;
- Já tentei na versão ve200, ve310 e ve400; todas retornam o mesmo erro no estado de SP;

XML de Envio:
<?xml version="1.0" encoding="UTF-8"?><ConsCad xmlns="http://www.portalfiscal.inf.br/nfe" versao="4.00"><infCons><xServ>CONS-CAD</xServ><UF>SP</UF><CNPJ>47964911000100</CNPJ></infCons></ConsCad>

XML de Retorno:
<?xml version="1.0" encoding="UTF-8"?><retConsCad versao="2.00" xmlns="http://www.portalfiscal.inf.br/nfe"><infCons><verAplic>SP_NFE_PL009_V4</verAplic><cStat>215</cStat><xMotivo>Rejeição: Falha no schema XML</xMotivo><UF></UF><dhCons>0001-01-01T00:00:00+00:00</dhCons><cUF>35</cUF></infCons></retConsCad>

Alguém está conseguindo consultar ?

 

Creio que vc primeiro precise isolar o problema.

Abra o IE 11, assegure-se que em Opções da Internet, esteja assim

image.png.7dd0682dfde784da53f90037927f987e.png

se não estiver coloque dessa forma , feche o IE e reabra.

No navegador consulte a URL :   
https://nfe-homologacao.svrs.rs.gov.br/ws/NfeStatusServico/NfeStatusServico4.asmx?wsdl

Deverá solicitar o certificado e após digitar deverá exibir o resultado positivo

image.thumb.png.688a617b63e15a96adff824cb5f8accb.png

 

Se não exibir, no windows não esta ativo o TLS 1.2

 

 

 

 

Share this post


Link to post
Share on other sites

Boa tarde Antonio Carlos,

Verifiquei sim as configurações do internet explorer, estão como você mencionou.

Fiz o teste no link que passou também, e abriu certinho.

ainda não consegui descobrir o que é. Se tiver mais alguma ideia.

Obrigado

20 horas atrás, Antonio Carlos L disse:

Creio que vc primeiro precise isolar o problema.

Abra o IE 11, assegure-se que em Opções da Internet, esteja assim

image.png.7dd0682dfde784da53f90037927f987e.png

se não estiver coloque dessa forma , feche o IE e reabra.

No navegador consulte a URL :   
https://nfe-homologacao.svrs.rs.gov.br/ws/NfeStatusServico/NfeStatusServico4.asmx?wsdl

Deverá solicitar o certificado e após digitar deverá exibir o resultado positivo

image.thumb.png.688a617b63e15a96adff824cb5f8accb.png

 

Se não exibir, no windows não esta ativo o TLS 1.2

 

 

 

 

 

Em 06/08/2018 at 18:26, BigWings disse:

Fiz o teste pelo demo do ACBrNFe e a consulta retornou normalmente, se configurado para ve400.

Configurando para ve310 a rejeição é a de falha no schema XML.

 

Em 06/08/2018 at 18:26, BigWings disse:

Fiz o teste pelo demo do ACBrNFe e a consulta retornou normalmente, se configurado para ve400.

Configurando para ve310 a rejeição é a de falha no schema XML.

Boa tarde BigWings,

Estou tentando também pelo Exemplo do ACBR (ACBrNFe) e está retornando o mesmo erro:

  <?xml version="1.0" encoding="utf-8" ?>
- <soap:Body>
- <retConsCad versao="2.00" xmlns="http://www.portalfiscal.inf.br/nfe">
- <infCons>
  <verAplic>SP_NFE_PL009_V4</verAplic>
  <cStat>215</cStat>
  <xMotivo>Rejeição: Falha no schema XML</xMotivo>
  <UF />
  <dhCons>0001-01-01T00:00:00+00:00</dhCons>
  <cUF>35</cUF>
  </infCons>
  </retConsCad>
  </nfeResultMsg>
  </soap:Body>
  </soap:Envelope>
 
Sabe o que pode ser ?
 
Obrigado

Share this post


Link to post
Share on other sites
19 minutos atrás, edjborges disse:

Boa tarde Antonio Carlos,

Verifiquei sim as configurações do internet explorer, estão como você mencionou.

Fiz o teste no link que passou também, e abriu certinho.

ainda não consegui descobrir o que é. Se tiver mais alguma ideia.

Obrigado

 

 

Boa tarde BigWings,

Estou tentando também pelo Exemplo do ACBR (ACBrNFe) e está retornando o mesmo erro:

  <?xml version="1.0" encoding="utf-8" ?>
- <soap:Body>
- <retConsCad versao="2.00" xmlns="http://www.portalfiscal.inf.br/nfe">
- <infCons>
  <verAplic>SP_NFE_PL009_V4</verAplic>
  <cStat>215</cStat>
  <xMotivo>Rejeição: Falha no schema XML</xMotivo>
  <UF />
  <dhCons>0001-01-01T00:00:00+00:00</dhCons>
  <cUF>35</cUF>
  </infCons>
  </retConsCad>
  </nfeResultMsg>
  </soap:Body>
  </soap:Envelope>
 
Sabe o que pode ser ?
 
Obrigado

Boa tarde, edjborges.

Anexe o xml para validação.


Equipe ACBr

Felipe Eduardo Resende Mesquita

Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

 

 

 

Share this post


Link to post
Share on other sites
2 minutos atrás, Felipe E. Resende Mesquita disse:

Boa tarde, edjborges.

Anexe o xml para validação.

Boa tarde,
Segue o xml anexos.

<?xml version="1.0" encoding="UTF-8"?>

<ConsCad versao="4.00" xmlns="http://www.portalfiscal.inf.br/nfe"> <infCons> <xServ>CONS-CAD</xServ> <UF>SP</UF> <CNPJ>44480747000160</CNPJ> </infCons> </ConsCad>

20180808163458-cad.xml

20180808163457-ped-cad.xml

Share this post


Link to post
Share on other sites
8 minutos atrás, edjborges disse:

Boa tarde,
Segue o xml anexos.

 

<?xml version="1.0" encoding="UTF-8"?>

<ConsCad versao="4.00" xmlns="http://www.portalfiscal.inf.br/nfe"> <infCons> <xServ>CONS-CAD</xServ> <UF>SP</UF> <CNPJ>44480747000160</CNPJ> </infCons> </ConsCad>

20180808163458-cad.xml

20180808163457-ped-cad.xml

Anexe todos por favor referente a essa operação.


Equipe ACBr

Felipe Eduardo Resende Mesquita

Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

 

 

 

Share this post


Link to post
Share on other sites
5 minutos atrás, Antonio Carlos L disse:

Uma coisa estranha é isso <dhCons>0001-01-01T00:00:00+00:00</dhCons

 

Também achei estranho mas não estou entendendo porque está retornando isso

Share this post


Link to post
Share on other sites
1 hora atrás, edjborges disse:

Estou tentando também pelo Exemplo do ACBR (ACBrNFe) e está retornando o mesmo erro:

Está configurando para a versão 4.00?

image.png


Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Share this post


Link to post
Share on other sites
4 minutos atrás, BigWings disse:

Está configurando para a versão 4.00?

image.png

Sim, está configurado para ve400

Você consultou um cadastro de contribuinte de SP ?

Share this post


Link to post
Share on other sites
11 minutos atrás, edjborges disse:

Sim, está configurado para ve400

Você consultou um cadastro de contribuinte de SP ?

Sim, o mesmo CNPJ deste tópico.

Teste de novo pelo demo e anexe o arquivo *-ped-cad-soap.xml gerado.


Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Share this post


Link to post
Share on other sites

Olá bom dia, alguém poderia por gentileza, anexar um xml onde a consulta do cnpj funcione para o estado de SP e GO ?

O xml de solicitação e o de retorno se possível, obrigada 

Share this post


Link to post
Share on other sites
10 minutos atrás, edjborges disse:

Pelo que vi, a diferença desse arquivo está aqui:

<ConsCad xmlns="http://www.portalfiscal.inf.br/nfe" versao="2.00">

Sendo o correto:

<ConsCad xmlns="http://www.portalfiscal.inf.br/nfe" versao="4.00">

Tem certeza que está configurando para a versão 4.00?


Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Share this post


Link to post
Share on other sites
10 minutos atrás, BigWings disse:

Pelo que vi, a diferença desse arquivo está aqui:

<ConsCad xmlns="http://www.portalfiscal.inf.br/nfe" versao="2.00">

Sendo o correto:

<ConsCad xmlns="http://www.portalfiscal.inf.br/nfe" versao="4.00">

Tem certeza que está configurando para a versão 4.00?

Tenho Certeza,

Tanto é que se eu clicar no link do arquivo aqui do fórum vai trazer:

 

<?xml version="1.0" encoding="UTF-8"?>

-<ConsCad versao="4.00" xmlns="http://www.portalfiscal.inf.br/nfe">


-<infCons>

<xServ>CONS-CAD</xServ>

<UF>SP</UF>

<CNPJ>47964911000100</CNPJ>

</infCons>

</ConsCad>

 

 

Segue a tela:

 

image.png.4b80a88ae02a3b1366f7f4a618e3ebc1.png

 

 

Share this post


Link to post
Share on other sites
3 minutos atrás, edjborges disse:

Tenho Certeza,

Tanto é que se eu clicar no link do arquivo aqui do fórum vai trazer:

 

<?xml version="1.0" encoding="UTF-8"?>

-<ConsCad versao="4.00" xmlns="http://www.portalfiscal.inf.br/nfe">

Verdade.

Ao comparar os dois arquivos, assumi que o correto fosse o arquivo com a versão 4.00, quando na verdade a versão correta é 2.00.

20180809101543-ped-cad.xml

20180809101543-ped-cad-soap.xml

20180809101546-cad.xml

20180809101546-cad-soap.xml

Como está o seu arquivo ACBrNFeServicos.ini?


Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Share this post


Link to post
Share on other sites
4 minutos atrás, BigWings disse:

Verdade.

Ao comparar os dois arquivos, assumi que o correto fosse o arquivo com a versão 4.00, quando na verdade a versão correta é 2.00.

20180809101543-ped-cad.xml

20180809101543-ped-cad-soap.xml

20180809101546-cad.xml

20180809101546-cad-soap.xml

Como está o seu arquivo ACBrNFeServicos.ini?

Está da forma originial que baixei do trunk2, as URLs de SP são:

 

[NFe_SP_P]
NfeRecepcao_2.00=https://nfe.fazenda.sp.gov.br/nfeweb/services/nferecepcao2.asmx
NfeRetRecepcao_2.00=https://nfe.fazenda.sp.gov.br/nfeweb/services/nferetrecepcao2.asmx
NfeInutilizacao_2.00=https://nfe.fazenda.sp.gov.br/nfeweb/services/nfeinutilizacao2.asmx
NfeConsultaProtocolo_2.00=https://nfe.fazenda.sp.gov.br/nfeweb/services/nfeconsulta2.asmx
NfeStatusServico_2.00=https://nfe.fazenda.sp.gov.br/nfeweb/services/nfestatusservico2.asmx
NfeConsultaCadastro_2.00=https://nfe.fazenda.sp.gov.br/ws/cadconsultacadastro2.asmx
RecepcaoEvento_1.00=https://nfe.fazenda.sp.gov.br/ws/RecepcaoEvento.asmx
NfeInutilizacao_3.10=https://nfe.fazenda.sp.gov.br/ws/nfeinutilizacao2.asmx
NfeConsultaProtocolo_3.10=https://nfe.fazenda.sp.gov.br/ws/nfeconsulta2.asmx
NfeStatusServico_3.10=https://nfe.fazenda.sp.gov.br/ws/nfestatusservico2.asmx
NfeAutorizacao_3.10=https://nfe.fazenda.sp.gov.br/ws/nfeautorizacao.asmx
NFeRetAutorizacao_3.10=https://nfe.fazenda.sp.gov.br/ws/nferetautorizacao.asmx
NfeInutilizacao_4.00=https://nfe.fazenda.sp.gov.br/ws/nfeinutilizacao4.asmx
NfeConsultaProtocolo_4.00=https://nfe.fazenda.sp.gov.br/ws/nfeconsultaprotocolo4.asmx
NfeStatusServico_4.00=https://nfe.fazenda.sp.gov.br/ws/nfestatusservico4.asmx
NfeConsultaCadastro_4.00=https://nfe.fazenda.sp.gov.br/ws/cadconsultacadastro4.asmx
RecepcaoEvento_4.00=https://nfe.fazenda.sp.gov.br/ws/nferecepcaoevento4.asmx
NFeAutorizacao_4.00=https://nfe.fazenda.sp.gov.br/ws/nfeautorizacao4.asmx
NFeRetAutorizacao_4.00=https://nfe.fazenda.sp.gov.br/ws/nferetautorizacao4.asmx

 

Segue anexo o arquivo também.

 

ACBrNFeServicos.ini

Share this post


Link to post
Share on other sites
1 hora atrás, BigWings disse:

Correto...

Quando à pasta de Schemas, é a mesma do repositório do ACBr?

Boa tarde BigWings,

Já havia feito testes de várias formas, eu tinha os schemas funcionando, apenas adicionar o pacote da versão 4.00 não deu certo. Limpei todos os schemas e peguei só o pacote da versão 4.00, também não deu certo, baixei novamente da versão 3.10 e da 4.00 coloquei junto e nada. Inclui da versão 2.00 e nada. Só não havia feito testes com o pacote de schemas baixado pelo ACBr.

RESOLVIDO: Usando a pasta de schemas do ACBR consultou normalmente. Atualizei os schemas do meu aplicativo e deu certo também.

Muito obrigado mesmo pela ajuda.

Abraço

  • Like 1

Share this post


Link to post
Share on other sites
12 minutos atrás, edjborges disse:

Boa tarde BigWings,

Já havia feito testes de várias formas, eu tinha os schemas funcionando, apenas adicionar o pacote da versão 4.00 não deu certo. Limpei todos os schemas e peguei só o pacote da versão 4.00, também não deu certo, baixei novamente da versão 3.10 e da 4.00 coloquei junto e nada. Inclui da versão 2.00 e nada. Só não havia feito testes com o pacote de schemas baixado pelo ACBr.

RESOLVIDO: Usando a pasta de schemas do ACBR consultou normalmente. Atualizei os schemas do meu aplicativo e deu certo também.

Muito obrigado mesmo pela ajuda.

Abraço

Oii, desculpe a ignorância, mas onde acha a pasta de schemas no ACBR? 

Share this post


Link to post
Share on other sites
5 minutos atrás, naiaragomesp disse:

Oii, desculpe a ignorância, mas onde acha a pasta de schemas no ACBR? 

Boa tarde, naiaragomesp

Basta você baixar os fontes e pastas através do Tortoise, veja o exemplo abaixo:

https://www.projetoacbr.com.br/fontes/

  • Thanks 1

Equipe ACBr

Felipe Eduardo Resende Mesquita

Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

 

 

 

Share this post


Link to post
Share on other sites
9 minutos atrás, naiaragomesp disse:

Oii, desculpe a ignorância, mas onde acha a pasta de schemas no ACBR? 

Boa tarde,

Se você já tem o ACBr baixado o caminho é:
..\ACBr\Exemplos\ACBrDFe\Schemas

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...