Jump to content

erro ao validar CT-e: tpMed is not a valid value of the local atomic type


Reinaldo Silveira
  • Este tópico foi criado há 695 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Olá amigos.

Ao tentar validar o xml CT-e em anexo pelo método:

ACBrCTe1.Conhecimentos.LoadFromFile(...);
ACBrCTe1.Conhecimentos.Validar;

recebo a seguinte exception:

erro.png.ce68c030b9f396a8346fb20f93f69d16.png

Observei que o xml possui caracteres acentuados, mas está sem a literal '<?xml version="1.0" encoding="UTF-8"?>' no início do arquivo.

Caso eu adicione, o arquivo é validado normalmente.

Alguma ideia de como proceder?

obs.: quando baixo o xml da receita, ele vem dessa forma (sem o encoding).

obs2: fontes e schemas atualizados.

Obrigado!

35180802012862004661570410000495991481082965.xml

Edited by Reinaldo Silveira
Link to comment
Share on other sites

  • Consultores

Bom dia Reinando,

Você deve ter baixando o XML diretamente do site da SEFAZ, correto?

Se sim, esse é o grande problema.

Infelizmente não temos como obrigar a SEFAZ fazer o dever de casa.

Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

  • 2 years later...
  • Este tópico foi criado há 695 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.