Jump to content

2 Dia do ACBr

Visite Stands dos Patrocinadores
Control iD, CS Devices, Elgin, Gertec, Bematech, Jetway, PlugMobile, Epson e Custom
Inscreva-se

Nova Loja Oficial
loja.projetoacbr.com.br
Ajude o projeto a crescer, com estilo

Comprar

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

tdpsistemas

ANSWERED Emissão de NFe com Certificado na Nuvem RemoteID

Recommended Posts

Em 22/01/2019 at 16:52, tdpsistemas disse:

Boa tarde.

Um cliente nosso adquiriu um certificado A3 da Certisign na nuvem chamado RemoteID (https://www.certisign.com.br/certificado-digital/remoteid). Configuramos no sistema, ele consegue validar a NFe, porém ao transmitir ele retorna o seguinte erro: Rejeição: Assinatura difere do calculado. Cstat: 297

Em conversa com o suporte da Certisign, ele nos informaram que ele trabalha igual ao A3. Teoricamente era para funcionar normal no sistema com o Acbr.

Alguém já passou por isso? Alguma dica?

Obrigado.

bom dia. Como vc fez para configurar o certificado?

 

  • Like 1

Share this post


Link to post
Share on other sites
6 horas atrás, Joas Vilas Boas Fernandes disse:

bom dia. Como vc fez para configurar o certificado?

 

Também gostaria de informações, estamos em vias de fazer aquisição desse modelo.

Pelos relatos já está sendo usado... Se puderem compartilhar a experiência de informações de como configurar / usar será de grande valia.

Obrigado.

Edited by gutembergscosta

Share this post


Link to post
Share on other sites
12 horas atrás, Joas Vilas Boas Fernandes disse:

bom dia. Como vc fez para configurar o certificado?

 

 

5 horas atrás, gutembergscosta disse:

Também gostaria de informações, estamos em vias de fazer aquisição desse modelo.

Pelos relatos já está sendo usado... Se puderem compartilhar a experiência de informações de como configurar / usar será de grande valia.

Obrigado.

Pessoal... basta instalar corretamente e pronto. É apenas mais um certificado, estando instalado corretamente, vai funcionar as emissões usando ACBr.

Se prestarem atenção, o tópico foi aberto, pois, havia um problema que o @Daniel Simoes resolveu.

Eu não consegui testar mais, pois, o cliente acabou cancelando e comprou o A1, pois, estava com urgência. E para não perder o cliente, paguei metade do certificado A1 dele.

  • Like 1

Share this post


Link to post
Share on other sites
Em 19/03/2019 at 23:36, Marcelo Calvi Belanga disse:

 

Pessoal... basta instalar corretamente e pronto. É apenas mais um certificado, estando instalado corretamente, vai funcionar as emissões usando ACBr.

Se prestarem atenção, o tópico foi aberto, pois, havia um problema que o @Daniel Simoes resolveu.

Eu não consegui testar mais, pois, o cliente acabou cancelando e comprou o A1, pois, estava com urgência. E para não perder o cliente, paguei metade do certificado A1 dele.

minha duvida era em relação a configuração do ACBR. Consegui utilizando libWinCrypt. Uso Capicom para certificados instalados (obsoleta), openSSL para certificado com caminho físico e a senha.

Edited by Joas Vilas Boas Fernandes
  • Like 1

Share this post


Link to post
Share on other sites

Vinicius boa tarde,

Você está usando qual SSLLib para o certificado RemoteID?

Estou com a versão de 25/03 e o meu não funciona...

Obrigada!

 

Share this post


Link to post
Share on other sites

Configure para usar por libWinCrypt

  • Like 1

Consultor SAC ACBr

Daniel Simões de Almeida
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites
1 hora atrás, julianamver disse:

Vinicius boa tarde,

Você está usando qual SSLLib para o certificado RemoteID?

Estou com a versão de 25/03 e o meu não funciona...

Obrigada!

 

Configurando para usar por libWinCrypt dá erro de parâmetro incorreto, será problema na instalação? Pelo teste de instalação do site, aparece ok...

Share this post


Link to post
Share on other sites

Provavelmente é problema de instalação no Certificado...

Tente acessar alguma página (Web) de teste do Certificado...


Consultor SAC ACBr

Daniel Simões de Almeida
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites

Olá, 

Foi instalado o certificado RemoteID, e está retornando a seguinte mensagem de erro:  

Erro: 12186 - Falha ao obter a Chave Privada do Certificado para comunicação segura

O certificado A3 funciona normalmente. Testei também o remoteID numa pagina da internet, funciona sem problemas.

Estou usando as seguintes configurações.

      ACBrNFe1.SSL.SSLType := LT_TLSv1_2;
      ACBrNFe1.Configuracoes.Geral.SSLCryptLib   := cryWinCrypt;
      ACBrNFe1.Configuracoes.Geral.SSLHttpLib    := httpWinHttp; 
      ACBrNFe1.Configuracoes.Geral.SSLLib        := libWinCrypt;
      ACBrNFe1.Configuracoes.Geral.SSLXmlSignLib := xsLibXml2;

Alguém passou por esse problema com o RemoteId

 

Share this post


Link to post
Share on other sites

Verifique se você instalou com a possibilidade de Exportar a Chave... (o mesmo problema ocorreria no A3, sem essa opção habilitada)


Consultor SAC ACBr

Daniel Simões de Almeida
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites
2 horas atrás, gutembergscosta disse:

Olá, 

Foi instalado o certificado RemoteID, e está retornando a seguinte mensagem de erro:  

Erro: 12186 - Falha ao obter a Chave Privada do Certificado para comunicação segura

O certificado A3 funciona normalmente. Testei também o remoteID numa pagina da internet, funciona sem problemas.

Estou usando as seguintes configurações.

      ACBrNFe1.SSL.SSLType := LT_TLSv1_2;
      ACBrNFe1.Configuracoes.Geral.SSLCryptLib   := cryWinCrypt;
      ACBrNFe1.Configuracoes.Geral.SSLHttpLib    := httpWinHttp; 
      ACBrNFe1.Configuracoes.Geral.SSLLib        := libWinCrypt;
      ACBrNFe1.Configuracoes.Geral.SSLXmlSignLib := xsLibXml2;

Alguém passou por esse problema com o RemoteId

 

estou usando assim:

    ACBrNFe1.SSL.SSLType := LT_all;
      ACBrNFe1.Configuracoes.Geral.SSLCryptLib   := cryWinCrypt;
      ACBrNFe1.Configuracoes.Geral.SSLHttpLib    := httpWinHttp; 
      ACBrNFe1.Configuracoes.Geral.SSLLib        := libWinCrypt;
      ACBrNFe1.Configuracoes.Geral.SSLXmlSignLib := xsLibXml2;

esta comunicando 

Share this post


Link to post
Share on other sites
26 minutos atrás, Joas Vilas Boas Fernandes disse:

estou usando assim:

    ACBrNFe1.SSL.SSLType := LT_all;
      ACBrNFe1.Configuracoes.Geral.SSLCryptLib   := cryWinCrypt;
      ACBrNFe1.Configuracoes.Geral.SSLHttpLib    := httpWinHttp; 
      ACBrNFe1.Configuracoes.Geral.SSLLib        := libWinCrypt;
      ACBrNFe1.Configuracoes.Geral.SSLXmlSignLib := xsLibXml2;

esta comunicando 

Nesse caso para a nova versão da NFe ... será esse T_TLSv1_2;

2 horas atrás, Daniel Simoes disse:

Verifique se você instalou com a possibilidade de Exportar a Chave... (o mesmo problema ocorreria no A3, sem essa opção habilitada)

Na instalação do RemoteId não tem essa opção.

Share this post


Link to post
Share on other sites
6 horas atrás, Antonio Carlos L disse:

 

6 horas atrás, Antonio Carlos L disse:

Tenho visto muitos relatos de problemas envolvendo o RemoteID

Share this post


Link to post
Share on other sites

Boa Tarde! Sobre o certificado RemoteID tem que registrar alguma dll no windows? Pois sempre que tento consultar o status  do serviço recebo o erro da imagem em anexo.

Captura de Tela 2019-05-27 às 13.48.36.png

Share this post


Link to post
Share on other sites
1 hora atrás, jmsistemas disse:

Boa Tarde! Sobre o certificado RemoteID tem que registrar alguma dll no windows? Pois sempre que tento consultar o status  do serviço recebo o erro da imagem em anexo.

Captura de Tela 2019-05-27 às 13.48.36.png

Recompilei o ACBr assim 

{$DEFINE DFE_SEM_CAPICOM}

e funcionou

  • Like 1

Share this post


Link to post
Share on other sites
Em 27/05/2019 at 15:27, jmsistemas disse:

Recompilei o ACBr assim 

{$DEFINE DFE_SEM_CAPICOM}

e funcionou

o certificado RemotID tá funcionando certinho, comprei um pra testar mas ta dando erro  "FCertificado.PrivateKey.IsHardwareDevice" diz que não foi criado, gostaria de saber se tenho que usar o Token e onde coloco ele

Share this post


Link to post
Share on other sites
14 horas atrás, Eremar Mates disse:

o certificado RemotID tá funcionando certinho, comprei um pra testar mas ta dando erro  "FCertificado.PrivateKey.IsHardwareDevice" diz que não foi criado, gostaria de saber se tenho que usar o Token e onde coloco ele

Quando você faz o processo de emissão, instalação do certificado, também será preciso instalar o App de Token que vai ficar no celular ..

Tudo funcionando corretamente, será  solicitado digitar dois códigos, o PIN (como já ocorre) e depois o Token apresentado no aplicativo do Celular.

 

  • Like 2

Share this post


Link to post
Share on other sites
Em 20/07/2019 at 14:08, gutembergscosta disse:

Quando você faz o processo de emissão, instalação do certificado, também será preciso instalar o App de Token que vai ficar no celular ..

Tudo funcionando corretamente, será  solicitado digitar dois códigos, o PIN (como já ocorre) e depois o Token apresentado no aplicativo do Celular.

 

até ai entendi, quando consulto a validade do Certificado ele pede o TOKEN mas quando uso o método TACBrNFSe.Enviar(const ALote: String; Imprimir: Boolean): Boolean; do ACBr ele me um erro no ACBrDFeCapicom no método TDFeCapicom.CarregarCertificado na linha FCertificado.PrivateKey.IsHardwareDevice como se não tivesse criado só que em nenhum momento antes o ACBr me solicita o TOKEN.

Share this post


Link to post
Share on other sites
17 minutos atrás, Eremar Mates disse:

até ai entendi, quando consulto a validade do Certificado ele pede o TOKEN mas quando uso o método TACBrNFSe.Enviar(const ALote: String; Imprimir: Boolean): Boolean; do ACBr ele me um erro no ACBrDFeCapicom no método TDFeCapicom.CarregarCertificado na linha FCertificado.PrivateKey.IsHardwareDevice como se não tivesse criado só que em nenhum momento antes o ACBr me solicita o TOKEN.

Não uso o Capicom, e é incentivado deixar de usar por falta de suporte e não atender aos novos requisitos de criptografia das novas versões NFe.

  • Like 1

Share this post


Link to post
Share on other sites

Realmente esse tipo de certificado só funcionará com Wincrypt 

  • Like 1

Consultor SAC ACBr

Daniel Simões de Almeida
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...