Jump to content

NumCopias ???


Fabrício Melo
  • Este tópico foi criado há 1268 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Bom dia, implementei no meu sistema a opção "NumCopias" mas nunca tinha usado, até um cliente querer imprimir mais de uma via do boleto, descobri que a propriedade não funciona.

Fui na função "TACBrBoletoFCFR.PreparaRelatorio" e inclui a linha "frxReport.PrintOptions.Copies := NumCopias" e passou a dar erro na tentativa de impressão...

Resolvi fazendo um laço na chamada do AcbrBoleto.Imprimir...

Então:
Tem como corrigir essa opção e fazer o Boleto imprimir mais de uma via?
ou senão
Tem como tirar a propriedade ja que ela não é usada?

Não consegui corrigir o erro, então vi que ela não deve esta sendo usada por esse motivo...

?

 

Analysis and System Development - Delphi Programmer - Computer Technician - Developing solutions together

 

Link to comment
Share on other sites

  • Consultores

Boa tarde,

É para funcionar essa propriedade... Se mandar imprimir em pdf por exemplo não está gerando duas páginas? Verifique se NÃO está com a opção preview ou Setup da impressora habilitado, se estiver vai respeitar essas configurações e não a propriedade Copia.

  • Like 1
Consultor SAC ACBr

José Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

  • Moderadores
3 horas atrás, bilogyn disse:

Fui na função "TACBrBoletoFCFR.PreparaRelatorio" e inclui a linha "frxReport.PrintOptions.Copies := NumCopias" e passou a dar erro na tentativa de impressão...

Fiz essa mesma alteração e aparentemente funcionou.

Qual erro teve?

  • Like 1
Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Link to comment
Share on other sites

Reeinstalei as impressoras e tentei de novo, já que deu certo pra você, não deu mais o erro, mas continuo com uma só impressão, teste na impressora virtual e na física, ambas recebem dois comandos, mas umas das linhas sempre somem e fica sá a primeira, é bem rápido... so imprime uma via... seria esse o ponto certo?

 

image.thumb.png.478871f759d20de6c60a5f45eca2a028.png

image.thumb.png.a1b461d1b4d7bf44a29330af2c4ed400.png

image.png.69b4f0a8ee1833fb12d1974b59542c87.png

 

Analysis and System Development - Delphi Programmer - Computer Technician - Developing solutions together

 

Link to comment
Share on other sites

  • Moderadores
11 minutos atrás, bilogyn disse:

Reeinstalei as impressoras e tentei de novo, já que deu certo pra você, não deu mais o erro, mas continuo com uma só impressão, teste na impressora virtual e na física, ambas recebem dois comandos, mas umas das linhas sempre somem e fica sá a primeira, é bem rápido... so imprime uma via... seria esse o ponto certo?

Não me parece o melhor lugar pra essa configuração.

Enviei uma correção para o repositório, rev. 16584. Experimente testar novamente com o arquivo do repositório.

  • Like 2
Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Link to comment
Share on other sites

  • Este tópico foi criado há 1268 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.