Jump to content

2 Dia do ACBr

Visite Stands dos Patrocinadores
Control iD, CS Devices, Elgin, Gertec, Bematech, Jetway, PlugMobile, Epson, Custom e Sweda
Inscreva-se

Nova Loja Oficial
loja.projetoacbr.com.br
Ajude o projeto a crescer, com estilo

Comprar

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

João Paulo Müller

Erro validação OpenSSL ISSJoinvile

Recommended Posts

Boa tarde pessoal, estou obtendo o seguinte erro ao validar o XML para o provedor ISSJoinville:

Erro na validação: the schema itself is not valid

Detalhe: O erro ocorre somente utilizando OPENSSL.

Alguém teria alguma sugestão? Estou com os fontes e schemas atualizados, já troquei o diretório dos schemas para certificar e conferi as permissões.

 

Edited by João Paulo Müller

Share this post


Link to post
Share on other sites
1 hora atrás, João Paulo Müller disse:

Boa tarde pessoal, estou obtendo o seguinte erro ao validar o XML para o provedor ISSJoinville:

Erro na validação: the schema itself is not valid

Detalhe: O erro ocorre somente utilizando OPENSSL.

Alguém teria alguma sugestão? Estou com os fontes e schemas atualizados, já troquei o diretório dos schemas para certificar e conferi as permissões.

Veja se é o teu caso:

 


Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Share this post


Link to post
Share on other sites

Boa tarde BigWings,

Não seria este o caso, não estou lendo os arquivos da rede, estou lendo do D:\.

Inclusive alterei de diretório para verificar se resolveria o problema, mas persiste.

 

Share this post


Link to post
Share on other sites
1 minuto atrás, João Paulo Müller disse:

Boa tarde BigWings,

Não seria este o caso, não estou lendo os arquivos da rede, estou lendo do D:\.

Inclusive alterei de diretório para verificar se resolveria o problema, mas persiste.

Pode anexar o XML com o erro?


Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Share this post


Link to post
Share on other sites
19 horas atrás, BigWings disse:

Experimente substituir o xsd de schema com o anexo.

nfse_v2-04.xsd 58 kB · 0 downloads

Bom dia BigWings,

Testei com esse xsd e funcionou corretamente, tanto em OpenSSL quanto WinCrypt.

Esse xsd não está no repositório? Pois com o xsd do repositório está ocorrendo o erro.

O correto não seria trocar o xsd do repositório por este em anexo?

Share this post


Link to post
Share on other sites

Boa tarde João, 

Muito obrigado pelo retorno, ainda hoje estarei enviando para o repositório o XSD corrigido pelo nosso amigo BigWings.

  • Like 1

Consultor SAC ACBr Italo Jurisato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...