Jump to content

PE: ACBrNFe: Rejeição: Endereço do site da UF de Consulta por chave de acesso diverge do previsto


Go to solution Solved by Maxisoft,
  • Este tópico foi criado há 1203 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Boa tarde,

Hoje começou a rejeitar as nfce em homologação em PE:

Rejeição 878: Endereço do site da UF da Consulta por chave de ...

Conforme tópico:

 

 

Primeiro começou a rejeitar as que tinha a identificação do cliente. e as que não tinha autorizava. (estranho mas foi o que notei).

Dai atualizei os fontes e passou a não atualizar mais nenhuma (Não sei se estão mudando algo na sefaz).

 

 

 

Link to comment
Share on other sites

12 minutos atrás, charles.libano disse:

Parece que alteraram o endereço do servidor de consulta do SVRS para homologação e no ACBr ainda está o antigo.

Eu queria mudar manualmente para testar, mas não sei onde fica isso nos arquivos fontes.

Charles

Então, acredito que mudaram algo mesmo, pois de uma hora pra outra começou a não autorizar e gerar a rejeição.

Agora com relação a mudar os endereços dos webservices creio que fica na pasta ...\Fontes\ACBrDFe\ACBrNFe  no arquivo ACBrNFeServicos.ini

Link to comment
Share on other sites

na pasta ...\Fontes\ACBrDFe\ACBrNFe  no arquivo ACBrNFeServicos.ini estão todos iguais do site http://nfce.encat.org/desenvolvedor/webservices-h/ , ou seja, não há erros.

Na dúvida, ainda executei o bat Compila_RES.bat que tem na pasta  ...\Fontes\ACBrDFe\ACBrNFe e o erro continua.

O problema só ocorre no ambiente de homologação com NFCe.

NFe transmite normalmente.

Charles

Link to comment
Share on other sites

1 minuto atrás, charles.libano disse:

na pasta ...\Fontes\ACBrDFe\ACBrNFe  no arquivo ACBrNFeServicos.ini estão todos iguais do site http://nfce.encat.org/desenvolvedor/webservices-h/ , ou seja, não há erros.

Na dúvida, ainda executei o bat Compila_RES.bat que tem na pasta  ...\Fontes\ACBrDFe\ACBrNFe e o erro continua.

O problema só ocorre no ambiente de homologação com NFCe.

NFe transmite normalmente.

Charles

É estranho. Devem está fazendo alguma manutenção nos serviços ou algo do tipo. Pois eu enviei em homologação hoje normal, depois parou.

 

Link to comment
Share on other sites

  • Membros Pro

Hoje cedo (de 7:00 as 9:30) eu estava emitindo normalmente, com o acbr já atualizado. Depois das 10hs de hoje (com a mesma versão do acbr), começou a dar essa mensagem de erro.

Tudo indica que foram feitas alterações no webservice de consulta.

Link to comment
Share on other sites

1 minuto atrás, carlosinfoteen disse:

É estranho. Devem está fazendo alguma manutenção nos serviços ou algo do tipo. Pois eu enviei em homologação hoje normal, depois parou.

 

Acredito que deva mudar as URLS, RS já está redirecionando para https://www.sefaz.rs.gov.br/NFCE/NFCE-COM.aspx.

O complicado é fazer isso as "vésperas" de uma virada de versão. Parece que eles não tem noção nenhuma do nosso dia-a-dia.

Link to comment
Share on other sites

  • Membros Pro

Boa tarde amigos

Estou com o mesmo problema aqui em Sergipe, precisando testar em ambiente de homologação e o ambiente retornado este erro.

ainda fiz o seguinte: acessei o site da sefaz de Sergipe e vi o endereço como estava http://www.hom.nfe.se.gov.br/portal/consultarNFCeDCA.jsp diferente do que que tinha no acbrnfeservicos.ini, então modifiquei no arquivo, reiniciei o acbrnfemonitor mas não resolveu. Alguém tem uma luz?.

Link to comment
Share on other sites

  • Solution

Boa tarde.

Aqui consegui resolver alterando no bloco [NFCe_RS_H] do arquivo ACBrNFeServicos.ini o endereço da consulta do RS em homologação para:

www.sefaz.rs.gov.br/nfce/consulta

Sem o http:// na frente. Por incrível que pareça. Mas aqui funcionou. Após alterar o .ini só compilei o ACBrNFeServicos.rc e reinstalei o ACBr, dei um build e voltou a validar as NFC-e em homologação.

Cheguei a testar com o outro endereço que foi postado aqui ( https://www.sefaz.rs.gov.br/NFCE/NFCE-COM.aspx) mas não deu certo. Verifiquei no site http://nfce.encat.org/desenvolvedor/httpnfce-encat-orgconsulte-sua-nota-qr-code-versao-2-0/ e nele os endereços estão sem o http resolvi testar achando que não iria funcionar mas deu certo.

Os demais endereços não modifiquei, envio o arquivo ACBrNFeServicos.ini alterado em anexo, espero que ajude vocês.

 

ACBrNFeServicos.ini

  • Like 3
Link to comment
Share on other sites

5 minutos atrás, Maxisoft disse:

Boa tarde.

Aqui consegui resolver alterando no bloco [NFCe_RS_H] do arquivo ACBrNFeServicos.ini o endereço da consulta do RS em homologação para:

www.sefaz.rs.gov.br/nfce/consulta

Sem o http:// na frente. Por incrível que pareça. Mas aqui funcionou. Após alterar o .ini só compilei o ACBrNFeServicos.rc e reinstalei o ACBr, dei um build e voltou a validar as NFC-e em homologação.

Cheguei a testar com o outro endereço que foi postado aqui ( https://www.sefaz.rs.gov.br/NFCE/NFCE-COM.aspx) mas não deu certo. Verifiquei no site http://nfce.encat.org/desenvolvedor/httpnfce-encat-orgconsulte-sua-nota-qr-code-versao-2-0/ e nele os endereços estão sem o http resolvi testar achando que não iria funcionar mas deu certo.

Os demais endereços não modifiquei, envio o arquivo ACBrNFeServicos.ini alterado em anexo, espero que ajude vocês.

 

ACBrNFeServicos.ini 87 kB · 2 downloads

Correto, fiz o teste aqui e funcionou o mesmo.. basta tirar o http://

  • Like 1
Link to comment
Share on other sites

19 horas atrás, Felipe D. Silva disse:

Boa tarde,

aqui no Rio Grande do Norte está com o mesmo problema. 

Fiz o mesmo procedimento que sugeriram aí em cima, no nosso caso na tag [NFCe_RN_H] retirando o http:// de:
URL-ConsultaNFCe_2.00=www.set.rn.gov.br/nfce/consulta
E recompile o RES e deu certo.

Link to comment
Share on other sites

  • Administradores

Bom dia.

Algum de vocês testou estas alterações em ambiente de produção?

Att.

  • Like 1
Consultora SAC ACBr

Juliana Tamizou
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.  Discord

Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil


Participe de nosso canal no Discord e fique ainda mais próximo da Comunidade !!

Link to comment
Share on other sites

Passei Pelo mesmo problema de Ontem pra Hoje.
Graças ao clebsonmarcal que me deu uma luz com a solução dele.

Correção para quem esta emitindo para o estado do ES

alterar o aquivo: ACBrNFeServicos.ini
Que se encontra dentro da Pasta (ACBr\trunk2\Fontes\ACBrDFe\ACBrNFe)

na linha:

[NFCe_ES_H]
Usar=NFCe_SVRS_H
URL-QRCode=http://homologacao.sefaz.es.gov.br/ConsultaNFCe/qrcode.aspx  (sem http)
URL-ConsultaNFCe=app.sefaz.es.gov.br/ConsultaNFCe   (sem http)
URL-ConsultaNFCe_2.00=www.sefaz.es.gov.br/nfce/consulta  (sem http)

depois executar Compila_RES.BAT
E em seguida recompilar o Projeto.

Edited by Edivaldo Matias - Imtegra
  • Like 2
Link to comment
Share on other sites

27 minutos atrás, Juliana Tamizou disse:

Bom dia.

Algum de vocês testou estas alterações em ambiente de produção?

Att.

Tivemos um problema agora pouco no ambiente de produção de SE. Vimos que o link do qrcode estava diferente.

Link to comment
Share on other sites

  • Este tópico foi criado há 1203 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.