Jump to content

2 Dia do ACBr

Pré-Venda com Desconto de R$100,00
INSCREVA-SE

Nova Loja Oficial
loja.projetoacbr.com.br
Ajude o projeto a crescer, com estilo

Comprar

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

jedusena@hotmail.com

ANSWERED Propriedade ForcarGerarTagRejeicao938 não funcionou

Recommended Posts

Boa tarde.

Mesmo após a atualização do ACBR, que realizei hoje, não consegui o efeito de ter as tags geradas no xml, em caso de CST 60 e valores 0.

Tem mais alguma coisa além de setar a propriedade com o valor fgtSempre ?

Obrigado.

Eduardo Sena

Share this post


Link to post
Share on other sites
Agora, [email protected] disse:

 

Boa tarde, [email protected].

Depois de atualizar você instalou?


Equipe ACBr

Felipe Eduardo Resende Mesquita

Conheça os Novos Planos do SAC do ACBr e seus Benefícios. Saiba mais aqui.

Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

 

 

 

Share this post


Link to post
Share on other sites
37 minutos atrás, Felipe E. Resende Mesquita disse:

Boa tarde, [email protected].

Depois de atualizar você instalou?

Sim! Aparece a propriedade, eu setei para fgtSempre e informei 0 nos valores, mesmo assim, não funcionou.

ACBrNFe1.Configuracoes.Geral.ForcarGerarTagRejeicao938:= fgtSempre;

                      Imposto.ICMS.pRedBCEfet := 0;
                      Imposto.ICMS.vBCEfet    := 0;
                      Imposto.ICMS.pICMSEfet  := 0;
                      Imposto.ICMS.vICMSEfet  := 0;

                      Imposto.ICMS.vBCSTRet   := 0;
                      Imposto.ICMS.vICMSSTRet := 0;
                      Imposto.ICMS.pST        := 0;
                      Imposto.ICMS.vICMSSubstituto := 0;

Dúvida: eu preciso retirar o componente e colocar de novo? Isso eu não fiz... a propriedade já apareceu depois da instalação.

Share this post


Link to post
Share on other sites
Agora, [email protected] disse:

 

Boa tarde, [email protected].

Sugiro que apague a pasta do ACBr, baixe novamente e faça a instalação.


Equipe ACBr

Felipe Eduardo Resende Mesquita

Conheça os Novos Planos do SAC do ACBr e seus Benefícios. Saiba mais aqui.

Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

 

 

 

Share this post


Link to post
Share on other sites
1 hora atrás, [email protected] disse:

Mesmo após a atualização do ACBR, que realizei hoje, não consegui o efeito de ter as tags geradas no xml, em caso de CST 60 e valores 0.

Tem mais alguma coisa além de setar a propriedade com o valor fgtSempre ? 

A configuração só tem efeito quando CST 60 ou CSOSN 500 e não é operação com consumidor final (tag: indFinal = 0).

  • Like 1

Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Share this post


Link to post
Share on other sites
9 minutos atrás, Felipe E. Resende Mesquita disse:

Boa tarde, [email protected].

Sugiro que apague a pasta do ACBr, baixe novamente e faça a instalação.

Ok, fiz e notei o seguinte no meu xml (mesmo preenchendo os valores, só mostra essas tags):


-<ICMS>

-<ICMS60>

<orig>2</orig>

<CST>60</CST>

<vBCSTRet>0.00</vBCSTRet>

<pST>0.0000</pST>

<vICMSSTRet>0.00</vICMSSTRet>

</ICMS60>

</ICMS>

Ontem, antes dessa atualização, preenchendo os campos:

-<ICMS>


-<ICMS60>

<orig>2</orig>

<CST>60</CST>

<vBCSTRet>0.28</vBCSTRet>

<pST>18.0000</pST>

<vICMSSubstituto>0.04</vICMSSubstituto>

<vICMSSTRet>0.01</vICMSSTRet>

<pRedBCEfet>38.8900</pRedBCEfet>

<vBCEfet>61.11</vBCEfet>

<pICMSEfet>0.0000</pICMSEfet>

<vICMSEfet>0.00</vICMSEfet>

</ICMS60>

</ICMS>

 

Share this post


Link to post
Share on other sites

Complementando a msg anterior, não foram montadas todas as tags, conforme a intenção da flag no componente, que foi setado com fgtSempre.

A indFinal = 0 e o CST = 60.

Se entendi bem, a flag só tem validade quando for essa configuração. Se for consumidor final (indFinal=1), não serão montadas as tags.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...