Jump to content

Delphi chamada_delphi.png acbr.png

C6 chamada_c6.png botao.png

Parou de Gerar Preview


Go to solution Solved by Arturo,
  • Este tópico foi criado há 1077 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Membros Pro

Baixei a versão, do ACBrMonitor, 1.2.0.62-20190513

Parou de gerar o preview da NF. Oque pode ser?

 

 

ACBrMonitor.png

1-rec.xml 1-rec-soap.xml 411001786616261-ped-rec.xml 411001786616261-ped-rec-soap.xml 411001786616261-pro-rec.xml 411001786616261-pro-rec-soap.xml 41190611276769000153650010000075621157454825-nfe.xml

Edited by Arturo
Faltou o LOG
Link to comment
Share on other sites

  • Consultores

Boa tarde @Arturo

Não houve alteração quanto a isso... Por favor anexe o log.txt do ACBrMonitor...

Notei pelo seu XML que se trata de NFCe, verifique na aba "NFCe" está emitindo em ESCPOS, neste caso realmente não mostra o Preview, pois a comunicação é diretamente com a impressora.

  • Like 1
Consultor SAC ACBr

José Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

  • Consultores
3 minutos atrás, Arturo disse:

Não consigo encontrar esse arquivo em nenhum lugar do PC. Vide a configuração (acredito que é "default", pois eu não me lembro de ter configurado isso).

Para começar a gerar log é preciso marcar a flag "Log de Comandos".

Mas verifique as configurações da aba NFCe (Citada acima) se estiver imprimindo no modelo: Fortes deve mostrar o Preview...

Consultor SAC ACBr

José Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

  • Membros Pro

OK. Mas não sei porque parou de fazer o preview (isso ocorreu após atualizar a versão do ACBrMonitor - alterei porque a versão que estava instalada não gerava os dados do responsável tecnico). Veja as configurações:

ACBrMonitorx.png

Edited by Arturo
Link to comment
Share on other sites

  • Consultores

@Arturo, no erro do log, não está passando o path do XML para impressão... veja:

04/06/2019 11:18:02 - NFE.ImprimirDanfe()
04/06/2019 11:18:02 - ERRO: Arquivo  nao encontrado.

 

Outro detalhe, na tela que anexou acima "NFCe": informe a impressora padrão para emissão de NFCe,  também pode alterar essa impressora via parâmetro...

Altere também a configuração de Largura, esta configuração está errada. Configure conforme a tela que eu postei acima....

Certifique-se também se está utilizando a versão atualizada do ACBrMonitor 

 

 

Consultor SAC ACBr

José Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

  • Membros Pro
  • Solution

Realmente a configuração não foi alterada. E não tinha sentido após tantas notas emitidas algo deixar de funcionar sem ninguém alterar nada.O que ocorreu é que eu pego os dados da linha 'Arquivo=', do arquivo retorno,  e informo no parâmetro ImprimeNF().

Essa linha por algum motivo passou a ser a última linha do retorno (antes não era) e dentro da rotina de leitura do arquivo TXT sai por EOF, consequentemente não obtendo o caminho para impressão.

É a 2ª vez que tenho problemas com o arquivo retorno. Da outra vez a linha NProt mudou para nProt e meu programa passou a considerar a emissão como erro, pois não encontrava o nº do protocolo. 

O problema do preview está resolvido.

Agradeço vossa atenção.

 

 

 

ACBrMonitorx.png

  • Like 1
Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.