Jump to content

2 Dia do ACBr

Confira o nosso time de palestrantes
Quero conhecer o Evento

Nova Loja Oficial
loja.projetoacbr.com.br
Ajude o projeto a crescer, com estilo

Comprar

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

Júlio Molon

Erro ao enviar provedor INFISC município Farroupilha.

Recommended Posts

Bom dia, estou implementando o envio da NFSe para o município de Farroupilha provedor Infisc ambiente de homologação, e estou enfrentando o seguinte problema ao enviar:
raised exception class EACBrDFeException with message ''.

Como o erro apresentado não foi muito claro estou com duvidas referentes a correta geração do XML e do Envelope Soap...  A principio eles são gerados conforme manual de integração da prefeitura: https://nfse.farroupilha.rs.gov.br/site/wp-content/uploads/2016/12/manualconectividadev1.4.pdf

Creio que o erro esteja ocorrendo devido retorno do web service, pois ao invés de eles me retornarem um XML de confirmação de lote eles me retornam um xml listando os métodos disponíveis no web service, alguém saberia o por que de tal retorno??

Seguem XML's usados no processo em anexo.

Obrigado pela atenção! 

 

10-rec-soap.xml 10_erro.xml 10-env-lot.xml 10-env-lot-soap.xml 10-rec.xml

Share this post


Link to post
Share on other sites

Bom dia Júlio. O erro ocorre no momento de gerar, assinar ou enviar? Já tentou debugar até onde ele chega para poder chegar a uma conclusão do que seja. Infelizmente esse erro pode ser N problemas. Sugiro que debugue a aplicação para chegar mais a fundo do erro.

  • Like 2

Share this post


Link to post
Share on other sites
1 hora atrás, Júlio Molon disse:

Bom dia, estou implementando o envio da NFSe para o município de Farroupilha provedor Infisc ambiente de homologação, e estou enfrentando o seguinte problema ao enviar:
raised exception class EACBrDFeException with message ''.

Como o erro apresentado não foi muito claro estou com duvidas referentes a correta geração do XML e do Envelope Soap...  A principio eles são gerados conforme manual de integração da prefeitura: https://nfse.farroupilha.rs.gov.br/site/wp-content/uploads/2016/12/manualconectividadev1.4.pdf

Creio que o erro esteja ocorrendo devido retorno do web service, pois ao invés de eles me retornarem um XML de confirmação de lote eles me retornam um xml listando os métodos disponíveis no web service, alguém saberia o por que de tal retorno??

Seguem XML's usados no processo em anexo.

Obrigado pela atenção! 

 

10-rec-soap.xml 18 kB · 0 downloads 10_erro.xml 1 kB · 2 downloads 10-env-lot.xml 5 kB · 0 downloads 10-env-lot-soap.xml 6 kB · 1 download 10-rec.xml 18 kB · 0 downloads

Júlio, encontrei este tópico no forum falando sobre o erro em branco,

Vou atualizar meu acbr pra ver se resolve... O estranho é que faz um tempo que eu não atualizo o meu repositório e estava tudo funcionando... de qualquer forma, vou atualizar e ver o que acontece.

  • Like 1

Share this post


Link to post
Share on other sites

é, mesmo atualizando, tive o mesmo retorno em branco

image.png.a507e6b9d8e1adb97217573c088d1c55.png

 

Só para confirmar, a alteração solicitada pelo @Italo Jurisato Junior já veio na atualização

 

image.png.9b713b1563ec1abb86fa5cebf2d26382.png

Edited by ramalho
  • Sad 1

Share this post


Link to post
Share on other sites
57 minutos atrás, Breno Luiz disse:

Bom dia Júlio. O erro ocorre no momento de gerar, assinar ou enviar? Já tentou debugar até onde ele chega para poder chegar a uma conclusão do que seja. Infelizmente esse erro pode ser N problemas. Sugiro que debugue a aplicação para chegar mais a fundo do erro.

Opa Breno, já debuguei sim,  e conforme dito, após realizar o envio do lote o web service me retorna aquele XML contendo os métodos disponíveis no web service e não um xml de confirmação de recebimento.  Após o envio dos dados, na função TratarResposta o Result  sempre será é False pois a Função LerXml_proInfisc espera por um XML de "comfirmaLote", e não um XML contendo uma lista de serviços disponibilizados...

 

21 minutos atrás, ramalho disse:

Bom dia, estou com o mesmo erro para campinas no IssDfe, está retornando este erro em branco tbm..

 algo estranho, são os Xmls com os bodys vazios...

  

1266-env-lot.xml 6 kB · 0 downloads 1266-env-lot-soap.xml 7 kB · 0 downloads 1266-rec.xml 64 B · 0 downloads 1266-rec-soap.xml 64 B · 1 download

Simm, estranho também... no meu caso ao invés de o body estar vazio ele me retorna uma lista com os métodos disponíveis, possivelmente temos o mesmo problema, mas cada webService deve trata-lo de uma maneira diferente...

18 minutos atrás, ramalho disse:

Júlio, encontrei este tópico no forum falando sobre o erro em branco,

Vou atualizar meu acbr pra ver se resolve... O estranho é que faz um tempo que eu não atualizo o meu repositório e estava tudo funcionando... de qualquer forma, vou atualizar e ver o que acontece.

Opa Ramalho, já havia visualizado este tópico anteriormente, mas pensei que não houvesse ligação com o meu problema, pois no tópico ele não fala nada sobre estar recebendo um retorno diferente do esperado do web service... 

 

 

Share this post


Link to post
Share on other sites

Apenas informações Para complementar,

 

a alteração feita dentro do 

image.png.460468130e04a1d7925057e81015ca80.png

não parece fazer efeito no meu caso, já que ele acaba não passando pelo 'TratarResposta' do TNFSeWebService e sim do TNFSeEnviarLoteRPS

Share this post


Link to post
Share on other sites

Boa tarde a todos,

Bom apesar de não ter nenhum comunicado no site oficial da prefeitura de campinas ou no provedor IssDsf.. o erro parece que estava por lá. não fiz nenhuma alteração significativa no sistema e agora de uma hora para outra a nota foi gerada... 

então esta tudo certo por aqui...

Edited by ramalho
  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...