Jump to content

2 Dia do ACBr

O Dia da Automação Comercial está chegando!
Inscreva-se

Nova Loja Oficial
loja.projetoacbr.com.br
Ajude o projeto a crescer, com estilo

Comprar

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

Recommended Posts

Boa Noite,

com a nova versao do OpenSuse Estou tendo problemas com o ACBr Linux. Ele instala configura porem nao funciona, logo na instalação ele reclama de algumas bibliotecas como a Lib SSL e OPen SSl que não são 

compativeis, gostaria de realsar que instalei a ultima versao do acbr linux o qual funciona prefeitamente no opensuse leap 42....

como tive que mudar para o leap 15.1 tive que recompilar tambem minhas aplicacoes no leap 15.1 , pois as .so são outras creio que o mesmo esteja acontecendo com o acbrmonitor, precisa ser recompilado em  leap 15.1 para funcinar corretamente.

só vai perceber o problema quem começar a usar o ACBr em Leap 15.1....

 

desde já  sem mais delongas

Obrigado.

 


Jamil Santos de Araújo

Engenheiro de sistemas /  Tec. Contabil

Email.: [email protected]     Skype.: jamilaraujo

Share this post


Link to post
Share on other sites

Eu uso OpenSuse Leap...

Qual a exata mensagem de erro ?

 

  • Like 2

Consultor SAC ACBr

Daniel Simões de Almeida
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites
15 minutos atrás, Daniel Simoes disse:

Eu uso OpenSuse Leap...

Qual a exata mensagem de erro ?

  

*** Verificando Links Simbólicos ***

libssl.so:libssl.so.1.0 libxmlsec.so:libxmlsec1.so libxmlsec1-openssl.so

Verificando biblioteca libssl.so, procurando por nome: libssl.so.1.0
 Biblioteca libssl.so.1.0 ainda não existe... procurando por Bibliotecas similares
     Erro: Nenhuma biblioteca similar a 'libssl.so.1.0' encontrada
Erro: Nenhuma biblioteca similar a 'libssl.so.1.0' encontrada


*** Configurando Atalhos /opt/ACBrMonitor


*** Configurando Menu Principal ***


Bom dia, @Daniel Simoes

lembrando Leap 15.1.... o ACBr instala, mais não funciona, nada nem NF-e/NFC-e, Boleto etc....

o que funciona corretamente no Leap 42.... espero ter sido claro na minha explicação quanto ao problema ok.

 

desde já parabéns a aquipe pelo exelente trabalho....

 


Jamil Santos de Araújo

Engenheiro de sistemas /  Tec. Contabil

Email.: [email protected]     Skype.: jamilaraujo

Share this post


Link to post
Share on other sites

Bom dia Jamil, no script de instalação deve criar os links simbólicos para as libs utilizadas pelo ACBr caso não existam, verifique se existem os links nesta Leap executando por exemplo o comando:  ls /lib64/libssl* -l

 

  • Like 1

Consultor SAC ACBr

José Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites

Verifique se você tem o OpenSSL 1.0.x (e não apenas o 1.1)

  • Like 1

Consultor SAC ACBr

Daniel Simões de Almeida
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites
35 minutos atrás, Daniel Simoes disse:

Verifique se você tem o OpenSSL 1.0.x (e não apenas o 1.1)

instalei, porém ....

*** Verificando Links Simbólicos ***

libssl.so:libssl.so.1.0 libxmlsec.so:libxmlsec1.so libxmlsec1-openssl.so

Verificando biblioteca libssl.so, procurando por nome: libssl.so.1.0
 Biblioteca libssl.so.1.0 ainda não existe... procurando por Bibliotecas similares
       libssl.so.1.0.0 (libc6,x86-64) => /usr/lib64/libssl.so.1.0.0
   Pegando a primeira ocorrencia de Bibliotecas Similares
     Criando Link simbólico de: /usr/lib64/libssl.so.1.0.0 para: /usr/lib64/libssl.so

Verificando biblioteca libxmlsec.so, procurando por nome: libxmlsec1.so
 Biblioteca libxmlsec1.so ainda não existe... procurando por Bibliotecas similares
       libxmlsec1.so.1 (libc6,x86-64) => /usr/lib64/libxmlsec1.so.1
   Pegando a primeira ocorrencia de Bibliotecas Similares
     Criando Link simbólico de: /usr/lib64/libxmlsec1.so.1 para: /usr/lib64/libxmlsec.so

Verificando biblioteca libxmlsec1-openssl.so, procurando por nome: libxmlsec1-openssl.so
/usr/lib64/libxmlsec1-openssl.so
 Biblioteca libxmlsec1-openssl.so já existe
      

*** Configurando Atalhos /opt/ACBrMonitor


*** Configurando Menu Principal ***


 


Jamil Santos de Araújo

Engenheiro de sistemas /  Tec. Contabil

Email.: [email protected]     Skype.: jamilaraujo

Share this post


Link to post
Share on other sites

Note que agora não apresentou o erro postado anteriormente: (Erro: Nenhuma biblioteca similar a 'libssl.so.1.0' encontrada)...

Ao executar o ACBrMonitor apresenta algum erro? Se possível anexe o log.txt do ACBrMonitor...

  • Confused 1

Consultor SAC ACBr

José Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites

@Daniel Simoes

Em 08/07/2019 at 11:25, José M. S. Junior disse:

Note que agora não apresentou o erro postado anteriormente: (Erro: Nenhuma biblioteca similar a 'libssl.so.1.0' encontrada)...

Ao executar o ACBrMonitor apresenta algum erro? Se possível anexe o log.txt do ACBrMonitor...

Bom dia, fazendo que voce me pede, praticamente toda as minhas aplicações pararam de funcionar.....

aviso: libssl.so.1.1, necessário por /usr/lib64/gcc/x86_64-suse-linux/7/../../../../lib64/libmysqlclient.so, pode conflitar c
om libssl.so.1.0.0

'[email protected]@OPENSSL_1_1_0'
/usr/lib64/gcc/x86_64-suse-linux/7/../../../../x86_64-suse-linux/bin/ld: /usr/lib64/libssl.so.1.1

cansado de procurar solução para o problema, resolvi, Formatar meu Leap 15.1 e colocar do 0....


.........

Lembrando que o OpenSuse Parou de fornecer Atualizações para a versão 42 ...

por esse motivo passei a usar o 15, no qual tive que me readaptar a varias novas libs (.so) , que são diferentes no Leap 15.... 

por esse motivo abri esse tópico.... ao instalar o ( OpenSSL 1.0.x ), criei uma série de problemas para mim que não tinha.

por esse motivo sugeri a equipe compilar o ACBr em Leap15.1 para que essas barreiras fossem superadas.

desculpa se não consigo ser claro e se pareço rude, mais a minha intenção é sempre somar com esse projeto que tanto me AJUDA a CRESCER .

Obrigado.


Jamil Santos de Araújo

Engenheiro de sistemas /  Tec. Contabil

Email.: [email protected]     Skype.: jamilaraujo

Share this post


Link to post
Share on other sites
22 minutos atrás, jamil disse:

por esse motivo abri esse tópico.... ao instalar o ( OpenSSL 1.0.x ), criei uma série de problemas para mim que não tinha.

As duas versões podem conviver pacificamente... basta criar os Link simbólicos de maneira adequada...

Creio ainda, que se você remover a versão 1.1, suas aplicações continuarão funcionando

  • Like 1
  • Sad 1

Consultor SAC ACBr

Daniel Simões de Almeida
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites
2 horas atrás, Daniel Simoes disse:

As duas versões podem conviver pacificamente... basta criar os Link simbólicos de maneira adequada...

Creio ainda, que se você remover a versão 1.1, suas aplicações continuarão funcionando

tentei fazer e não deu certo...

com isso parei de usar o ACRr versão  linux..... no Leap 15.1 até que minha aplicações com o ACBr linux no Leap 15 estejam alinhadas...

sugiro que seja encerrado este topico tendo em vista que não chegaremos em lugar nenhum....

desde já mais uma vez.... parabéns a equipe e obrigado


Jamil Santos de Araújo

Engenheiro de sistemas /  Tec. Contabil

Email.: [email protected]     Skype.: jamilaraujo

Share this post


Link to post
Share on other sites

Boa tarde Jamil,

O problema não está em compilar o aplicativo ACBrMonitor em outra versão do Linux e sim na versão da lib que o ACBrMonitor precisa para poder funcionar...

Note na mensagem que está recebendo: "aviso: libssl.so.1.1, necessário por /usr/lib64/gcc/x86_64-suse-linux/7/../../../../lib64/libmysqlclient.so, pode conflitar c
om libssl.so.1.0.0"

O ACBrMonitor precisa da libssl.so.1.0.0 e precisa criar um link simbólico com o nome: "libssl.so" para que possa funcionar. Pode ser que esteja direcionando para a lib versão 1.1, o que causaria erro... Esse conflito precisa ser ajustado, o ideal é excluir os links simbólicos e depois deixar apenas a versão: libssl.so.1.0.0 e reinstalar o ACBrMonitor.rpm.

 

Se preferir crie o link de forma manual depois de deixar apenas a versão libssl.so.1.0.0 nessa versão do seu OpenSuse...

cd /lib64/
ln -s libssl.so.1.0.0 libssl.so

 

  • Like 3

Consultor SAC ACBr

José Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites
5 horas atrás, José M. S. Junior disse:

Boa tarde Jamil,

O problema não está em compilar o aplicativo ACBrMonitor em outra versão do Linux e sim na versão da lib que o ACBrMonitor precisa para poder funcionar...

Note na mensagem que está recebendo: "aviso: libssl.so.1.1, necessário por /usr/lib64/gcc/x86_64-suse-linux/7/../../../../lib64/libmysqlclient.so, pode conflitar c
om libssl.so.1.0.0"

O ACBrMonitor precisa da libssl.so.1.0.0 e precisa criar um link simbólico com o nome: "libssl.so" para que possa funcionar. Pode ser que esteja direcionando para a lib versão 1.1, o que causaria erro... Esse conflito precisa ser ajustado, o ideal é excluir os links simbólicos e depois deixar apenas a versão: libssl.so.1.0.0 e reinstalar o ACBrMonitor.rpm.

 

Se preferir crie o link de forma manual depois de deixar apenas a versão libssl.so.1.0.0 nessa versão do seu OpenSuse...

cd /lib64/
ln -s libssl.so.1.0.0 libssl.so

 

Vou montar um novo servidor com o  Leap 15.1 e criar o mesmo ambiente com os mesmos problemas e fazer o que voce esta me orientando, e ver se irá dar tudo certo.... e retorno aqui no forum como fiz outras vezes com o resultado.....

por enquanto mais uma vez obrigado.

  • Like 1

Jamil Santos de Araújo

Engenheiro de sistemas /  Tec. Contabil

Email.: [email protected]     Skype.: jamilaraujo

Share this post


Link to post
Share on other sites
Em 11/07/2019 at 15:59, José M. S. Junior disse:

Boa tarde Jamil,

O problema não está em compilar o aplicativo ACBrMonitor em outra versão do Linux e sim na versão da lib que o ACBrMonitor precisa para poder funcionar...

Note na mensagem que está recebendo: "aviso: libssl.so.1.1, necessário por /usr/lib64/gcc/x86_64-suse-linux/7/../../../../lib64/libmysqlclient.so, pode conflitar c
om libssl.so.1.0.0"

O ACBrMonitor precisa da libssl.so.1.0.0 e precisa criar um link simbólico com o nome: "libssl.so" para que possa funcionar. Pode ser que esteja direcionando para a lib versão 1.1, o que causaria erro... Esse conflito precisa ser ajustado, o ideal é excluir os links simbólicos e depois deixar apenas a versão: libssl.so.1.0.0 e reinstalar o ACBrMonitor.rpm.

 

Se preferir crie o link de forma manual depois de deixar apenas a versão libssl.so.1.0.0 nessa versão do seu OpenSuse...

cd /lib64/
ln -s libssl.so.1.0.0 libssl.so

 

Bom Dia @José M. S. Junior

antes de mais nada, tenho acompanhado outros posts da equipe que tem me ajudado muito no acerto/desenvolvimento da NF-e / NFC-e / MDF-e e principalmente esse mes no Boleto do Santander.....

parabéns a equipe ....

Bom voltado ao assunto em questão no tópico fiz varios teste inclusive seguindo a orientação da equipe, porem no Leap 15.1 é nativo de todas a aplicações dependentes da libssl ... (necessário a libssl.so.1.1 ) não somente a libmysql .....

quando atribuo a    ln -s libssl.so.1.0.0 libssl.so.... , para o ACBrMonitor.... as outras aplicações do Leap15.1 que param de funcionar (necessário a libssl.so.1.1 ). mesmo ....

voltado ao default, ou seja, ln -s libssl.so.1.1 libssl.so....tudo funciona mais o ACBrMonitor apenas Imprime o que já está pronto não faz mais nada......

o meio termo seria se o ACBrMonitor utilizar a libssl.so.1.1.....

gostaria de usar ACBrMonitor no Leap 15.1, ja que essa é a evolução natural da SuSe,

recorrir a forum para ver se algem esta com o mesmo problema, e se juntos podemos chegar a uma solução 

a todo  informo que na versão anterior do OpenSuSe o ACBtMonitor funciona perfeitamente bem.

Obrigado desde já pela Ajuda.


Jamil Santos de Araújo

Engenheiro de sistemas /  Tec. Contabil

Email.: [email protected]     Skype.: jamilaraujo

Share this post


Link to post
Share on other sites

o ACBr não é compatível com o OpenSSL 1.1.X... é necessário usar o OpenSSL 1.0.x

Nesse vídeo e Documento PDF, é mostrado como montar um ambiente Linux com OpenSuse

 

  • Like 3

Consultor SAC ACBr

Daniel Simões de Almeida
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...