Jump to content

2 Dia do ACBr

Visite Stands dos Patrocinadores
Control iD, CS Devices, Elgin, Gertec, Bematech, Jetway, PlugMobile, Epson, Custom e Sweda
Inscreva-se

Nova Loja Oficial
loja.projetoacbr.com.br
Ajude o projeto a crescer, com estilo

Comprar

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

Recommended Posts

Olá pessoal!

Estou com um problema no Delphi 2010 e XE 10. Um problema inusitado.

Fiz a instalação de ambos no mesmo PC e tudo está funcionando perfeitamente já a uns 15 dias.

Agora, abri o Delphi e carreguei meu projeto e ao clicar em qualquer componente, ele se desloca. Se eu clicar no Label ou Edit ou qualquer outro componente, ele se desloca para qualquer lado.

Exemplifiquei no Label e Edit mas, isso acontece com qualquer componente que eu clico em cima dele. Clique simples pra selecionar o componente.

Não tem um padrão de deslocamento. Ele pode se deslocar para cima, para baixo, direita ou esquerda. Cada componente vai pra um lado.

Existe alguma configuração no Delphi que impeça esse tipo de deslocamento?

Obrigado,

Rogério.

Share this post


Link to post
Share on other sites
23 minutos atrás, Rogério Braga disse:

Existe alguma configuração no Delphi que impeça esse tipo de deslocamento?

Tente modificar as configurações do Form Designer.

Pela sua descrição parece algo que a opção "Snap to grid" faria.

image.png

  • Like 1

Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Share this post


Link to post
Share on other sites

 

Não resolveu, infelizmente.

Muito estranho isso! É só clicar no componente e dá um salto. Coisa estranha!!!

Se eu clicar no componente pressionando a tecla Shift, esse salto não ocorre, porém, nenhum outro comando funciona. Por exemplo, se eu selecionar com Shift + Clique, não funcionar o Ctrl+C, por exemplo.

Share this post


Link to post
Share on other sites

Verifique se não tem alguma extensão com problemas instalada. Por exemplo, talvez uma versão do CNPack, GExperts, etc...


[]'s

Consultor SAC ACBr

Elton
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Um engenheiro de Controle de Qualidade(QA) entra num bar. Pede uma cerveja. Pede zero cervejas.
Pede 99999999 cervejas. Pede -1 cervejas. Pede um jacaré. Pede asdfdhklçkh.

Share this post


Link to post
Share on other sites
Em 10/07/2019 at 10:21, BigWings disse:

Tente modificar as configurações do Form Designer.

Pela sua descrição parece algo que a opção "Snap to grid" faria.

image.png

Boa tarde!

Muito obrigado a todos pela ajuda.

BigWings, sua ajuda bateu na trave, mas sem ela, eu não teria conseguido.

Eu desmarquei a opção "Use designer guidelines" e os componentes pararam de se movimentar ao clicar.

Obrigado,

Rogério.

  • Like 2

Share this post


Link to post
Share on other sites

Obrigado por reportar.

Fechando. Para novas dúvidas, criar um novo tópico.

  • Like 1

Consultora SAC ACBr

Juliana Tamizou
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...