Jump to content

Compre o Delphi
Com até 30% de desconto
e parcelado em até 12x sem juros

Saiba Mais

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

Recommended Posts

Olá bom dia estou fazendo testes da gnre 2.00 para SC e alguns campos foram validados por exemplo o mês esta indo 1 digito precisa ser 2, não esta indo a data de pagamento e se preencher o valor_principal como o pgnreGNREW busca somente o valor_total assim gerando processamento com pendencias ao emitir a gnre em homologação.  Obrigado

Share this post


Link to post
Share on other sites

Bom dia Daniel,

Você tem o manual da versão 2 que mostra como tem que ser gerado as tags dessa versão?

Se sim, favor anexar para que possamos fazer os devidos ajustes.

  • Like 1

Consultor SAC ACBr Italo Jurisato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Share this post


Link to post
Share on other sites

Olá boa tarde precisei fazer 2 mudanças para emitir a gnre na unit pgnreGNRE.pas coloquei  Fc04_docOrigem := '0';

e na unit pgnreGNREW.pas 

  if GNRE.c06_valorPrincipal > 0 then
    Gerador.wCampo(tcDe2, '', 'valorGNRE        ', 01, 15, 1, GNRE.c06_valorPrincipal, '');

  if GNRE.c10_valorTotal > 0 then
    Gerador.wCampo(tcDe2, '', 'valorGNRE        ', 01, 15, 1, GNRE.c10_valorTotal, '');

Pois como estava informando o valor no campo do valor principal no xml o valor da gnre ficava 0. 

Mandei as units alteradas.

testado com as alterações deu certo a emissão. 

 

Obrigado.
 

pgnreGNRE.pas pgnreGNREW.pas

Share this post


Link to post
Share on other sites

Boa tarde Daniel,

Se possível anexar os XMLs de envio e de retorno para que possamos fazer as devidas alterações na rotina que faz a leitura do retorno.

Desde já muito obrigado pela colaboração.

Vou analisar as suas alterações e assim que possível vou enviar para o repositório.


Consultor SAC ACBr Italo Jurisato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Share this post


Link to post
Share on other sites

Italo bom dia fiz os testes aqui deu certo tanto o envio como o retorno porem fazendo uma outra usando uma receita que exige periodo de referencia ao informar que é mensal o valor do campo é 0 no xml não gera a tag dando a mensagem de processado com pendencias. Estou anexando o xml de envio e de retorno. Obrigado

1900635606-pro-rec.xml 4025-gnre.xml

Share this post


Link to post
Share on other sites

Italo boa tarde fazendo vários teste em algumas vezes deu um erro e a mensagem fica em branco e da um erro de valor numérico invalido quando o sistema aqui tenta gravar no banco o id_guia que vem do retorno. Isso acontece as vezes, e quando envia a 2 ou 3 vezes dai não da erro e o sistema consegue gravar o id da guia. Será que o retorno da receita demora algum tempo pra retornar o xml ?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...