Jump to content

Promoção de Natal SAC Mensal

Contrate e ganhe 1 Kit agenda + Caneta
Saiba mais

LANÇAMENTO
Curso Completo - Dominando o ACBrMonitor

Conheça o Curso

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

ROSENILDO

Rejeição - Falha no schema XML do CTe

Recommended Posts

6 minutos atrás, ROSENILDO disse:

Suspeito que tenha algo haver com a Tag de ICMS de partilha, pois o TOMADOR do serviço é NÃO CONTRIBUINTE, e é obrigado a enviar essa TAG.

Segue em anexo XML. Componente está atualizado,  e Schemas também!

Veja o tópico abaixo, parece o mesmo caso:

 

  • Like 1

Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Share this post


Link to post
Share on other sites

Também estou com esse problema, ja acertei a tag de partilha, está zerado, esse problema está ocorrendo com um cliente em MG, está passando o Qrcode tmb.,aqui tmb fiz a troca do schema de homologação e o outro processo  e ainda continua o erro de falha nos schema

7763-env-lot.xml

2 horas atrás, ROSENILDO disse:

Boa tarde. 

Tento enviar CT-e e apresenta essa mensagem. 

Suspeito que tenha algo haver com a Tag de ICMS de partilha, pois o TOMADOR do serviço é NÃO CONTRIBUINTE, e é obrigado a enviar essa TAG.

Segue em anexo XML. Componente está atualizado,  e Schemas também!

29190823259028000224570010000001881314852035-cte.xml 6 kB · 3 downloads

No seu xml, só remover a tag de icms de partilha que é pra resolver

 

  • Like 2

Share this post


Link to post
Share on other sites
Em 26/08/2019 at 19:47, luisclaudio_jr disse:

Também estou com esse problema, ja acertei a tag de partilha, está zerado, esse problema está ocorrendo com um cliente em MG, está passando o Qrcode tmb.,aqui tmb fiz a troca do schema de homologação e o outro processo  e ainda continua o erro de falha nos schema

7763-env-lot.xml 7 kB · 5 downloads

No seu xml, só remover a tag de icms de partilha que é pra resolver

 

Bom dia. 

Mas amigo, se eu remover aparece a rejeição obrigando a ser informada pois o tomador de serviço é não contribuinte!

Alguma outra ideia?

Share this post


Link to post
Share on other sites
28 minutos atrás, ROSENILDO disse:

Bom dia. 

Mas amigo, se eu remover aparece a rejeição obrigando a ser informada pois o tomador de serviço é não contribuinte!

Alguma outra ideia?

Fiz o teste retirando pICMSInterPart só que quando não preencho esse campo o ACBR retira do XML a TAG -   <ICMSUFFim> toda! E ai caiu em uma outra rejeição que é justamente a da obrigatoriedade da informação desta tag para Não contribuintes!

Ajuda por favor! :)

Share this post


Link to post
Share on other sites
7 minutos atrás, ROSENILDO disse:

Fiz o teste retirando pICMSInterPart só que quando não preencho esse campo o ACBR retira do XML a TAG -   <ICMSUFFim> toda! E ai caiu em uma outra rejeição que é justamente a da obrigatoriedade da informação desta tag para Não contribuintes!

Ajuda por favor! :)

Isso já foi corrigido. Está com os fontes atualizados?

  • Like 1

Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Share this post


Link to post
Share on other sites

Boa noite estou com mesmo erro...não estou conseguindo emtir CT-e para Não Contribuinte.......Emitente do Simples Nacional, estou colocar 

Assim  Imp.ICMS.SituTrib := cstICMSSN;
            Imp.ICMS.ICMSSN.indSN := 1;

e estou recendo essa rejeição em Obrigando colocar os valores da Partilha do ICMS...

 

Conhecimento(s) não confirmados:
1182->786-Rejeição: Grupo de informações da partilha com a UF de fim da prestação deve estar preenchido

Share this post


Link to post
Share on other sites
6 hours ago, Italo Jurisato Junior said:

Boa noite Claudio,

Favor anexar o XML do CT-e.

 

6 hours ago, Italo Jurisato Junior said:

Boa noite Claudio,

Favor anexar o XML do CT-e.

Boa noite. Resolvido zerando a tag PICMSInterPart e atualizando os schemas. Obrigado. 

Share this post


Link to post
Share on other sites

Bom dia Rosenildo,

O seu XML não contem o grupo infCTeSupl que contem a tag qrCodCTe com a string do qr-Code.

E no grupo ICMSUFFim ainda esta sendo gerado a tag pICMSInterPart com o valor 100.

Essa tag não deve mais ser gerada, portanto faça os cálculos como se ela tivesse o valor 100, mas atribua o valor zero a ela.


Consultor SAC ACBr Italo Jurisato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Share this post


Link to post
Share on other sites
22 minutos atrás, Italo Jurisato Junior disse:

Bom dia Rosenildo,

O seu XML não contem o grupo infCTeSupl que contem a tag qrCodCTe com a string do qr-Code.

E no grupo ICMSUFFim ainda esta sendo gerado a tag pICMSInterPart com o valor 100.

Essa tag não deve mais ser gerada, portanto faça os cálculos como se ela tivesse o valor 100, mas atribua o valor zero a ela.

Caro Ítalo vou pedir mais uns minutos da sua atenção.

Em anexo segue dois XMLs, o PRIMEIRO é com a pICMSInterPart com o valor 100. Isso faz apresentar o erro de Schemas Inválido.

O segundo é com o pICMSInterPart com valor 0, que ocasiona o rejeição 786 - Grupo de informações de partilha deve ser informado...

Vou buscar na documentação como implementar a TAG qrCodCTe nos meus XMLs

Aguardo, desde já agradeço!

Segundo.xml Primeiro.xml

Share this post


Link to post
Share on other sites
7 minutos atrás, ROSENILDO disse:

Caro Ítalo vou pedir mais uns minutos da sua atenção.

Em anexo segue dois XMLs, o PRIMEIRO é com a pICMSInterPart com o valor 100. Isso faz apresentar o erro de Schemas Inválido.

O segundo é com o pICMSInterPart com valor 0, que ocasiona o rejeição 786 - Grupo de informações de partilha deve ser informado...

Vou buscar na documentação como implementar a TAG qrCodCTe nos meus XMLs

Aguardo, desde já agradeço!

Segundo.xml 6 kB · 1 download Primeiro.xml 6 kB · 0 downloads

pICMSInterPart, remove isso, não pode ir a TAG no xml, as outras precisam ir.

Implementar qrcode: ACBrCTe1.configuracoes.Geral.GerarInfCTeSupl := fgtSempre;

Share this post


Link to post
Share on other sites
20 minutos atrás, luisclaudio_jr disse:

pICMSInterPart, remove isso, não pode ir a TAG no xml, as outras precisam ir.

Implementar qrcode: ACBrCTe1.configuracoes.Geral.GerarInfCTeSupl := fgtSempre;

Luis atualizei os fontes do ACBR, coloquei a Geração do QR Code, removi a pICMSInterPart, ela não está mais aparecendo no XML, porém aparece um erro agora na estrutura.

Em anexo segue novo XML e o Print do Errro.

Imagem.png

29190923259028000224570010000002321445763560-cte.xml

Share this post


Link to post
Share on other sites

Rosenildo,

Os campos: vBCUFFim, pFCPUFFim, pICMSUFFim, pICMSInter, vFCPUFFim, vICMSUFFim, vICMSUFIni devem ser calculados supondo que o valor de vICMSInterPart seja 100.

Mas devemos atribuir o valor zero a vICMSInterPart para que essa tag não seja gerada no XML.

Favor atualizar todos os fontes de todas as pastas, reinstale a suíte ACBr e recompile a sua aplicação.

Por fim faça novos testes.


Consultor SAC ACBr Italo Jurisato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Share this post


Link to post
Share on other sites
1 minuto atrás, ROSENILDO disse:

Luis atualizei os fontes do ACBR, coloquei a Geração do QR Code, removi a pICMSInterPart, ela não está mais aparecendo no XML, porém aparece um erro agora na estrutura.

Em anexo segue novo XML e o Print do Errro.

Imagem.png

29190923259028000224570010000002321445763560-cte.xml 6 kB · 1 download

Atualiza os Schemas... Usa os da acbr atualizados

Share this post


Link to post
Share on other sites

Rosenildo,

A sua aplicação esta usando um Schema antigo que contem a tag pICMSInterPart.

Favor utilizar os Schemas da pasta: ...\Exemplos\ACBrDFe\Schemas\CTe

  • Like 1

Consultor SAC ACBr Italo Jurisato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Share this post


Link to post
Share on other sites
1 minuto atrás, Italo Jurisato Junior disse:

Rosenildo,

A sua aplicação esta usando um Schema antigo que contem a tag pICMSInterPart.

Favor utilizar os Schemas da pasta: ...\Exemplos\ACBrDFe\Schemas\CTe

RESOLVIDO MEU AMIGO!

Só para ficar claro para quem passar por esse problema, foi uma série de acertos que foi feito!

Atualização do ACBr, Atualização de Schemas, inclusão da TAG  infCTeSupl

Obrigado a todos pela ajuda fundamental que me prestaram!

Abraço a todos, Deus abençoe!

  • Like 3

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...