Jump to content

Embarcadero Conference 2019

22/10 - Visite o Stand do ACBr
Saiba mais

Nova Loja Oficial
loja.projetoacbr.com.br
Ajude o projeto a crescer, com estilo

Comprar

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

JJA

Delphi Seattle. Compila mas não roda.

Recommended Posts

Bom dia pessoal.

Estou migrando de versão do Delphi, atualmente trabalho com a versão 2010 e estou iniciando agora do Delphi Seattle.
Meu primeiro teste foi o tão famoso "Hello world" clicando em um botão, porém ao rodar, o programa simplesmente não sobe.
Ele compila normalmente, cria o executável na pasta Debug, tentei também na Release. 

Não dá erro, não dá mensagem alguma, ele simplesmente ao tentar rodar tanto pelo Delphi quanto direto pelo executável é como se eu não tivesse executando. Não pisca tela, não faz nada.

O que pode ser?

Muito obrigado.

Share this post


Link to post
Share on other sites
Agora, JJA disse:

Bom dia pessoal.

Estou migrando de versão do Delphi, atualmente trabalho com a versão 2010 e estou iniciando agora do Delphi Seattle.
Meu primeiro teste foi o tão famoso "Hello world" clicando em um botão, porém ao rodar, o programa simplesmente não sobe.
Ele compila normalmente, cria o executável na pasta Debug, tentei também na Release. 

Não dá erro, não dá mensagem alguma, ele simplesmente ao tentar rodar tanto pelo Delphi quanto direto pelo executável é como se eu não tivesse executando. Não pisca tela, não faz nada.

O que pode ser?

Muito obrigado.

executar como administrador?


Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP

Share this post


Link to post
Share on other sites

Acabei de descobrir.
Eu estava gerando o executável em 32bits, adicionei a opção de 64bits em Target Plataform e o executável roda normalmente.
Agora a dúvida: Sendo meu Windows 64bits, não deveria rodar aplicações 32 bits? Ou pelo menos a aplicação me retornar um erro?

Share this post


Link to post
Share on other sites
3 minutos atrás, JJA disse:

Acabei de descobrir.
Eu estava gerando o executável em 32bits, adicionei a opção de 64bits em Target Plataform e o executável roda normalmente.
Agora a dúvida: Sendo meu Windows 64bits, não deveria rodar aplicações 32 bits? Ou pelo menos a aplicação me retornar um erro?

sim e não é isso seu problema mas outra coisa. sua instalação foi bem sucedida?

caso continue sugiro entrar em contato com a embarcadero pra lhe auxiliar e refazer a instalação

  • Like 1

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP

Share this post


Link to post
Share on other sites
1 hora atrás, Juliomar Marchetti disse:

sim e não é isso seu problema mas outra coisa. sua instalação foi bem sucedida?

caso continue sugiro entrar em contato com a embarcadero pra lhe auxiliar e refazer a instalação

Bom dia Juliomar,
acredito que a instalação tenha sido concluída com sucesso. Não me lembro de qualquer problema durante ela.
Mas porque simplesmente alternando para compilar em 64 bits funcionou? Porque isso seria um problema na instalação? Como se tivesse faltando algo na instalação que prejudicou compilações em 32 bits?

Share this post


Link to post
Share on other sites

Será que não poderia ser algum problema de antivírus? Talvez detectando que seu aplicativo em 32 bits seja um malware e bloqueando a execução?


[]'s

Consultor SAC ACBr

Elton
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Um engenheiro de Controle de Qualidade(QA) entra num bar. Pede uma cerveja. Pede zero cervejas.
Pede 99999999 cervejas. Pede -1 cervejas. Pede um jacaré. Pede asdfdhklçkh.

Share this post


Link to post
Share on other sites
1 hora atrás, JJA disse:

Bom dia Juliomar,
acredito que a instalação tenha sido concluída com sucesso. Não me lembro de qualquer problema durante ela.
Mas porque simplesmente alternando para compilar em 64 bits funcionou? Porque isso seria um problema na instalação? Como se tivesse faltando algo na instalação que prejudicou compilações em 32 bits?

Não Elton. é erro de instalação. tu tem mais alguma versão do delphi junto ?  vou fazer a pergunta só para desencargo mas são versões registradas correto?

15 minutos atrás, EMBarbosa disse:

Será que não poderia ser algum problema de antivírus? Talvez detectando que seu aplicativo em 32 bits seja um malware e bloqueando a execução?

 


Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP

Share this post


Link to post
Share on other sites
33 minutos atrás, Juliomar Marchetti disse:

Não Elton. é erro de instalação. tu tem mais alguma versão do delphi junto ?  vou fazer a pergunta só para desencargo mas são versões registradas correto?

 

Tenho 2 versões do Delphi instalados. Delphi 7 e Seattle.

Edited by JJA

Share this post


Link to post
Share on other sites

Boa tarde,

Seu problema foi resolvido?

Att.

  • Like 1

Consultora SAC ACBr

Juliana Tamizou
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

Share this post


Link to post
Share on other sites
17 horas atrás, Juliana Tamizou disse:

Boa tarde,

Seu problema foi resolvido?

Att.

Bom dia Juliana,

por algum motivo ainda não entendido, resolveu sim. O problema que ocorreu no início do tópico não acontece mais. Estou conseguindo gerar aplicativos tanto em 32bits quanto em 64bits, porém não foi feito absolutamente nada.

Obrigado pela ajuda.

  • Like 1

Share this post


Link to post
Share on other sites

Obrigado por reportar.

Fechando. Para novas dúvidas, criar um novo tópico.

  • Like 1

Consultora SAC ACBr

Juliana Tamizou
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...