Jump to content

Promoção de Natal SAC Mensal

Contrate e ganhe 1 Kit agenda + Caneta
Saiba mais

LANÇAMENTO
Curso Completo - Dominando o ACBrMonitor

Conheça o Curso

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

jamil

ACBrLibNFe falha de segmentação (imagem do núcleo gravada)

Recommended Posts

Vários usuários já estão usando a ACBrLibNFe em produção... então não creio que o problema seja nela...

Fiquei confuso, estamos falando de Linux ou Windows? 32 ou 64 bits ???

Você pode ver alguns Demos em Harbour, nessa pasta:

http://svn.code.sf.net/p/acbr/code/trunk2/Projetos/ACBrLib/Demos/Harbour/


Consultor SAC ACBr

Daniel Simões de Almeida
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites

O erro é característico de linguagem C (o xHarbour usa o compilador C, para gerar o binário, correto?)

https://pt.wikipedia.org/wiki/Falha_de_segmentação

Isso me leva a crer que o problema seja na maneira que você está instanciando a Lib ou como passa os parâmetros para ela... Creio que estudando as declarações e chamadas dos métodos do exemplo que disponibilizamos, você consiga isolar o problema...

  • Like 1

Consultor SAC ACBr

Daniel Simões de Almeida
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites
28 minutos atrás, Daniel Simoes disse:

Vários usuários já estão usando a ACBrLibNFe em produção... então não creio que o problema seja nela...

Fiquei confuso, estamos falando de Linux ou Windows? 32 ou 64 bits ???

Você pode ver alguns Demos em Harbour, nessa pasta:

http://svn.code.sf.net/p/acbr/code/trunk2/Projetos/ACBrLib/Demos/Harbour/

Linux 64

OpenSuse Leap 15.1

me desculpa na ansiedade de resolver logo o problema, entendi que queria que eu verificasse as dependencias DLL que estão na pasta 

2 minutos atrás, Daniel Simoes disse:

O erro é característico de linguagem C (o xHarbour usa o compilador C, para gerar o binário, correto?)

https://pt.wikipedia.org/wiki/Falha_de_segmentação

Isso me leva a crer que o problema seja na maneira que você está instanciando a Lib ou como passa os parâmetros para ela... Creio que estudando as declarações e chamadas dos métodos do exemplo que disponibilizamos, você consiga isolar o problema...

utilizei os exemplos do demo .... 


Jamil Santos de Araújo

Engenheiro de sistemas /  Tec. Contabil

Email.: [email protected]     Skype.: jamilaraujo

Share this post


Link to post
Share on other sites

@jamil, conversando com o @Rafael Dias, ele comentou comigo, que as declarações da Lib, no Demo em Harbour, foram projetadas apenas para Windows, usando STDCALL...

Então creio que você conseguirá funcionar no Windows, desde que use a versão StdCall da ACBrLibNFe... Veja os tópicos abaixo:

https://www.projetoacbr.com.br/forum/search/?&q=harbour&search_and_or=or&sortby=relevancy

 

  • Like 1

Consultor SAC ACBr

Daniel Simões de Almeida
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites
2 horas atrás, Daniel Simoes disse:

@jamil, conversando com o @Rafael Dias, ele comentou comigo, que as declarações da Lib, no Demo em Harbour, foram projetadas apenas para Windows, usando STDCALL...

Então creio que você conseguirá funcionar no Windows, desde que use a versão StdCall da ACBrLibNFe... Veja os tópicos abaixo:

https://www.projetoacbr.com.br/forum/search/?&q=harbour&search_and_or=or&sortby=relevancy

 

realmente, isso me escapou, peço desculpas, vou reescrever o código usando CDECL  para linux e testar, já que não uso windows  e retorno com o resultado....

mais uma vez obrigado a Equipe ACBr pelo Apoio.

  • Like 2

Jamil Santos de Araújo

Engenheiro de sistemas /  Tec. Contabil

Email.: [email protected]     Skype.: jamilaraujo

Share this post


Link to post
Share on other sites

Bom Dia,

Fiz as mudanças no meu código para CDECL que não funcionava e agora está funcionando bem, emitindo os boletos SHOW... (com alguns probleminhas fáceis de resolver que é assunto para outro tópico),

agradeço a todos pela ajuda,

porém a LibNFE continua apresentando a seguinte mensagem Gtk-WARNING **; canot open display: ..... e para de funcionar.... quando tento simplesmente usar NFE_ StatusServico()

NFE_ Nome() me retorna o nome , NFE_Versao() me retorna a verão corretamente

  • Like 1
  • Thanks 1

Jamil Santos de Araújo

Engenheiro de sistemas /  Tec. Contabil

Email.: [email protected]     Skype.: jamilaraujo

Share this post


Link to post
Share on other sites

Que bacana... parabéns pela persistência...

30 minutos atrás, jamil disse:

porém a LibNFE continua apresentando a seguinte mensagem Gtk-WARNING **; canot open display: ..... e para de funcionar.... quando tento simplesmente usar NFE_ StatusServico()

Acho que se você rodar com o xvfb deve funcionar....

xvfb-run SeuPrograma

  • Like 1

Consultor SAC ACBr

Daniel Simões de Almeida
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites
10 horas atrás, Daniel Simoes disse:

Que bacana... parabéns pela persistência...

Acho que se você rodar com o xvfb deve funcionar....

xvfb-run SeuPrograma

Boa Noite,

usando xvfb-run ... o resultado sai conforme (xvfb-run.pdf), na impressora, pdf e html..... (imagino que com a NF-e/NFC-e será a mesma coisa)

se não usar xvfb-run consigo fazer uns 2 (dois) boletos conforme em anexo (root_bol3110224802.pdf), na impressora, pdf e html mais depois, apresentanda a seguinte mensagem Gtk-WARNING **; ai para de funcionar.

já entendi que em windows está funcionado, como só uso linux, acho que terei que continuar com o meu Bom e Funcional Monitor, 

agradeço o empenho na tentativa de resolver a questão.

 

xvfb-run.pdf root_bol3110224802.pdf


Jamil Santos de Araújo

Engenheiro de sistemas /  Tec. Contabil

Email.: [email protected]     Skype.: jamilaraujo

Share this post


Link to post
Share on other sites

Acho que solução definitiva, seria modificar a forma como você compila o seu Binário, para que o mesmo tenha dependências de GUI (Servidor X)

Há muito tempo não uso xHarbour... então não consigo avançar nessa questão... mas talvez alguém da comunidade do PCToledo, possa ajudar...

http://www.pctoledo.com.br/forum/


Consultor SAC ACBr

Daniel Simões de Almeida
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites
Em 01/11/2019 at 13:37, Daniel Simoes disse:

Acho que solução definitiva, seria modificar a forma como você compila o seu Binário, para que o mesmo tenha dependências de GUI (Servidor X)

Há muito tempo não uso xHarbour... então não consigo avançar nessa questão... mas talvez alguém da comunidade do PCToledo, possa ajudar...

http://www.pctoledo.com.br/forum/

Bom Dia,

Desculpa pela demora em responder, estava testando o boleto usando o GUI em QT

, já estou usando o GUI, já consigo e estou usar a LIB boleto em produção , porém a LIB nfe continua apresentando o mesmo problema.

 


Jamil Santos de Araújo

Engenheiro de sistemas /  Tec. Contabil

Email.: [email protected]     Skype.: jamilaraujo

Share this post


Link to post
Share on other sites
Em 15/11/2019 at 11:32, jamil disse:

Bom Dia,

Desculpa pela demora em responder, estava testando o boleto usando o GUI em QT

, já estou usando o GUI, já consigo e estou usar a LIB boleto em produção , porém a LIB nfe continua apresentando o mesmo problema.

 

gostaria de corrigir minha resposta anterior... consigo imprimir /gerar 1 ou 2 boletos, consigo até fazer remessa.... em seguida

falha de segmentação (imagem do núcleo gravada)

pensei que com o uso do GUI/QT(Servidor X)  esse problema fosse desaparecer....

a equipe ainda pode me ajudar?


Jamil Santos de Araújo

Engenheiro de sistemas /  Tec. Contabil

Email.: [email protected]     Skype.: jamilaraujo

Share this post


Link to post
Share on other sites

Precisamos de mais informações... como um passo a passo mais exato, de como reproduzir o problema...

  • Thanks 1

Consultor SAC ACBr

Daniel Simões de Almeida
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites
4 minutos atrás, Daniel Simoes disse:

Precisamos de mais informações... como um passo a passo mais exato, de como reproduzir o problema...

@Daniel Simoes

Obrigado pela atenção,

mais me diga exatamente o que precisa que lhe envio....

 


Jamil Santos de Araújo

Engenheiro de sistemas /  Tec. Contabil

Email.: [email protected]     Skype.: jamilaraujo

Share this post


Link to post
Share on other sites

Como disse antes... um passo a passo... Exemplo:

1 - Inicialize a Lib com o arquivo em anexo
2 - Chame o método XXX com os parâmetros A,B,C
3 - Chame o método YYY...
4 - Observe o erro...


Consultor SAC ACBr

Daniel Simões de Almeida
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites
Em 18/11/2019 at 08:42, Daniel Simoes disse:

Como disse antes... um passo a passo... Exemplo:

1 - Inicialize a Lib com o arquivo em anexo
2 - Chame o método XXX com os parâmetros A,B,C
3 - Chame o método YYY...
4 - Observe o erro...

Boa Tarde,

Espero está fazendo corretamente: vou relatar as etapas na sequência  que usei nessa sequência

- inicializei a lib

NFE_ ConfigGravarValor(xxx,yyy) - funcionou perfeitamente, configurei toda a lib sem apresentar nenhum problema

-NFE_ LimparLista - funcionou 

-NFE_ StatusServico() - quando usei esse comado apresentou o problema de falha na segmentação

 

obs: testeis quase todos os métodos da LibNFe e Boleto, e alguns apresentaram falha na segmentação, mais na resposta preferi apresentar um para ver se estou no caminho certo.

desde já obrigado a equipe.


Jamil Santos de Araújo

Engenheiro de sistemas /  Tec. Contabil

Email.: [email protected]     Skype.: jamilaraujo

Share this post


Link to post
Share on other sites
23 horas atrás, jamil disse:

obs: testeis quase todos os métodos da LibNFe e Boleto, e alguns apresentaram falha na segmentação, mais na resposta preferi apresentar um para ver se estou no caminho certo.

desde já obrigado a equipe.

Boa tarde Jamil, 

Veja em anexo, executei um teste compilando a lib ACBrNFe em Java, funcionado corretamente a comunicação com WebService... Ou seja, a lib ( ACBrNFe32.dll ou ACBrNFe64.dll ) é a mesma, o problema está no processo de consumir a lib pela sua aplicação...

Qual o erro gerado no arquivo de Log que acompanha a Lib? Se possível anexe o log e trecho do código onde realiza a chamada do método pela sua aplicação e obtem a resposta, para que possamos tentar te ajudar com esse erro...

image.png

  • Like 1

Consultor SAC ACBr

José Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites
Em 21/11/2019 at 12:23, José M. S. Junior disse:

Boa tarde Jamil, 

Veja em anexo, executei um teste compilando a lib ACBrNFe em Java, funcionado corretamente a comunicação com WebService... Ou seja, a lib ( ACBrNFe32.dll ou ACBrNFe64.dll ) é a mesma, o problema está no processo de consumir a lib pela sua aplicação...

Qual o erro gerado no arquivo de Log que acompanha a Lib? Se possível anexe o log e trecho do código onde realiza a chamada do método pela sua aplicação e obtem a resposta, para que possamos tentar te ajudar com esse erro...

image.png

Bom Dia, @José M. S. Junior

Obrigado pela ajuda, segue conforme solicitado:

     _usu_:=_pastas+"acbrlib.ini"
     nfe:=ACBrNFe():New(_usu_, "")
     nfe:ConfigGravarValor("Principal", "LogPath", (_pastas) )
     nfe:ConfigGravarValor("Principal", "LogNivel", "4") // logParanoico     /2- normal
     
     //if(_inf_==.T.) //preenchimento completo 
        nfe:ConfigGravarValor("NFe", "Visualizar", "0")
        nfe:ConfigGravarValor("NFe", "FormaEmissao", "0")
        nfe:ConfigGravarValor("NFe", "SalvarGer", "1")
        nfe:ConfigGravarValor("NFe", "ExibirErroSchema", "1")
        nfe:ConfigGravarValor("NFe", "RetirarEspacos", "0")
        nfe:ConfigGravarValor("NFe", "ValidarDigest", "0")
        nfe:ConfigGravarValor("NFe", "IdCSC", cad_emp->(alltrim(ep_nfctkn)))
        nfe:ConfigGravarValor("NFe", "CSC", cad_emp->(alltrim(ep_nfccsc)) )
        
        nfe:ConfigGravarValor("NFe", "VersaoDF", cad_emp->(ep_nfever))
        nfe:ConfigGravarValor("NFe", "VersaoQRCode",cad_emp->ep___qrvs)
        nfe:ConfigGravarValor("NFe", "CamposFatObrigatorios", "1")
        nfe:ConfigGravarValor("NFe", "TagNT2018005", "3")
        nfe:ConfigGravarValor("NFe", "Ambiente", if(cad_ecf->im_ambt=="1","0","1"))
        nfe:ConfigGravarValor("NFe", "SSLType", "5")
        nfe:ConfigGravarValor("NFe", "PathSalvar", _pastas+"danfe") // analizar novo armazenamento
        nfe:ConfigGravarValor("NFe", "PathSchemas", "/mnt/simm/config/schemas/NFe")
        nfe:ConfigGravarValor("NFe", "IniServicos", "/mnt/simm/config/cfg/ACBrNFeServicos.ini")
        nfe:ConfigGravarValor("NFe", "SalvarArq", "1")
        nfe:ConfigGravarValor("NFe", "AdicionarLiteral", "1")
        nfe:ConfigGravarValor("NFe", "SepararPorCNPJ", "0")
        nfe:ConfigGravarValor("NFe", "SepararPorMes", "1")
        nfe:ConfigGravarValor("NFe", "SalvarEvento", "1")
        nfe:ConfigGravarValor("NFe", "SalvarApenasNFeProcessadas", "1")
        nfe:ConfigGravarValor("NFe", "PathNFe",_pastas+"danfe")
        nfe:ConfigGravarValor("NFe", "PathInu",_pastas+"inutil")
        nfe:ConfigGravarValor("NFe", "Download.PathDownload", _pastas+"dfe")
        nfe:ConfigGravarValor("NFe", "PathEvento", _pastas+"arqs")
        //nfe:ConfigGravarValor("NFe", "IdCSRT", "") //Define o id do responsável técnico.
        //nfe:ConfigGravarValor("NFe", "CSRT", "") //Define o CSRT do responsável técnico.

        nfe:ConfigGravarValor("DFe", "SSLCryptLib", "1")
        nfe:ConfigGravarValor("DFe", "SSLHttpLib", "3")
        nfe:ConfigGravarValor("DFe", "SSLXmlSignLib", "4")

        nfe:ConfigGravarValor("DANFE", "MostraSetup", "0")
        nfe:ConfigGravarValor("DANFE", "MostraPreview", "0")
        nfe:ConfigGravarValor("DANFE", "MostraStatus", "0")

        nfe:ConfigGravarValor("DANFE", "PathPDF",_pastas+"pdf") //"
        
        _lgc_:="/mnt/simm/config/logos/empresas/"+alltrim(cad_emp->ep___logo)
        nfe:ConfigGravarValor("DANFE", "PathLogo", if(cad_emp->ep___sist=="S",_lgc_,"") )
        nfe:ConfigGravarValor("DANFE", "MargemInferior", "0.70")
        nfe:ConfigGravarValor("DANFE", "MargemSuperior", "0.70")
        nfe:ConfigGravarValor("DANFE", "MargemEsquerda", "0.70")
        nfe:ConfigGravarValor("DANFE", "MargemDireita", "0.70")
        nfe:ConfigGravarValor("DANFE", "CasasDecimais.qCom", "2")
        
        nfe:ConfigGravarValor("DANFE", "TipoDANFE", "1")
        nfe:ConfigGravarValor("DANFE", "ExibeInforAdicProduto", "1")
        nfe:ConfigGravarValor("DANFE", "QuebraLinhaEmDetalhamentos", "1")

        nfe:ConfigGravarValor("DANFENFe", "FormularioContinuo", "0")
        nfe:ConfigGravarValor("DANFENFe", "ImprimeValor", "1")
        nfe:ConfigGravarValor("DANFENFe", "ImprimeDescPorPercentual", "1")
        nfe:ConfigGravarValor("DANFENFe", "PosCanhoto", "0")
        nfe:ConfigGravarValor("DANFENFe", "ExibeCampoFatura", "1")
        nfe:ConfigGravarValor("DANFENFe", "ExibeDadosISSQN", "0")
        nfe:ConfigGravarValor("DANFENFe", "LarguraCodProd", "60")
        nfe:ConfigGravarValor("DANFENFe", "ExibeEAN", "0")
        nfe:ConfigGravarValor("DANFENFe", "Fonte.Nome", "1")
        nfe:ConfigGravarValor("DANFENFe", "Fonte.Negrito", "0")
        nfe:ConfigGravarValor("DANFENFe", "Fonte.TamanhoFonteRazaoSocial", "10")
        nfe:ConfigGravarValor("DANFENFe", "Fonte.TamanhoFonteEndereco", "8")
        nfe:ConfigGravarValor("DANFENFe", "Fonte.TamanhoFonteDemaisCampos", "8")
        
        nfe:ConfigGravarValor("DANFENFCe", "TipoRelatorioBobina", "1") //Define o tipo de impressão da NFCe.
        nfe:ConfigGravarValor("DANFENFCe", "ImprimeDescAcrescItem", "0")
        nfe:ConfigGravarValor("DANFENFCe", "ImprimeItens", "0")
        nfe:ConfigGravarValor("DANFENFCe", "vTroco", "1")
        nfe:ConfigGravarValor("DANFENFCe", "ImprimeQRCodeLateral", cad_ecf->im_qrlc)
        nfe:ConfigGravarValor("DANFENFCe", "ImprimeLogoLateral", "1")
        nfe:ConfigGravarValor("DANFENFCe", "EspacoFinal", "4")
        //   nfe:ConfigGravarValor("DANFENFCe", "TamanhoLogoHeight", "")
        //   nfe:ConfigGravarValor("DANFENFCe", "TamanhoLogoWidth", "")
     //elseif(_inf_==.F.)
        nfe:ConfigGravarValor("NFe", "ModeloDF", if(__tip==1,0,1)) 
        nfe:ConfigGravarValor("DANFE", "Impressora", VrfImprFiscal(cad_ecf->im_nfci,1,.F.,val(cad_ecf->im_base)) )
        nfe:ConfigGravarValor("DANFE", "CasasDecimais.vUnCom", if(empty(cad_ecf->im_decm),"2",cad_ecf->im_decm) )
        nfe:ConfigGravarValor("DANFENFCe", "TipoRelatorioEvento", "1") //0-A4 / 1-Bobina
        _cmh_:="/mnt/simm/config/certificado/"+alltrim(cad_emp->ep___mode)
        _snh_:=alltrim(cad_emp->ep___senh)
        nfe:ConfigGravarValor("DFe", "ArquivoPFX", _cmh_) 
        nfe:ConfigGravarValor("DFe", "Senha", _snh_)
        nfe:ConfigGravarValor("DFe", "UF", cad_emp->(ep_estado))
         _x_:=cad_par->pr_ecftra
        _x__:=if(_x_=="S","-02:00",if(_x_=="X","",""))
        nfe:ConfigGravarValor("DFe", "TimeZone.Modo", if(_x__=="","0","2"))
        nfe:ConfigGravarValor("DFe", "TimeZone.Str", _x__)
     //endif
     
     nfe:ConfigGravar(_usu_)
     nfe:LimparLista()

     //ate aqui sem apresentar erros
     

    nfe:StatusServico()

   
     nfe:=nil
 

 

 o Metodo, StatusServico(),  é executado com sucesso, acho que o problema está no retorno que ele tras

     esse retorno da função deve esta causando conflito com C++ (ou seja, ao invéz de retornar

     um texto com a mensagem da WEB esta retornado uma tela Gráfica com a mensagem....), me desculpem se não soube me explicar bem,

porem foi o que pude observar utilizando alguns Metodo que apresentam a Falha.

 

mais uma vez obrigado pela ajuda.

 


     

 

acbrlib.ini ACBrLibNFE-20191123.log 20191123080849-ped-sta.xml


Jamil Santos de Araújo

Engenheiro de sistemas /  Tec. Contabil

Email.: [email protected]     Skype.: jamilaraujo

Share this post


Link to post
Share on other sites

Olá @jamil...

Muito obrigado pelas informações... Baseado no seu post, estive olhando a classe definida em ACBrNFe.prg

http://svn.code.sf.net/p/acbr/code/trunk2/Projetos/ACBrLib/Demos/Harbour/NFe/ACBrNFe.prg

METHOD StatusServico() CLASS ACBrNFe
    local hResult, buffer, bufferLen
    bufferLen := STR_LEN
    buffer := Space(bufferLen)
    hResult := DllCall(::hHandle, DLL_OSAPI, "NFE_StatusServico", @buffer, @bufferLen)
    ::CheckResult(hResult)
    RETURN ::ProcessResult(buffer, bufferLen)

Estou achando que o problema está na chamada abaixo:

ProcessResult(buffer, bufferLen)

pois aparentemente, essas variáveis deveriam ser passadas por referência... ou seja:

ProcessResult(@buffer, @bufferLen)

Por favor tente editar o ACBrNFe.prg, modificando todas as chamadas ao método ProcessResult, conforme mencionado acima

  • Thanks 1

Consultor SAC ACBr

Daniel Simões de Almeida
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites
3 horas atrás, Daniel Simoes disse:

Olá @jamil...

Muito obrigado pelas informações... Baseado no seu post, estive olhando a classe definida em ACBrNFe.prg

http://svn.code.sf.net/p/acbr/code/trunk2/Projetos/ACBrLib/Demos/Harbour/NFe/ACBrNFe.prg

METHOD StatusServico() CLASS ACBrNFe
    local hResult, buffer, bufferLen
    bufferLen := STR_LEN
    buffer := Space(bufferLen)
    hResult := DllCall(::hHandle, DLL_OSAPI, "NFE_StatusServico", @buffer, @bufferLen)
    ::CheckResult(hResult)
    RETURN ::ProcessResult(buffer, bufferLen)

Estou achando que o problema está na chamada abaixo:

ProcessResult(buffer, bufferLen)

pois aparentemente, essas variáveis deveriam ser passadas por referência... ou seja:

ProcessResult(@buffer, @bufferLen)

Por favor tente editar o ACBrNFe.prg, modificando todas as chamadas ao método ProcessResult, conforme mencionado acima

Boa Tarde @Daniel Simoes....

Fiz conforme me orientou, e o problema continua ....

 


Jamil Santos de Araújo

Engenheiro de sistemas /  Tec. Contabil

Email.: [email protected]     Skype.: jamilaraujo

Share this post


Link to post
Share on other sites

Tente inserir um BreakPoint para Debug no inicio de

METHOD StatusServico() CLASS ACBrNFe

 precisamos saber qual linha exata o problema ocorre...

  • Like 2

Consultor SAC ACBr

Daniel Simões de Almeida
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites
Em 25/11/2019 at 10:10, Daniel Simoes disse:

Tente inserir um BreakPoint para Debug no inicio de

METHOD StatusServico() CLASS ACBrNFe

 precisamos saber qual linha exata o problema ocorre...

Obrigado mais uma vez pelo empenho ,

segue o número da linha que me aparece conforme solicitado na LIbNFe: 9447

estou usando a última atualização desta Lib

Edited by jamil

Jamil Santos de Araújo

Engenheiro de sistemas /  Tec. Contabil

Email.: [email protected]     Skype.: jamilaraujo

Share this post


Link to post
Share on other sites
9 horas atrás, jamil disse:

segue o número da linha que me aparece conforme solicitado na LIbNFe: 9447

Não compreendi... o ACBrNFe.prg, tem apenas 378 linhas...

Se possível envie um PrintScreen do seu Debug


Consultor SAC ACBr

Daniel Simões de Almeida
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites
Em 28/11/2019 at 20:04, Daniel Simoes disse:

Não compreendi... o ACBrNFe.prg, tem apenas 378 linhas...

Se possível envie um PrintScreen do seu Debug

image.thumb.png.53f65a0c90f7259ae2d8104b9acce157.png

Desculpa a demora,

se eu prosseguir, ai ocorre o problema.....


Jamil Santos de Araújo

Engenheiro de sistemas /  Tec. Contabil

Email.: [email protected]     Skype.: jamilaraujo

Share this post


Link to post
Share on other sites

Você não consegue fazer um "StepInto" ou seja, deixar o Debug entrar no código desse método?

  • Like 1

Consultor SAC ACBr

Daniel Simões de Almeida
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites
Em 06/12/2019 at 11:25, Daniel Simoes disse:

Você não consegue fazer um "StepInto" ou seja, deixar o Debug entrar no código desse método?

image.thumb.png.964b8c31445e645a9f3c4a1d941da711.png

Aparentemente o problema ocorre sempre na hora de finalizar o método.


Jamil Santos de Araújo

Engenheiro de sistemas /  Tec. Contabil

Email.: [email protected]     Skype.: jamilaraujo

Share this post


Link to post
Share on other sites

×
×
  • Create New...