Jump to content

110.png

Curso Gratuito para todos Usuários
+ Super Treinamento Assinando o SAC Anual

botao_campanha_thulio.png

sem_ttulo-620.fw_-e1583866078274.png 

Curso Dominando o ACBrMonitor
Novo Módulo Soluções de Varejo
Assine o SAC ACBr em qualquer plano e tenha acesso

Saiba Mais

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba Mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

Cleiver

ANSWERED NFC-e - MG Retorno de Consulta

Recommended Posts

Boa tarde Ítalo, 

fazendo testes em homologação descobri um erro na rotina .

No envio da nota fiscal série 55 ele tambem exclui o NameSpace.

 

na função anterior do nosso amigo Cleiver, ela fica dentro do  if ((FPConfiguracoesNFe.Geral.ModeloDF = moNFCe) or (FVersaoDF >= ve310)) and FSincrono then

e na sua rotina esta antes, assim ele executa no modo moNFE.

Share this post


Link to post
Share on other sites
Agora, johnbh3 disse:

Alguém esta conseguindo inutilizar o NFCe?

Fiz várias inutilizações agora a pouco sem problema.

Segue código

    DM1.ACBrNFe1.WebServices.Inutiliza(DM1.TB99100CNPJ.Value, EdtJust.Text, StrToInt(ComboAno.Text), 65, StrToInt(ComboSerie.Text),
      StrToInt(EdtNumero.Text), StrToInt(EdtNumero.Text));
    if DM1.ACBrNFe1.WebServices.Inutilizacao.cStat = 102 then
       // insira seu codigo aqui

 


Rodrigo Cardilo

Card System Info

[email protected]

Share this post


Link to post
Share on other sites
4 minutos atrás, johnbh3 disse:

Alguém esta conseguindo inutilizar o NFCe?

Aqui o sistema está inutilizando, porém os retornos estão com o mesmo problema nas tags. Assim o sistema não entende o retorno.

Share this post


Link to post
Share on other sites

Comigo da erros!
As vezes responde, as vezes responde: Já existe pedido de Inutilização com a mesma faixa de inutilização
Quando retorna que já foi inutilizado eu concluo.

Mas e necessário algumas tentativas pra obter retorno. Acusa dezena de erro pra obter tal resposta.

E não retorna nenhum erro. 
Mesmo trantando no on E:Exception

Edited by johnbh3

Share this post


Link to post
Share on other sites

Outro detalhe o webservice pra inutilizar tem dado erros.
Mas com algumas tentativas, ele responde!

Mas retorna como 563-Já existe pedido de Inutilização com a mesma faixa de inutilização
Fui no site do estado pra consultar documentos inutilizados - http://nfce.fazenda.mg.gov.br/portalnfce/sistema/consultainutilizacao.xhtml

A inutilização consta ! A meu ver o werservice deveria retornar 206: NF-e já está inutilizada na Base de dados da SEFAZ
Mas ele estranhamente retorna 563.

a Inutilização não esta funcionando 100%

Share this post


Link to post
Share on other sites
1 minuto atrás, josadac disse:

Olá Ítalo,

Sobre essa tua mudança, terei que substituir esse arquivo .pas nos fontes e recop

Amigo,

Substitua na pasta Acbr\Fontes\ACBrDFe\ACBrNFe. O ideal é apagar a pasta Acbr/Lib e rodar o ACBrInstall_Trunk2.exe novamente e compilar tudo.

Aqui deu certinho.

  • Like 1

Rodrigo Cardilo

Card System Info

[email protected]

Share this post


Link to post
Share on other sites
3 horas atrás, Italo Jurisato Junior disse:

Boa tarde a todos,

Favor testarem com a unit em anexo.

ACBrNFeWebServices.pas 124 kB · 23 downloads

Olá Ítalo,

Sobre essa alteração, terei que substituir esse arquivo .pas na pasta fontes do ACBr e recompilar ?

Se for, não terei condição, estou no cliente fora da minha cidade, 

 

3 minutos atrás, Rodrigo Cardilo disse:

Amigo,

Substitua na pasta Acbr\Fontes\ACBrDFe\ACBrNFe. O ideal é apagar a pasta Acbr/Lib e rodar o ACBrInstall_Trunk2.exe novamente e compilar tudo.

Aqui deu certinho.

Perfeito Rodrigo, 

Como disse acima, estou sem condição de recompilar.

 

Será que a partir de amanhã normaliza ?

Meu cliente precisará iniciar a emissão da NFCe.

 

Share this post


Link to post
Share on other sites

Bom dia Pessoal,

Continuo com problema no retorno do envio da NFCe em Homologação, tanto na Forma de Emissão, teNormal quanto teOffline, conforme abaixo.

01/10/2019 08:39:30 - OK: C:\zando\NFE\XML\31191018580456000133650080000000049049862987-nfe.xml
01/10/2019 08:39:52 - NFe.EnviarNFe(C:\zando\NFE\XML\31191018580456000133650080000000049049862987-nfe.xml,1,0)
01/10/2019 08:39:52 - OK: 
[Envio]
CStat=0
CUF=0
Msg=
NRec=
TMed=0
VerAplic=
Versao=4.00
XMotivo=
tpAmb=1

 

A única solução, no momento, será mesmo substituindo a unit, conforme acima ?

Grato.

Josadac

 

Share this post


Link to post
Share on other sites
1 hora atrás, josadac disse:

Bom dia Pessoal,

Continuo com problema no retorno do envio da NFCe em Homologação, tanto na Forma de Emissão, teNormal quanto teOffline, conforme abaixo.

01/10/2019 08:39:30 - OK: C:\zando\NFE\XML\31191018580456000133650080000000049049862987-nfe.xml
01/10/2019 08:39:52 - NFe.EnviarNFe(C:\zando\NFE\XML\31191018580456000133650080000000049049862987-nfe.xml,1,0)
01/10/2019 08:39:52 - OK: 
[Envio]
CStat=0
CUF=0
Msg=
NRec=
TMed=0
VerAplic=
Versao=4.00
XMotivo=
tpAmb=1

 

A única solução, no momento, será mesmo substituindo a unit, conforme acima ?

Grato.

Josadac

 

Bom dia,

 

aqui substitui e deu certo.

Reinstalei os componentes pelo ACBrInstall e voltou tudo ao normal

  • Like 1

Cleber C. Ferreira
Analista de Sistemas e Consultor
Email e
Skype: [email protected]
Formiga-MG

Share this post


Link to post
Share on other sites
17 horas atrás, Rodrigo Cardilo disse:

Amigo,

Substitua na pasta Acbr\Fontes\ACBrDFe\ACBrNFe. O ideal é apagar a pasta Acbr/Lib e rodar o ACBrInstall_Trunk2.exe novamente e compilar tudo.

Aqui deu certinho.

Olá Cleber,

Ainda não faço parte do SAC, compilo pelo Lazarus.

- Vc disse que reinstalou os componentes pelo ACBrInstall e voltou tudo ao normal 

- Fiz conforme o Rodrigo, só que ao executar o ACBrInstall_Trunk2.exe, retornou uma msg dizendo que é apenas para os usuários do SAC.

Será que seu apenas substituir a unit nos fontes e recompilar funciona ?

Grato.

 

Share this post


Link to post
Share on other sites
9 minutos atrás, josadac disse:

Olá Cleber,

Ainda não faço parte do SAC, compilo pelo Lazarus.

- Vc disse que reinstalou os componentes pelo ACBrInstall e voltou tudo ao normal 

- Fiz conforme o Rodrigo, só que ao executar o ACBrInstall_Trunk2.exe, retornou uma msg dizendo que é apenas para os usuários do SAC.

Será que seu apenas substituir a unit nos fontes e recompilar funciona ?

Grato.

 

Não precisa ser usuário do SAC para fazer isso. o acbrInstall está disponível para todos. Quando vc baixa usando o svn ele vem junto.

  • Like 1

Rodrigo Cardilo

Card System Info

[email protected]

Share this post


Link to post
Share on other sites
23 horas atrás, Italo Jurisato Junior disse:

Boa tarde a todos,

Favor testarem com a unit em anexo.

ACBrNFeWebServices.pas 124 kB · 41 downloads

@Italo Jurisato Junior, essa correção é temporária?

Alguém já conseguiu uma resposta da SEFAZ-MG sobre esse comportamento do servidor?

Sabem se realmente é algum erro?

Share this post


Link to post
Share on other sites
1 hora atrás, Rodrigo Cardilo disse:

Não precisa ser usuário do SAC para fazer isso. o acbrInstall está disponível para todos. Quando vc baixa usando o svn ele vem junto.

Certo Rodrigo,

Ao executar o ACBrInstall_Trunk2.exe, emite a seguinte mensagem, print em anexo, teclando ok, dai aparece a tela do ACBr, print2.

Só para saber se posso prosseguir.

Vai tendo paciência comigo ai pessoal, esto preocupado, a empresa teria que começar emitir NFCe hoje.

Grato.

Print.jpg

Print2.jpg

Share this post


Link to post
Share on other sites

Recebi o seguinte retorno da Sefaz de MG na quinta-feira, dia 26 sobre esse problema, mas a Sefaz ainda esta com problemas:

"Senhores contribuintes, boa tarde!
A STI já detectou o problema e está trabalhando na solução do mesmo. Orientamos aos contribuintes que, em caso de dificuldade na autorização do documento eletrônico, utilizem a contingência."

 

Estava esperando que a Sefaz corrigisse o problema mas como estão demorando muito vou utilizar as alterações sugeridas pelo Ítalo.

Aqui o problema ainda estava acontecendo na Inutilização de NFC-e, fiz uma alteração no arquivo do Ítalo para corrigir o retorno da Sefaz também para a função TNFeInutilizacao.TratarResposta

ACBrNFeWebServices.pas

Edited by Rodrigo Sidney
  • Thanks 1

Share this post


Link to post
Share on other sites
Agora, josadac disse:

Certo Rodrigo,

Ao executar o ACBrInstall_Trunk2.exe, emite a seguinte mensagem, print em anexo, teclando ok, dai aparece a tela do ACBr, print2.

Só para saber se posso prosseguir.

Vai tendo paciência comigo ai pessoal, esto preocupado, a empresa teria que começar emitir NFCe hoje.

Grato.

Print.jpg

Print2.jpg

Rapaz, depois do primeiro erro não consegue continuar? Não tenho experiência no Lazarus pra te ajudar.


Rodrigo Cardilo

Card System Info

[email protected]

Share this post


Link to post
Share on other sites

Então, estou com essa dúvida.

24 minutos atrás, Leonardo de Alice disse:

@Italo Jurisato Junior, essa correção é temporária?

Alguém já conseguiu uma resposta da SEFAZ-MG sobre esse comportamento do servidor?

Sabem se realmente é algum erro?

Meu questionamento é o mesmo do Leonardo aí.

Não estou tendo retorno da SEFAZ-MG sobre esse problema, alguém aí sabe dizer alguma previsão ?

Share this post


Link to post
Share on other sites
52 minutos atrás, Rodrigo Cardilo disse:

Rapaz, depois do primeiro erro não consegue continuar? Não tenho experiência no Lazarus pra te ajudar.

Pelo visto o ACBrInstall_Trunk2.exe é só para quem utiliza Delphi.

Alguém me confirma ?

 

20 horas atrás, Rodrigo Cardilo disse:

Amigo,

Substitua na pasta Acbr\Fontes\ACBrDFe\ACBrNFe. O ideal é apagar a pasta Acbr/Lib e rodar o ACBrInstall_Trunk2.exe novamente e compilar tudo.

Aqui deu certinho.

Segui essa orientação, só não deu certo a execução do ACBrInstall pelo motivo relatado acima.

Não funcionou, continua retornando o seguinte:

01/10/2019 11:09:51 - OK: C:\zando\NFE\XML\31191018580456000133650080000000041049862981-nfe.xml
01/10/2019 11:10:11 - NFe.EnviarNFe(C:\zando\NFE\XML\31191018580456000133650080000000041049862981-nfe.xml,1,0)
01/10/2019 11:10:11 - OK: 
[Envio]
CStat=0
CUF=0
Msg=
NRec=
TMed=0
VerAplic=
Versao=4.00
XMotivo=
tpAmb=1

Edited by josadac

Share this post


Link to post
Share on other sites
8 minutos atrás, josadac disse:

Pelo visto o ACBrInstall_Trunk2.exe é só para quem utiliza Delphi.

Alguém me confirma ?

Sim.

Pra quem usa o ACBrMonitorPLUS foi disponibilizada uma versão especial:

 

  • Like 2

Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Share this post


Link to post
Share on other sites
15 minutos atrás, BigWings disse:

Sim.

Pra quem usa o ACBrMonitorPLUS foi disponibilizada uma versão especial:

 

Ok Bingwings,

Tentei fazer o download que o José disponibilizou, mas acho é só para quem faz parte do SAC.

É isso mesmo ?

Segue o print do retorno.

 

print.jpg

Edited by josadac

Share this post


Link to post
Share on other sites

Boa tarde Pessoal,

Fiz como o Ítalo orientou, baixei os fontes, recompilei e deu certo.

Muito obrigado a todos pela atenção.

Gratio,

Josadac

Edited by josadac
  • Like 1

Share this post


Link to post
Share on other sites

Também tentei fazer esse download, mas não funcionou. Até tentei compilar, mas ai fica dando muito erro , falta de dlls,  e por último deu ate ERRO: Access violation

Fico esperando a Sefaz corrigir, ou o projeto disponibilizar uma versão para o público geral.

 

Share this post


Link to post
Share on other sites

Boa noite Pessoal quem usa ACBrMonitorPlus 
Coloque um Executável que vai corrigir as tags de retorno de Minas Gerais 

Site: www.rhsolucoes.adm.br

no menu Acesso Remoto, na caixa de dialogo Utilitários

Espero ter ajudado  

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...