Jump to content

dev botao

Problema Emai.Novo


Go to solution Solved by José M. S. Junior,
  • Este tópico foi criado há 1754 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Membros Pro

Boa tarde,

Utilizamos o ACBRMonitorPlus para emitir NFe e Boleto.

Configuramos o e-mail direto no ACBRMonitorPlus.

Nosso cliente pediu para colocarmos um e-mail para enviar NFe e outro para enviar Boleto.

Criei o metodo Email.Novo para configurar os e-mails, mas o mesmo não funciona. Ele mante o e-mail configurado no ACBRMonitorPlus.

Como resolver esse prolema?

Att,

Carlos

Link to comment
Share on other sites

  • Fundadores

Você precisa de vários comandos para compor um novo e-mail... Veja um exemplo na documentação:

https://acbr.sourceforge.io/ACBrMonitor/ComandosdoObjetoEMAIL.html

https://acbr.sourceforge.io/ACBrMonitor/EMAILNovo.html

Consultor SAC ACBr

Daniel Simões de Almeida
O melhor TEF, é com o Projeto ACBr - Clique e Conheça
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

  • Membros Pro

Eu fiz exatamente todos os comandos acima. O e-mail foi enviado perfeitamente, mas como meu cliente quer um e-mail ( endereço de e-mail remetente ) para cada função, estou com problema de configurar o e-mail via comando por arquivo texto, pois ele sempre envia com o e-mail previamente cadastrado no ACBRMonitorPlus.

 

Link to comment
Share on other sites

  • Membros Pro

EMAIL.Novo("c:\temp\confmail.ini" )
OK: Novo E-mail iniciado!
EMAIL.ConfirmarLeitura(True)
OK: 
EMAIL.AdicionaPara("[email protected]")
OK: E-mail [email protected] adicionado a lista "Para".
EMAIL.Assunto("Teste de e-mail")
OK: 
EMAIL.TextoMensagem("Veja anexo!")
OK: 
EMAIL.AdicionaAnexo("C:\tempo\precompra.pdf")
ERRO: Add Attachment: File not Exists.
EMAIL.AdicionaAnexo("C:\tempo\pedcompra.pdf")
OK: Anexo inclu?do com sucesso!
EMAIL.Enviar

Email: Iniciando processo de envio.
Email: Configurando o cabeçalho do e-mail.
Email: Logando no servidor de e-mail.
Email: Iniciando os envios.
Email: Processando lista de destinatários.
Email: Enviando dados.
Email: Fazendo Logout no servidor de e-mail.
Email: Enviado com sucesso
OK: E-mail enviado com sucesso!

 

Arquivo confmail.ini


[email protected]
[email protected]
Email=smtp.office365.com
[email protected]
Senha=************
Porta=587
ExigeSSL=0
ExigeTLS=1

 

O problema que o e-mail remetente foi ainda o [email protected], que estava cadastrado anteriormente.

 

Link to comment
Share on other sites

  • Moderadores
  • Solution

Bom dia
Carlos, não consegui simular esse tipo de problema... No seu arquivo .ini você está passando a seção EMAIL, conforme descrito no manual? 

Pois apenas se o Monitor não encontrar valor na leitura das tags será utilizada as configurações default configuradas em tela....

Outro detalhe é que se deseja utilizar uma configuração de e-mail diferente da cadastrada, precisa passar essa informação a cada comando email.novo(".ini") enviado, pois essa informação será utilizada para envio mas não ficara gravada para um próximo envio.

Se o problema persistir, por favor anexe o log completo do ACBrMonitor e o  seu arquivo .ini (remova o campo senha)

 

Edited by EMBarbosa
Remoção dos links
  • Like 1
Consultor SAC ACBr

José Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.