Jump to content

Não salva o PDF da NFe no local indicado


Marcos Bordin
  • Este tópico foi criado há 1027 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Boa tarde!

Atualizei o ACBR hoje e notei que não está salvando o pdf no local indicado.

Eu passo para a propriedade ACBrNFe1.DANFE.PathPDF o mesmo caminho do xml, porém o pdf está gerando na raiz desse diretório.

Eu notei que mesmo passando ACBrNFe1.DANFE.PathPDF := F:\NFE-Saidas ao passar por essa linha o valor de PathPDF aparece apenas o F:\ .

Em outra máquina que atualizei semana passada, funciona normalmente.

 

 

Link to comment
Share on other sites

  • Consultores

as configurações de separar por pasta podem estar influenciando

  • Like 1
Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

 

Link to comment
Share on other sites

19 horas atrás, Marcos Bordin disse:

Boa tarde!

Atualizei o ACBR hoje e notei que não está salvando o pdf no local indicado.

Eu passo para a propriedade ACBrNFe1.DANFE.PathPDF o mesmo caminho do xml, porém o pdf está gerando na raiz desse diretório.

Eu notei que mesmo passando ACBrNFe1.DANFE.PathPDF := F:\NFE-Saidas ao passar por essa linha o valor de PathPDF aparece apenas o F:\ .

Em outra máquina que atualizei semana passada, funciona normalmente.

 

 

Estou com o mesmo problema! Alguém sabe o motivo? xml salva normalmente apenas PDF esta salvando fora da pasta yyymm

Link to comment
Share on other sites

Bom dia, utilizo DELPHI RIO, e ontem ao atualizar o ACBrInstall_Trunk2.exe, passou a Salvar os .PDF na raiz junto com o executável da N.F.e, o mesmo acontece com o CTe, MDFe. Conferi que o acbrboleto continua como antes, salvando na pasta especificada no .PathPDF.

Atualize hoje novamente e o erro persiste....

ALGUÉM TEM UMA SOLUÇÃO ???????????

Link to comment
Share on other sites

Pessoal, o erro está no ..\Fontes\ACBrDFe\ACBrDFeReport.pas
foi alterado na revisão 17729 de:
procedure TACBrDFeReport.SetPathPDF(const Value: String);
begin
  FPathPDF := PathWithDelim(Trim(Value));
end;

para:

procedure TACBrDFeReport.SetPathPDF(const Value: String);
begin
  FPathPDF := PathWithDelim( ExtractFilePath(Trim(Value)) );
end;

 

Voltei e funcionou perfeitamente.

ACBrDFeReport.pas

Edited by Fernando Amado
  • Like 1
Link to comment
Share on other sites

  • Administradores

Bom dia.

Vejam este tópico por favor.

Att.

  • Like 1
Consultora SAC ACBr

Juliana Tamizou
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.  Discord

Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil


Participe de nosso canal no Discord e fique ainda mais próximo da Comunidade !!

Link to comment
Share on other sites

  • Administradores

Obrigado por reportar.

Fechando. Para novas dúvidas, criar um novo tópico.

Consultora SAC ACBr

Juliana Tamizou
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.  Discord

Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil


Participe de nosso canal no Discord e fique ainda mais próximo da Comunidade !!

Link to comment
Share on other sites

  • Este tópico foi criado há 1027 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.