Jump to content

click.png

click.png

click.png

click.png click.png click.png

click.png click.png click.png

click.png

click.png

click.png

click.png

click.png

click.png

erro quando tem icms


Armando Monteiro
Go to solution Solved by Rafael Dias,
  • Este tópico foi criado há 775 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Membros Pro

<?xml version="1.0"?><CFe><infCFe versaoDadosEnt="0.07"><ide><CNPJ>16716114000172</CNPJ><signAC>SGR-SAT SISTEMA DE GESTAO E RETAGUARDA DO SAT</signAC><numeroCaixa>030</numeroCaixa></ide><emit><CNPJ>27101611000182</CNPJ><IE>111111111111</IE><indRatISSQN>N</indRatISSQN></emit><dest><CPF></CPF></dest><det nItem="1"><prod><cProd>10</cProd><xProd>SAL DE GADO 25K</xProd><NCM>25010011</NCM><CFOP>5102</CFOP><uCom>UN</uCom><qCom>1.0000</qCom><vUnCom>16.90</vUnCom><indRegra>A</indRegra><vDesc>0.00</vDesc><vOutro>0.00</vOutro></prod><imposto><vItem12741>3.85</vItem12741><ICMS><ICMS00><Orig>0</Orig><CST>00</CST><pICMS>7.00</pICMS></ICMS00></ICMS><PIS><PISAliq><CST>01</CST><vBC>16.90</vBC><pPIS>0.0165</pPIS></PISAliq></PIS><COFINS><COFINSAliq><CST>01</CST><vBC>16.90</vBC><pCOFINS>0.0760</pCOFINS></COFINSAliq></COFINS></imposto></det><total><vCFeLei12741>3.85</vCFeLei12741></total><pgto><MP><cMP>01</cMP><vMP>16.90</vMP></MP></pgto><infAdic><infCpl>Opedador(a):ARMANDO
Obrigado, volte sempre</infCpl></infAdic></infCFe></CFe>

 

se envio direto com dll da bematech gera normalmente resp "015383|06000|0000|Emitido com sucesso + conteúdo notas|"

 

mas e envio o mesmo xml pelo componente ACBrSAT32.dll resp "408326|06010|1999|Erro desconhecido||"

 

 

 

 

cfe.xml ACBrLibSAT-20191010.log bemaSATlog_10-10-2019.xml

Link to comment
Share on other sites

  • Consultores

Olha eu consegui ler seu xml corretamente aqui na lib inclusive mandei regerar e o xml veio idêntico.

Vou tentar usar o demo do VB6 para ver se consigo reproduzir o erro.

Outra coisa como esta o xml de env para o aparelho esta diferente do xml que você mandou carregar ?

Teria como extrair o log do aparelho também ?

  • Like 1
Consultor SAC ACBr Rafael Dias
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Desenvolvedor ACBrLib.

 

Link to comment
Share on other sites

  • Membros Pro

mesmo teste

teste simples nacional funciona "<ICMS><ICMSSN102><Orig>0</Orig><CSOSN>400</CSOSN></ICMSSN102></ICMS>"

teste com icms não funciona "<ICMS><ICMS00><Orig>0</Orig><CST>00</CST><pICMS>7.00</pICMS></ICMS00></ICMS>"

 

em anexo todos os resultados

teste_com_icms.zip teste_simples_nacional.zip

Link to comment
Share on other sites

  • Membros Pro

baixei hj a ultima data 09-10-2019...baixei um teste2.ini e gerou o arquivo de envio...mas se vc pegar o xml criado e enviar da o mesmo erro.

Mas como já gero o xml de envio não quero criar uma rotina de arquivo.ini, mas com certeza é um erro da ACBrSAT32.dll quando tem icms

 

errox.jpg

AD20191010193939-025405-env.xml teste2.ini

Link to comment
Share on other sites

  • Membros Pro
15 horas atrás, Armando Monteiro disse:

baixei hj a ultima data 09-10-2019...baixei um teste2.ini e gerou o arquivo de envio...mas se vc pegar o xml criado e enviar da o mesmo erro.

Mas como já gero o xml de envio não quero criar uma rotina de arquivo.ini, mas com certeza é um erro da ACBrSAT32.dll quando tem icms

 

errox.jpg

AD20191010193939-025405-env.xml 1 kB · 0 downloads teste2.ini 1 kB · 0 downloads

Será que não vai ter solução????

Link to comment
Share on other sites

  • Membros Pro

[SATConfig]
infCFe_versaoDadosEnt=0,07
ide_CNPJ=
ide_numeroCaixa=1
ide_tpAmb=1
emit_CNPJ=27101611000182
emit_IE=16716114000172
emit_IM=111111111111
emit_cRegTrib=3
emit_cRegTribISSQN=0
emit_indRatISSQN=0
EhUTF8=0
PaginaDeCodigo=0
ArqSchema=
XmlSignLib=0

 

 

TESTEI COM  emit_cRegTrib=0 , emit_cRegTrib=1 , emit_cRegTrib=3

Link to comment
Share on other sites

  • Consultores
  • Solution

emit_cRegTrib só tem 0 e 1 como diz no manual

https://acbr.sourceforge.io/ACBrLib/ConfiguracoesdaBiblioteca17.html

No seu caso o correto seria 1.

Eu enviei uma outra versão da dll favor fazer o download da mesma ela deve corrigir este problema.

Realmente tinha um problema que so acontece quando carrega o xml e o mesmo não tem as informações padrões preenchidas, a lib não preenchia elas.

  • Like 1
Consultor SAC ACBr Rafael Dias
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Desenvolvedor ACBrLib.

 

Link to comment
Share on other sites

  • Consultores

Bom dia Armando.

 Você chegou a criar um tópico para esta outra situação? Se não penso que seria melhor criar, afim de evitar misturar os assuntos.

Att.

Consultora SAC ACBr

Juliana Tamizou
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.  Discord

Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil


Participe de nosso canal no Discord e fique ainda mais próximo da Comunidade !!

Link to comment
Share on other sites

  • Consultores

Boa tarde.

Qual é o tópico sobre o problema no QRCode?

Att.

Consultora SAC ACBr

Juliana Tamizou
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.  Discord

Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil


Participe de nosso canal no Discord e fique ainda mais próximo da Comunidade !!

Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.